3 Set up your project

3.1 Start FaceReader

IF YOU HAVE A HARDWARE KEY — 35
IF YOU HAVE SITE LICENSES — 35

3.2 Projects

WHAT IS A PROJECT? — 35
CREATE A NEW PROJECT — 36
BACK UP YOUR PROJECT — 37
THE PROJECT EXPLORER — 38

3.3 Add your test participants

ADD PARTICIPANTS AUTOMATICALLY — 39
ADD PARTICIPANTS MANUALLY — 39

3.4 Add analyses

ADD ANALYSES AUTOMATICALLY — 41
ADD ANALYSES MANUALLY — 41
CAMERA ANALYSIS — 43

3.5 Project wizard

WHY A PROJECT WIZARD? — 44
PROCEDURES — 45

4 Analyze facial expressions

4.1 Default and specific settings

DEFAULT ANALYSIS SETTINGS — 54
SETTINGS FOR THE CURRENT ANALYSIS — 55

4.2 Select a face model — 55

4.3 Analyze facial expressions

AUTOMATIC ANALYSIS PROCEDURE — 56
MANUAL PROCEDURE — 56
NOTES — 58

4.4 Optional classifications

CONTEMPT (EXPERIMENTAL) — 61
FACIAL STATES — 62
GLOBAL GAZE DIRECTION — 62
PERSON IDENTIFICATION — 63

4.5 Calibrate FaceReader

CREATE A PARTICIPANT CALIBRATION — 65
USE CONTINUOUS CALIBRATION — 67
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.4 Event markers</td>
<td>117</td>
</tr>
<tr>
<td>DEFINE EVENT MARKERS — 117</td>
<td></td>
</tr>
<tr>
<td>SCORE EVENT MARKERS — 118</td>
<td></td>
</tr>
<tr>
<td>6.5 Independent Variables</td>
<td>119</td>
</tr>
<tr>
<td>DEFINITION — 119</td>
<td></td>
</tr>
<tr>
<td>DEFINE INDEPENDENT VARIABLES — 119</td>
<td></td>
</tr>
<tr>
<td>SCORE INDEPENDENT VARIABLES — 120</td>
<td></td>
</tr>
<tr>
<td>6.6 Participant groups</td>
<td>121</td>
</tr>
<tr>
<td>DEFINE PARTICIPANT GROUPS — 121</td>
<td></td>
</tr>
<tr>
<td>DELETE OR EDIT A PARTICIPANT GROUP — 122</td>
<td></td>
</tr>
<tr>
<td>6.7 Numerical group analysis</td>
<td>122</td>
</tr>
<tr>
<td>ABSOLUTE VS RELATIVE ANALYSIS — 123</td>
<td></td>
</tr>
<tr>
<td>HOW RELATIVE STATISTICS ARE CALCULATED — 127</td>
<td></td>
</tr>
<tr>
<td>RESULT EXPORT AND CHARTS — 127</td>
<td></td>
</tr>
<tr>
<td>6.8 Temporal group analysis</td>
<td>130</td>
</tr>
<tr>
<td>PROCEDURE — 130</td>
<td></td>
</tr>
<tr>
<td>CHARTS — 131</td>
<td></td>
</tr>
<tr>
<td>6.9 Analysis advisor for project analysis</td>
<td>136</td>
</tr>
<tr>
<td>EXPRESSION INTENSITY; ENTIRE ANALYSIS — 136</td>
<td></td>
</tr>
<tr>
<td>COMPARE STIMULI WITH A NEUTRAL EPISODE — 139</td>
<td></td>
</tr>
<tr>
<td>THE PERCENTAGE OF EACH FACIAL EXPRESSION — 142</td>
<td></td>
</tr>
<tr>
<td>7 The Action Unit Module</td>
<td>143</td>
</tr>
<tr>
<td>7.1 Action Unit classification</td>
<td>144</td>
</tr>
<tr>
<td>7.2 Analyze Action Units</td>
<td>145</td>
</tr>
<tr>
<td>7.3 Action Units during the analysis</td>
<td>146</td>
</tr>
<tr>
<td>7.4 Action Units in the analysis output</td>
<td>146</td>
</tr>
<tr>
<td>ACTION UNIT INTENSITY — 146</td>
<td></td>
</tr>
<tr>
<td>ACTION UNIT STATES — 147</td>
<td></td>
</tr>
<tr>
<td>ACTION UNITS IN THE LOG FILES — 148</td>
<td></td>
</tr>
<tr>
<td>8 The Remote PPG Module</td>
<td>152</td>
</tr>
<tr>
<td>8.1 Introduction</td>
<td>153</td>
</tr>
<tr>
<td>REMOTE PPG — 153</td>
<td></td>
</tr>
<tr>
<td>REFERENCES — 153</td>
<td></td>
</tr>
<tr>
<td>THE REMOTE PPG MODULE — 154</td>
<td></td>
</tr>
</tbody>
</table>
8.2 Heart rate analysis .................................................................................................. 155
   HEART RATE WINDOW — 155
   HEART RATE LINE CHART — 156

9 USE FACEREADER WITH THE OBSERVER XT 158

9.1 FaceReader and The Observer XT ........................................................................... 159
   WHY USE FACEREADER IN COMBINATION WITH THE OBSERVER XT — 159

9.2 The Observer XT 13 .................................................................................................. 160
   EXCEPTIONS FOR N-LINX PORT IN WINDOWS FIREWALL (FOR TWO COMPUTER SETUP) — 161
   SETTINGS IN FACEREADER — 162
   SETTINGS IN THE OBSERVER XT — 164
   CREATE A MAPPED DRIVE FOR THE FOLDER WITH VIDEOS (FOR TWO COMPUTER SETUP) — 167
   OBSERVE IN THE OBSERVER XT AND ANALYZE IN FACEREADER — 170
   HOW FACEREADER DATA ARE IMPORTED INTO THE OBSERVER XT 13 — 170
   IMPORTANT NOTES — 172

9.3 With The Observer XT 12.5 or lower ....................................................................... 173
   SETTINGS IN FACEREADER — 173
   SETTINGS IN THE OBSERVER XT — 173
   OBSERVE IN THE OBSERVER XT AND ANALYZE IN FACEREADER — 176
   EXPORT FACEREADER LOG FILES — 176
   IMPORT FACEREADER LOG FILES AS OBSERVATIONAL DATA — 177
   IMPORT DETAILED LOGS AS EXTERNAL DATA — 179

9.4 Visualize FaceReader data in The Observer XT ...................................................... 182
   STATE EXPRESSION VALUES — 182
   EVENT MARKERS AND STIMULI — 182
   FACIAL STATES AND GLOBAL GAZE DIRECTION — 183
   CONTINUOUS DATA — 183
   ACTION UNIT INTENSITIES AS CONTINUOUS DATA — 184
   ACTION UNITS AS OBSERVATIONAL DATA — 184
   DETAILED LOG AS OBSERVATIONAL DATA — 185
   VALENCE AND AROUSAL VALUES AS OBSERVATIONAL DATA — 185
   HEAD ORIENTATION AS OBSERVATIONAL DATA — 186
   DATA SELECTION AND STATISTICAL ANALYSIS — 186

9.5 The Observer XT sample projects with FaceReader data ....................................... 187

10 SETTINGS 188

10.1 General settings ...................................................................................................... 190
   LICENSE — 190
   PROJECT EXPLORER — 190
   PROJECT INFORMATION — 191
10.2 Default Analysis Settings ................................................................. 191
  ACTIVE FACE MODEL — 191
  CALIBRATION — 192
  CLASSIFICATION — 192
  ROTATION — 192
  VIDEO — 193

10.3 Analysis options ............................................................................... 194
  BATCH ANALYSIS — 194
  CAMERA ANALYSIS — 194
  OPTIONAL CLASSIFICATIONS — 195

10.4 Identification .................................................................................... 196
  BASIC SETTINGS — 196
  FINETUNE SETTINGS — 196

10.5 Data Export ....................................................................................... 198
  EXTERNAL COMMUNICATION (API AND STIMULUS PRESENTATION TOOL) — 198
  EXTERNAL COMMUNICATION (N-LINX) — 199
  EXPORT (DETAILED LOG, ODX, N-LINX AND API) — 200

10.6 Visualization ..................................................................................... 202
  VIDEO — 202

10.7 Reporting Client ................................................................................ 203
  DISPLAY STYLE — 203
  TIMING — 203

10.8 Site license ...................................................................................... 204
  SITE LICENSE — 204

10.9 Advanced options ............................................................................ 205
  ADVANCED SETTINGS PRESETS — 205
  ENGINE — 207
  FACE MODELING — 207
  SIZE OF INTEREST — 207

A VIDEO AND IMAGE FORMATS ............................................................ 209

A.1 Video formats .................................................................................. 210
  SUPPORTED VIDEO FORMATS — 210
  OTHER VIDEO FORMATS — 211
  PROJECT WIZARD — 212
  VIDEO LENGTH, DURATION AND NUMBER OF SAMPLES — 212

A.2 Image formats .................................................................................. 213
  SUPPORTED IMAGE FORMATS — 213
  PROJECT WIZARD — 213
Chapter 1

Introduction

1.1 An introduction to FaceReader
A general overview of how FaceReader works and what it does.

1.2 What’s new in FaceReader 7
1.1 An introduction to FaceReader

FaceReader is a program for facial analysis. It can detect emotional expressions in the face. It can identify six basic emotions: happy, sad, angry, surprised, scared, disgusted and a neutral state. Additionally, it can detect contempt (an expression in which one corner of the lips is tightened and slightly raised), facial states (left and right eye open or closed, mouth open or closed and eyebrows raised, neutral or lowered), the test participant’s global gaze direction and track the head orientation. FaceReader also analyzes the valence, which indicates whether the person’s emotional status is positive or negative, and arousal, which indicates how active the person is. FaceReader can also indicate the person’s gender, age, ethnicity, the amount of facial hair (beard and/or mustache) and whether the person is wearing glasses or not. The software can also identify the subject.

FaceReader data can be imported into The Observer XT, the leading software package for the collection, analysis and presentation of observational data. This enables you to integrate FaceReader data with other data, such as manually logged events, physiological data and eye tracker data and to analyze the full context. For instance, what user interface is the test participant looking at and what part triggers an emotion.

FaceReader can be used in a wide range of research areas:

- **Psychology** — How do people respond to particular stimuli, e.g. in cognitive research.
- **Education** — Observing students’ facial expressions can support the development of educational tools.
- **Human-computer interaction** — Facial expressions can provide valuable information about user experience.
- **Usability testing** — Emotional expressions can indicate the ease of use and efficiency of user interfaces.
- **Market research** — How do people respond to a new commercial’s design?
- **Consumer behavior** — How do participants in a sensory panel react to a presentation?
HOW DOES FACEREADER WORK?

FaceReader classifies facial expressions in several steps which is explained in Figure 1.1. Please see reference [1] - [3] on page 14 and the references mentioned in the text below for more information.

1. **Face finding** — The position of the face in an image is found using a method called the Viola Jones cascaded classifier algorithm, which was developed for finding the face in images [4].

2. FaceReader uses two methods that work side-by-side. In previous FaceReader versions, only the upper method (2a) was used. Using this method in combination with Deep face classification (2b), makes the analysis more reliable and robust.
   
   a **Face modeling and classification** — First, a model-based method is used, called the Active Appearance Model (AAM) [5], to synthesize an artificial face model, which describes the location of over 500 key points in the face and the facial texture of the area entangled by these points. The model uses a database of annotated images and calculates the main sources of variation found in the images. Principal Component Analysis compression is used to reduce the model dimensionality. New faces can then be described as deviations from the mean face, using a vector. Then, classification of the facial expressions is done by training an artificial neural network [6], which takes the above vector as input. As training material over 10000 manually annotated images were used. The network was trained to classify the six basic or universal emotions described by Ekman [7]: happy, sad, angry, surprised, scared, disgusted and a neutral state.

   b **Deep face classification** — FaceReader uses a deep artificial neural network to recognize patterns in the face [8]. With this method, FaceReader directly classifies the facial expressions from image pixels. So no face modeling is done. This has the advantage that FaceReader can analyze the face even if it is partly hidden. See also **What if face modeling fails?** on page 13.
3. **Creating output** — The output of methods 2a and 2b is combined to give the classification results.

**What if face modeling fails?**

Deep face classification (2b in Figure 1.1) is used side by side-by-side with face modeling (2a in Figure 1.1). It is used stand-alone when face modeling with method 2a fails, for example because part of the face is hidden. This is only possible when FaceReader can find the eyes. The following analyses can then be carried out:

- Facial expressions classification.
- Valence calculation.
- Arousal calculation.
- Action Unit classification (when your FaceReader license includes the Action Unit Module).
- Subject characteristics analysis.

**Validation**

Facial expression analysis of FaceReader 6.1 was validated with expressions scored by manual annotators. FaceReader 6.1 only contained the upper method from Figure 1.1 (steps 1, 2a, and 3). FaceReader 6.1 could analyze facial expressions with an accuracy of 95%. For some expressions the accuracy is higher, for others lower (Figure 1.2). In combination with the deep face classification, the accuracy will be even higher.
### References


---

![Figure 1.2: Proportion of agreement between the facial expressions scored manually by the annotators of the RadboudFaces Database (horizontally) and the expressions scored by FaceReader version 6.1 (vertically). Number in brackets display the number of images [9,10].](image)


**SAMPLE PROJECT**

The FaceReader installation USB stick contains an example project **FaceReader 7 sample project**. The pdf-file **Description of FaceReader 7 sample project** describes the features that you can view in the project.

**LIMITATIONS OF THE CURRENT VERSION**

The current FaceReader version has a number of limitations. It is good to keep these in mind when you start working with FaceReader.

- FaceReader is currently not trained to work with very young children, below the age of 3.
- FaceReader is not yet trained for analysis of children from East Asia and South-East Asia. FaceReader works well with other children and East Asian and South-east Asian adults.
- Glasses may hinder classification. Especially thick and dark frames can reduce performance significantly. It may be useful to have a number of rimless reading glasses available in a few strengths when you carry out a test. A polarization filter on the camera can help to avoid reflections in the glasses.
- Pose, movement and rotation of the test person are limited. The test person should stand or sit and look frontally into the camera (angle < 40°)
- FaceReader requires strict light conditions. Please see page 33 for more information.
Factors that partially hide the face, like a hat, or very heavy facial hair may hinder the analysis. It is also very difficult to classify a person’s facial expressions when he/she is eating, because the person’s hand covers part of the face when he/she puts food in the mouth and the muscles in the face move.

FaceReader can analyze one face at once. If there are more faces in an image, these can be analyzed in different runs, provided that the positions do not change significantly. Please contact us if any of the limitations above impede your research.

**MOUSE CONTROL**

Some features of FaceReader are controlled with mouse clicks. If you do not have a mouse, you can use a mouse-emulator like NeatMouse to use those FaceReader functions. You can download NeatMouse for free from [http://neatdecisions.com/products/neatmouse/](http://neatdecisions.com/products/neatmouse/).

### 1.2 What’s new in FaceReader 7

Customers that upgrade FaceReader from a previous version should read this section carefully to get an impression of the new features in FaceReader 7.

**IF YOU UPGRADED FROM FACEREADER 6.1**

**Additional classification method**

To obtain even more reliable classification results, FaceReader now has an additional classification method, the Deep Face classification. This model is used side by side with the Active Appearance Model that was also present in previous FaceReader versions. The Deep Face classification method classifies facial expressions directly from pixels using an artificial neural network. With this method, facial expressions can be classified, even if FaceReader is unable to make a model of the face, for example because part of the face is hidden. See page 12 for more information.

**Site Licenses**

The use of FaceReader can now be managed with Site Licenses. The Site License administrator can specify with the program Site License Manager which user is allowed to use FaceReader with which rights. This is especially useful if a large group of people, like
students, use the program. This way it is no longer necessary to use hardware keys. However, if preferred, it is still possible to use hardware keys.

**N-Linx communication**

FaceReader is now fully compatible with the Noldus network communication protocol N-Linx. This enables real-time import of FaceReader event data and continuous data into the video annotation program The Observer XT. This makes import of FaceReader data into The Observer XT much easier and faster. In addition to this, it ensures synchronization of FaceReader analysis and annotations, also if both programs run on different computers.

**Updated General face model**

The new face model General61 in FaceReader 6.1 was renamed to General and the old General model from FaceReader 6.1 and earlier versions was removed. Face models are improved and updated with every FaceReader version.

We recommend to use the same FaceReader version within a project. So if you are in the middle of a project, finish it first before you upgrade to FaceReader 7. For details on face models, see page 55.

**Stimuli improvements**

You can now present images as stimuli and specify a duration to show them to the test participants.

In previous FaceReader versions, stimuli could not overlap. This has been changed in FaceReader 7. Different stimuli are now allowed to overlap.

**Window 10 support**

FaceReader 7 is supported with the 64 bit versions of Windows Professional 7 and 10. For more information, see “System requirements for Noldus software” on www.noldus.com/downloads.
Remote Photoplethysmography

FaceReader can estimate heart rate of the subject in front of the camera by means of remote photoplethysmography (RPPG). This is a method based on the fact that changes in blood volume due to the pressure pulses cause small changes in the reflectance of the skin.

For this functionality, your FaceReader license must include the Remote PPG Module. Contact Noldus for more information.

For details, see The Remote PPG Module on page 152.

Stimulus Presentation Tool

The Stimulus Presentation Tool is a new component of the Project Analysis Module (see Chapter 6 for details), which allows you to have FaceReader analysis and stimulus videos automatically synchronized. Here are the basic steps:

1. Install the Stimulus Presentation Tool on the test participant’s computer.

2. On the test leader’s computer with FaceReader installed, define a Test. A Test is a collection of stimulus videos or images to be presented in a specific order.

3. After connection is established between the two computers, the Stimulus Presentation Tool presents the stimulus videos to the test participants and sends time information to FaceReader. This way FaceReader data and stimuli are in sync and can be analyzed immediately and reliably. For details, see The Stimulus Presentation Tool on page 104.
Chapter 2

Installation

2.1 System requirements ................................................................. 20
2.2 Before you install FaceReader ...................................................... 21
2.3 Install FaceReader ...................................................................... 24
   How to install FaceReader on your computer.
2.4 Modules .................................................................................. 25
2.5 FaceReader trial version ............................................................. 27
2.6 Camera and accessories ............................................................. 28
   Information about the placement of the camera and the lighting of the
   subject’s face.
2.1 System requirements

**OPERATING SYSTEM**

FaceReader has been thoroughly tested using a US English version of Windows 7 and 10 (64 bit Professional edition). For Windows 7, Service Pack 1 is required. Like any software package, it is possible that minor differences in the operating systems of certain local language versions may affect how well FaceReader runs. If you encounter a problem of this sort, please contact Noldus Technical Support.

**COMPUTER**

If you order a complete solution from Noldus Information Technology, you will obtain a Dell Precision™ T5810 Workstation (or its successor) or a M4800 laptop (or its successor) with the FaceReader software installed and ready to use.

*Technical specifications Dell Precision T5810*
- Processor: Intel Xeon E5-1620 v3 (Quad core), 3.5 GHz.
- Internal memory: 8 GB.
- Hard disk: 1 TB.
- Graphics card: 2 GB NVIDIA Quadro K620, resolution 1920 x 1080.

*Technical specifications Dell Precision™ M4800 laptop:*
- Processor: Intel I7-4810MQ (Quad core), 2.8 GHz.
- Internal memory: 8 GB.
- Hard disk: 500 GB.
- Graphics card: 2 GB NVIDIA Quadro K1100M, resolution 1920 x 1080.

*Other computers*

If you choose to order a PC from another supplier, you can use the above specifications as a guideline.

We recommend that you use a professional workstation. It is possible to buy consumer-range computers with a high processor speed and plenty of memory, but in order to remain competitive regarding price, the manufacturers often economize on the underlying system architecture. That means those computers are suitable for home use, but not for running
professional scientific software. You should select a computer which is intended for professional use or labeled by the manufacturer as a workstation.

**CAMERA**

You can use one of the following camera types:

- **CCD webcam** with a resolution of at least 640 x 480 pixels.
  
  We strongly recommend that you use a high-quality webcam. Simple web cams are not suitable.

- **IP camera**.

**INTERNET CONNECTION**

If you are using an IP camera, you need a fast internet connection for this set-up to work.

### 2.2 Before you install FaceReader

If you ordered a new computer from Noldus Information Technology when you purchased FaceReader, all your software and any internal hardware is already installed and tested. If you install FaceReader yourself, please follow the instructions below, in the order they are presented. Please note that it is not possible to install The Observer XT on one computer and access it from another across a network. The program must be installed on the computer where it will be used.

You must have administrator rights to install FaceReader. This means you either are the system administrator or a member of the Windows group **Administrators** and have been assigned administrator rights.

Prior to installation, please check the packing list to make sure all the components are present. If any of the components listed is missing or damaged, please report this to us immediately.

Before you install FaceReader, turn off automatic updates for device drivers. See the next section for the procedure.
**TURN OFF AUTOMATIC UPDATES FOR DEVICE DRIVERS**

Although the general recommendation from Microsoft to use automatic updates is good, especially for security updates, automatic updates of hardware device drives can sometimes give problems. The procedure below describes how to specifically turn off the automatic updates only for device drivers. If you ordered a computer with FaceReader from Noldus IT, the automatic updates for device drivers have already been turned off.

**Windows 7**

1. From the Windows Control Panel, go to **Devices and Printers**

   ![Devices and Printers](image)

   If you do not see **Devices and Printers**, open the Windows **Start** menu and type **Devices and Printers**.

2. Right-click on the icon of your computer and select **Device installation settings**.

3. To the question “**Do you want Windows to download driver software and realistic icons for your devices?**,” select **No, let me choose what to do** and then
4. Select **Never install driver software from Windows Update**.

5. Click **Save Changes**.

**Windows 10**

1. Click the Windows icon on your desktop and type **Change device installation settings**.

2. Click **Change Device Installation Settings**.

3. To the question **“Do you want to automatically download manufacturers’ apps and custom icons that are available for your devices?,”** select **No** (your devices might not work as expected).

4. Click **Save Changes**.
2.3 Install FaceReader

To install FaceReader

1. Insert the FaceReader installation USB stick in your computer.

2. Run the file FaceReader 7.0 Setup.exe. If a security message appears, click Run.

3. We recommend to choose Standard as Installation type. Choose Custom if you want to change the folder into which FaceReader is installed, or if you do not want shortcuts on the desktop to the program and the Reference Manual.

4. If you have the Microsoft LifeCam Studio, select Microsoft LifeCam Studio driver in the Drivers and Tools field.

5. Optionally, select Acrobat Reader DC in the Drivers and Tools field to install the software to read the documentation.

6. Click Next, read License Agreement carefully, Select I accept, and click Next. The installation of FaceReader starts.

7. When the installation of FaceReader is finished, a message appears informing you that installation is complete. Click Launch to start FaceReader, or Close to exit.

Notes

- FaceReader is installed in C:\ Program Files (x86)\Noldus\FaceReader 7\.

- A number of sample images and video files is installed in C:\ Program Files (x86)\Noldus\FaceReader 7\Examples.

- To install the Stimulus Presentation Tool, see page 105.
Projects saved in FaceReader 7 cannot be opened in earlier versions anymore.

### 2.4 Modules

You can extend the base functionality of FaceReader with modules. Your license determines which modules you can use (see page 27).

**PROJECT ANALYSIS MODULE**

This module allows you to make a selection out of your participants and carry out a group analysis. You can for example analyze the facial expressions of all male and all female participants. You can analyze participant groups and calculate average expression intensities per group. The groups can be created manually. But it is also possible to create them automatically, based on, so called, independent variables. These independent variables can be, for example, whether test participants saw a commercial prior to the test, or the native language of the test participant. The independent variables *Age* and *Gender* are present by default and can also be used to group participants.

With this module it is also possible to mark episodes in the analysis, for example to mark the occurrence of a smell or sound. In addition, you can synchronize and visualize the video tests participants have watched. You can mark parts of interests within these videos and compare the data associated with these video fragments with each other, or with other parts of the analysis.

For more information, see Chapter 6 *The Project Analysis Module*.

**ACTION UNIT MODULE**

With the Action Unit Module you can analyze the intensity of a number of Action Units from the Facial Action Coding System (FACS). FaceReader can analyze 20 Action Units, that are most common in facial expressions.

For more information, see Chapter 7 *The Action Unit Module*. 
REMOTE PPG MODULE

With the Remote PPFG Module you can analyze the heart rate of the test participant by means of remote photoplethysmography. For details, see Chapter 8 The Remote PPG Module.

2.5 Upgrade to FaceReader 7

UPGRADE FACEREADER

See the system requirements on page 20 to check that your computer can run FaceReader.

To install FaceReader 7 while keeping a previous version

To install FaceReader while keeping a version lower than 7, make sure that the destination folder on C:\Program Files x86 is not the same as that of the previous version. For this purpose we advise you to keep the default folders (C:\ Program Files (x86)\Noldus\FaceReader 7\) selected during FaceReader installation (see page 24).

To open a project created with an older version in FaceReader 7

If you open a project that was created in an older version with FaceReader 7, that project is converted to a FaceReader 7 project. A project created in FaceReader 7 cannot be opened in previous versions. To work with that project in older versions first create a backup in an older version. See page 37 how to create a backup. We recommend to use the same FaceReader version within one project.

UPGRADE THE LICENSE

If you have a hardware key
1. Install FaceReader 7 (see page 24).
2. Insert the hardware key into your computer and start FaceReader.
3. The system automatically detects the old license on the hardware key and the **Enter Upgrade Key** window appears. Enter the key codes that were supplied to you by Noldus IT. These numbers are normally sent by e-mail or are present in your welcome letter.

![Enter Upgrade Key (3 tries left)](image)

*If you bought an extra module*

When you already have FaceReader 7 and bought an extra module, for example the Action Unit Module, you also need to upgrade your license. To do so, in FaceReader choose **Help > Upgrade** and enter the upgrade keys that were supplied to you by Noldus IT.

*If you have Site Licenses*

Upgrading Site Licenses is done in Site License Manager. See the Site License Manager Reference Manual for the procedure.

### 2.6 FaceReader trial version

The free 30-day trial version allows you to evaluate the software without hardware key. When you start FaceReader for the first time without a hardware key, a message will appear that no valid hardware key is detected.

1. Click **Start Trial**. A window will appear asking you to enter your license number and e-mail address.
2. Click **Request Trial Information**. A web page is opened where you can request a trial license number.
3. Enter the license number and your e-mail address.
You can check the number of days left for evaluation, choose Help > About. When the trial period is over, a message will be shown.

The trial version has a number of restrictions:

- Maximum video length per analysis is 2 minutes.
- Maximum number of analyses is 5.
- Batch video analysis is disabled.

Please note that the Project Analysis Module and the Action Unit Module are enabled in the Trial version.

### 2.7 Camera and accessories

FaceReader can only classify facial expressions correctly if it gets a good image. Both the placement of the camera and the lighting of the subject’s face are of crucial importance in obtaining reliable classification results.

#### CHOOSE YOUR CAMERA

FaceReader has been thoroughly tested with a Microsoft LifeCam Studio webcam. You can purchase this camera from us or use another high quality webcam with a resolution of at least 640 x 480 pixels. Simple webcams are not suitable.

If you have the Microsoft LifeCam Studio, use the camera drivers from the FaceReader installation USB stick. Choose Microsoft LifeCam Studio driver in the Drivers and Tools field of the FaceReader installation window.

If you already installed FaceReader, and want to install the camera drivers, browse to the folder Microsoft LifeCam drivers on the installation USB stick and run the file Noldus Microsoft Lifecam Driver 4.25.529.exe. If you have Windows 10 and your computer has an internet connection, the latest drivers for your camera will be automatically installed.

You can also use an IP camera. An IP camera is connected with the FaceReader PC via Internet, and enables you to do tests with test participants at another location or at the test participant’s home.
CAMERA POSITION

It is important to place the camera at a location that will give the most steady frontal view of the subject’s face throughout the experiment. The ideal position for the camera is directly in front of the test participant. If the subject faces a computer screen, the camera can be placed either directly above or directly below the screen. When placing the camera on top of the monitor, try to position it slightly below eye level, either by raising the chair and/or by lowering the monitor. When placing the camera below the monitor, lower the chair to position the camera slightly below eye level. The classification output may have a small bias towards ‘angry’ when the camera is placed on top of the monitor and a small bias towards ‘surprised’ when the camera is placed below the monitor. This is due to the fact that people tend to tilt their head when showing these emotions. If that is a problem, you can compensate for it by calibration (see page 63).

IMAGE BRIGHTNESS AND CONTRAST

It is important to adjust your camera to provide images with a good contrast and brightness. You can adjust the contrast and brightness by adjusting the hardware settings using the software provided by the manufacturer of your camera. When adjusting your hardware settings, do not pay attention to the lighting of the background. Focus only on the face area of the image and ignore a very light or very dark background.

Changing the brightness and/or contrast of an already recorded video or an image will have little or no effect on the quality of the analysis. The procedure below can only improve FaceReader’s performance when applied at the moment the video is made.

Figure 2.1 Image with a good contrast and brightness.
In Figure 2.1 you can see an example of a face image showing a good contrast and lighting. Dark areas of the face (such as the eyebrows and the pupils) are near-black and the lightest part of the face (the eye whites) are nearly white. The intensity histogram (made of the face area only) (Figure 2.2) shows how the intensity values fill the whole spectrum.

![Intensity histogram of the image in Figure 2.1](image)

**Figure 2.2 Intensity histogram of the image in Figure 2.1**

Please note that it is not possible to view a histogram like the one above in FaceReader. If you want to view such a plot, you can use graphics software like Paint.NET or Photoshop. To analyze video images, first make a screenshot of the image of interest.

The face area of the image in Figure 2.3 is overexposed. The forehead and cheekbones are nearly white and show very little texture.

![Overexposed image](image)

**Figure 2.3 Overexposed image.**
The histogram (Figure 2.4) shows how only the high intensity part of the spectrum is filled. Decrease the brightness by adjusting the hardware settings of your digital camera or decrease the aperture size of your analog camera to correct this problem.

![Intensity histogram of the image in Figure 2.3](image1)

**Figure 2.4 Intensity histogram of the image in Figure 2.3**

A very common problem is that the image has too little contrast (Figure 2.5).

![Image with too little contrast](image2)

**Figure 2.5 Image with too little contrast.**

Especially when the background is very dark or very light and the camera is set to 'automatic', the face area of the image will have a very low variability in intensity (a low contrast). The contrast is too low when the face area of the image contains no bright white and no deep black pixels. The intensity histogram (Figure 2.6) shows that only the middle section of the spectrum is filled. Correct this problem by adjusting your camera (increase the contrast).

![Intensity histogram of the image in Figure 2.5](image3)

**Figure 2.6 Intensity histogram of the image in Figure 2.5**
When working with a subject with a dark or very pale skin color, you may need to make some extra adjustments. The default settings will often yield an image as shown below (Figure 2.7). Although there are both dark areas and white areas (the eyes) in the face, the skin itself shows too little variations in intensity. By increasing the brightness (to make the face lighter) and increasing the contrast (to increase the variation in skin tones) you can correct this problem. For people with a very pale skin, decrease the brightness and contrast.

![Figure 2.7 Image that is too dark.](image)

The corrected image should look similar to the image below (Figure 2.8). Pay special attention to the skin tones. The eye whites may have less variation in intensity, but this is of lesser importance. Similarly, for individuals with a pale skin, darker areas like the eyebrows may loose some detail.

![Figure 2.8 Image with a good contrast and brightness.](image)
LIGHTING SETUP

A good lighting setup is vital to get a good image. Diffuse frontal lighting is desirable. The light intensity or color is less relevant. Strong shadows or reflections should be avoided. If possible, place the FaceReader setup in front of a window. Make sure that any windows to the sides of the subject are blinded. Lights from the ceiling, common in most buildings, will produce shadows below the eyebrows and nose. In situations where interior lighting cannot be controlled, stronger lights (e.g., professional photo lights) can be used to negate the effect of other, undesirable, light sources (see Figure 2.9). You can purchase such lights from Noldus IT.

Figure 2.9 FaceReader set-up with professional photo light.

To assess the quality of your (video) image, you can view FaceReader’s image quality bar (see page 57).
Chapter 3

Set up your project

3.1 Start FaceReader ................................................................. 35
3.2 Projects .............................................................................. 35
3.3 Add your test participants ................................................ 39
3.4 Add analyses ................................................................. 40
3.5 Project wizard ................................................................. 44
3.1 Start FaceReader

There are two types of FaceReader licenses. You may either have one or more hardware keys or a batch of licenses that can be managed with Site License Manager.

**IF YOU HAVE A HARDWARE KEY**

The hardware key is your FaceReader license. This is an important piece of equipment. It is sensitive and can be easily damaged. Please be careful with the hardware key and make sure you do not lose it. You will need to pay for a new license if you do so.

To use FaceReader with a hardware key, plug the key into a USB port on your computer. If the hardware key is correctly connected, a red light is visible inside the key. Now start FaceReader. Keep the key inserted in your computer while you work with FaceReader.

**IF YOU HAVE SITE LICENSES**

Site licenses are managed with Site License Manager. Your Site License administrator determines who can use FaceReader with which rights.

To use FaceReader with a site license, start FaceReader and log in with the details supplied to you by your Site License administrator.

3.2 Projects

**WHAT IS A PROJECT?**

FaceReader works with projects. A project groups all the data belonging to one experimental set-up. Your project contains the subjects who participated in the experiment, their personal details (name, gender and age) and the analysis results for each participant.

Furthermore, with the Project Analysis Module (see Chapter 6) you can:

- Create groups of participants based on their age and gender.
• Define independent variables to create groups of participants, like the stimulus used, or the observation day.
• Define stimuli to be shown to the participants (for instance, commercial 1, 2, 3, 4 and 5).
• Organize stimuli in tests, that is, collections of stimuli to be presented in a specific order.
• Define event markers, to indicate that, for instance, the participant was distracted or was trying food product A.

CREATE A NEW PROJECT

Choose File > New > Project. Give the project a name and select a location to store it, or accept the default location.

You can now add your test participants to the project (see Section 3.3).
**To save a project**

Choose File > Save or press Ctrl+S.

Choose File > As or press Ctrl+Shift+S to create a copy of the project with a different name.

Please note that this does not make a copy of the video files and the saved log files. To create a copy of the project with all the videos and log files, see **BACK UP YOUR PROJECT** below.

Never shut down the computer by pressing the power button, or cutting off the electricity. Your project data may become lost, even after you saved your project. Always use the Windows shut down feature to close your computer.

**BACK UP YOUR PROJECT**

Create a backup of your project at least once a day and store it in a safe location, for example on a network, or an external hard drive in another building. If you record videos from the test participant’s faces, create backups of these videos as well.

**To back up a project**

1. Choose File > Project Backup > Copy Videos/Images to Project Folder.

   This makes all the paths in the project relative, so you can copy the entire project to another location.

   Note — If you have the Project Analysis Module, you must copy the stimulus videos to the project folder as well. Choose File > Project Backup > Copy Stimulus Videos to Project Folder. Please be aware that video files are generally very large, so make sure there is enough space to write in the project folder.

2. Choose File and then Open Project Folder. This opens the project folder in Windows Explorer.

3. Select the contents of this folder and copy it.

4. Paste this to a folder in the location where you want to store the backup, for example a network drive or an external hard disc.
THE PROJECT EXPLORER

The Project Explorer is present on the left side of your screen. It displays the test participants and analyses currently in the project. You can expand elements to view more details.

Show/hide the Project Explorer

To create more space on your screen for the analysis, you may want to hide the project explorer. To do so, click the **Hide** button in the top-right corner of the project explorer.

Project Analysis Module

If you have the Project Analysis Module (see Chapter 6), the project explorer includes a window with four tabs: **Stimuli, Event Markers, Independent variables** and **Tests**.
3.3 Add your test participants

ADD PARTICIPANTS AUTOMATICALLY

**With the FaceReader’s Base Module**

If you know before you create your project how many participants and analyses per participant your project will contain, you do not need to enter them manually. Use the project wizard instead. See [Project wizard](#) on page 44.

**With the Project Analysis Module**

With the Project Analysis Module and the Stimulus Presentation Tool, each participant is added automatically to the project when he/she starts a test (see [RUN A TEST](#) on page 110). You do not have to add participants manually.

ADD PARTICIPANTS MANUALLY

FaceReader organizes the data per test participant.

**To add a participants to your project**

1. Choose Participant > Add Participant.
2. In the Name field, enter the participant’s name or, for example, a number.

![Add New Participant](#)
3. Two independent variables are present by default, the age and gender. FaceReader automatically estimates the age and gender of the participant from the video, camera input or image. To set the age or gender manually, click the pencil button and enter the correct value. Please enter age as an integer (for example 40, not 40.5). The gender and age in the Subject Characteristics window (see page 74) are then not estimated by FaceReader, but are fixed with the values you entered manually.

4. If you have the Project Analysis Module (see Chapter 6) and defined extra independent variables, also enter the values for these variables.

To delete a participant, make sure all its analyses are closed. To close an open analysis, click the button next to it.

Then right-click the participant’s name and select Delete Participant.

3.4 Add analyses

If you want to use settings other than the default ones for your analyses (see the chapter Settings on page 188), read the section Default and specific settings on page 54 before you add all analyses. If you, for example, work with Asian test participants, change the default face model to EastAsian before you add the analyses.
ADD ANALYSES AUTOMATICALLY

With the Base Module
If you know before you create your project how many participants and analyses per participant your project will contain, you do not need to enter them manually. Use the project wizard instead. See Project wizard on page 44.

With the Project Analysis Module
With the Project Analysis Module and the Stimulus Presentation Tool, the analysis is added automatically to the project when a participant starts a test (see RUN A TEST on page 110).

ADD ANALYSES MANUALLY

1. In the Project Explorer, select the participant for which you want to add an analysis. Click the Video, Camera or Image button on the toolbar to add a video file, a live video source or images.

2. Select and open the input source. If you carry out camera analysis, select the Resolution and the Frame rate. If you let FaceReader record the video (see page 43), use the highest frame rate possible. Select the Use as Default Camera check box if you want FaceReader to automatically select the current camera for future camera analysis sessions.

For more information on camera analysis, see CAMERA ANALYSIS on page 43.

A camera analysis results in 15 data points per second, independent of the frame rate you choose. This makes the analysis comparable with the frame rate of video recorded (see page 43).
A new analysis is added to the Project Explorer. The video, camera or images icon indicates what type of analysis it is.

![Project Explorer](image)

To add multiple video files to your project, right-click the participant name in the Project Explorer and select Add Multiple Video Analyses.

3. Repeat steps 1 and 2 to add more video files, images or live video sources.

![Important note](image)

If your project contains image analyses you cannot add video or camera analyses and if your project contains video or camera analyses you cannot add an image analysis.

If you carry out a camera analysis, or video analysis, do not use very long recordings. Especially if you export many different data, like facial states, action units, stimuli and event markers, these files get very large, which may cause performance problems. FaceReader has been tested and works well with camera analyses of 2 hours and video analyses of 2 hours with 15 fps and 1 hour with 30 fps.

You are now ready to start an analysis. See Chapter 4 for the step-by-step instructions to analyze the test participants’ facial expressions.

**Camera analysis with an IP camera**

1. In the Select Camera window, under select Camera, choose IP Camera.

2. Under Source URL, enter the source URL of your camera.

   Check the documentation of your camera or contact the service department of your camera for the correct URL. For Axis IP cameras you can type one of the following:
   - http://XXX.XXX.XXX.XXX/mjpg/video.mjpg
   - http://XXX.XXX.XXX.XXX/axis-cgi/mjpg/video.cgi

   Where XXX.XXX.XXX.XXX is the IP address of the camera.

3. Under Frame rate, select the frame rate (default: 5 fps).
4. If your camera is password-protected, select this **Secured** and enter the **Username** and the **Password**.
   
   For Noldus IP cameras, enter **root** and **Noldus**, respectively.

5. Select either **JPEG** or **MJPEG**.
   
   Check in the documentation of the camera what type of stream the camera produces (JPEG or MJPEG).

6. Select **Use as Default Camera** if you want FaceReader to automatically select the current camera for future camera analyses.

The camera view appears in the **Camera Analysis** window.

**To delete an analysis**

Right-click the analysis in the Project Explorer and select **Delete Analysis**. You cannot delete an analysis if it is open. To close an open analysis, click the button next to it.

---

**CAMERA ANALYSIS**

**Default camera**

If you always use the same camera for camera analysis, set this camera as the default one.

Choose **File > Set Default Camera**. Select your camera. This camera will be automatically selected in future analyses.

**To make a video recording from your live camera image**

The advantage of recording a video is that you can view the video of the test participant’s face, can carry out additional analyses later and integrate the video with other data modalities in The Observer XT.

Select **Record** when choosing your camera (in step 2 on page 40). The video will have a frame rate of 15 fps.

**Video frame rate and samples in FaceReader**

When you choose to record video from the live camera image, the resulting video file is always made of 15 frames per second (fps). This is independent of what you choose as camera **Frame rate** (see step 2 on page 41).
In camera analysis, **Frame rate** only specifies how many frames are sent by the camera. FaceReader processes the frames to obtain a video file of 15 fps. If you select a Frame rate of 30, FaceReader skips one every two frames. If you select a Frame rate of lower than 15 fps, FaceReader interpolates the results. The result is that you always have a video file of 15 fps and the analysis contains 15 samples per second. You can see this when you export the results to a Detailed log (see page 95).

We recommend to select the highest frame rate among those available. FaceReader by default selects the optimal frame rate, so in general you can leave the default value selected.

This allows FaceReader to analyze a frame that is closest to the time point that results to a frame rate of 15.

Note that when you carry out video analysis, the sample rate of FaceReader corresponds to what you choose in the analysis settings.

**Video format**

The video file format is DivX/MP4V. This format is compatible with The Observer XT.

To play back a DivX video on a computer without FaceReader or The Observer XT, it may be necessary to install a DivX player on your computer.

### 3.5 Project wizard

**WHY A PROJECT WIZARD?**

If you know before you create your project how many participants and analyses per participant your project will contain, you do not need to enter them manually. Use the project wizard instead.

Also use the project wizard if you created many videos, or images and stored them in a consistent way. For example, you created a folder per participant and each participant folder contains a number of folders and subfolders that contain the videos or images to analyze. You can use this folder and file structure to make a template and create the participants and analyses automatically. With such a template it is also possible to read the age and gender from the file names and enter these values as independent variables for the participants. See page 213 which file formats can be used with the project wizard.
PROCEDURES

Project wizard — Manual

2. Give the project a name, select the location to store it, and select whether you want to carry out video, camera or image analysis from the Source type list.


4. Select the Number of participants and the number of Analyses per participant.

5. If you have chosen Camera as Source type, also select the camera under Default camera.

6. The Project Preview on the right displays the project structure.

![Design New Project dialog box showing Manual project configuration](image)

Project wizard — From a group of video/image files
This option is only available for video and image analyses, because it uses the way the stored files are organized.


2. Give the project a name, select the location to store it and select Video, or Images from the Source type list.

3. Select From file structure. The Project Preview window displays the project structure with the selected options.
4. Under **Path**, select the root of the folders where your videos or images are stored.

5. Under **Predefined Templates**, select one of the following:
   - one of the predefined templates. See page 46.
   - **Custom template** — Then use the building blocks under **Choose File Template Parts** to create your custom structure. See page 51.

6. Click **OK** when ready.

**Predefined templates**

Choose a template from the list.

![Predefined Templates](image)

The **File template** field shows the building blocks used for this template. For an explanation of the building blocks, see page 51.

- **Add all videos to a unique participant**

  File template <WildCard>.<WildCard>

  Each video found in the folders and subfolders will be added as analysis to a separate participant. Participants will be named **Participant 1, Participant 2**, etc. The analyses will be named **Analysis 1**. Video location plays no role here.
Example:

- **Folder equals participant name**

  File template `<ParticipantName>\<WildCard>.<WildCard>`

  Each video found in the folders and subfolders will be assigned as analysis to a separate participant. Each participant will get the name of the folder where the video was found. Note that this results in the same person being represented by several “participants” in FaceReader. All analyses will be named **Analysis 1**.
Example:

- **Folder equals unique participant name**

  File template `<UniqueParticipantName>\<WildCard>.<WildCard>

  Each participant will get the name of the folders found in the root folder. Each participant name will only be used once.

  If more videos are found in the same folder, these will be added as analyses to the same participant. The analyses will be named **Analysis 1, Analysis 2, ....etc.**
Example (different colors represent different levels of organization):

- **Folder equals participant index**

  File template `<ParticipantIndex><WildCard><WildCard>`

  In case your folders have numbers instead of letters. Each participant will get the folder number and the videos in this folder or subfolders are assigned as analyses to this participant. The analyses will be named **Analysis 1, Analysis 2, ....etc**
Folder equals participant index, subfolders equal analysis index

File template `<ParticipantIndex>`<AnalysisIndex>`\<WildCard>`<WildCard`

Use this template when your folders and subfolders have numbers instead of letters. Each subfolder may contain only one video file. Each participant will get the number of the folder directly under the root folder specified in the Path field. Each analysis will get the number of the subfolder and the name of the file.
Example (different colors represent different levels of organization):

Custom template

Before you start, check that the field under File Template is empty. If not, double-click the text in the field and press Delete.
To create your structure, click one or more items under **Choose File Template Parts**.

- Use a slash (\) to indicate a new folder.
- Use a dot (.) to separate the filename from the extension.

The following building blocks are available:

- **ParticipantIndex** – For folders and files with numerical names. Uses the folder numbers for the participants numbers.
- **UniqueParticipantName** – Uses the folder or file names for the participant names. Each participant name will be used once.
- **ParticipantName** – Uses the folder or file names for the participant names. Different participants can have the same name.
- **ParticipantAge** – Reads the participant age from the file name and enters this as category for the independent variable Age.
  
  *Example*: file name is 32_male_commercial 1.avi
  
  Then use building blocks <ParticipantAge>_<Wildcard>.<Wildcard>

- **ParticipantGender** – Reads the gender from the file name and enters this as category for the independent variable Gender.
  
  *Example*: file name is 32_male_commercial 1.avi
  
  Then use building blocks: <Wildcard>_ParticipantGender_<Wildcard>.<Wildcard>
  
  For the example above, you can also combine **ParticipantAge** and **ParticipantGender** in the following way:
  
  <ParticipantAge>_ParticipantGender_<Wildcard>.<Wildcard>

- **AnalysisIndex** – For subfolders or files with numerical names. Each subfolder may contain only one video file. Uses the folder numbers for the analysis names.
- **Wildcard** – Allows any character.
Chapter 4

Analyze facial expressions

4.1 Default and specific settings ............................................................... 54

4.2 Select a face model .............................................................................. 55
Information about the General, Children, East Asian and Elderly Face Models.

4.3 Analyze facial expressions ................................................................... 56
Step-by-step instructions how to analyze facial expressions in a video signal coming from a camera or in a video file or image.

4.4 Optional classifications ....................................................................... 60
Information about the facial states which FaceReader can detect: left/ right eye open or closed, mouth open or closed, eye browse raised, normal or lowered and the global gaze direction.

4.5 Calibrate FaceReader ........................................................................... 63
How to correct the facial expressions of people who have a bias towards a certain emotion.
4.1 Default and specific settings

Face analysis is based on a number of settings, like the face model and the number of frames to be analyzed.

- You can keep some settings the same for all participants and analyses. For example, the video sample rate. These are **default analysis settings** (see below).

- You can also adjust the settings for the analysis currently open on the screen. These are **settings for the current analysis** (see page 55).

You can set default and current analysis settings for the following:

- **Face model** – see page 55.
- **Calibration** – see page 63.
- **Smoothen classification** – see page 192.
- **Image rotation** – see page 192.
- **Video sample rate** – see page 193.

**DEFAULT ANALYSIS SETTINGS**

The default settings are used for each new analysis. To set the default settings, choose **File > Settings** and then **Default Analysis Settings**.

![Application Settings](image)
SETTINGS FOR THE CURRENT ANALYSIS

To use other than the default settings for a specific analysis, open the analysis by double-clicking it in the project explorer or clicking the magnifying glass button next to it.

Select the settings in the Settings window in the bottom-left part of your screen. Click the pencil next to a setting to edit it.

### 4.2 Select a face model

Before you can start analyzing facial expressions, you must select the face model that best fits the faces that you are going to analyze. You can choose from a list of four models:

- **General** – This model has been trained on a very diverse selection of images. This model works well under most circumstances for most people. This model was called General61 in FaceReader 6.1.

- **Children** – Select this model if your test participants are children between the age of 3 and 10. The current FaceReader version is not well-trained for analysis of East-Asian children.

- **EastAsian** – Select this model to analyze East Asian faces, for instance, Chinese or Japanese faces.

- **Elderly** – Select this model if your test participants are elderly from the age of 60. The model has been trained with a very diverse selection of images from people of all ethnicities.
4.3 Analyze facial expressions

AUTOMATIC ANALYSIS PROCEDURE

With the Project Analysis Module and the Stimulus Presentation Tool, analysis is carried out automatically when the participant starts a test (see RUN A TEST on page 110). You do not have to start and stop analysis manually.

MANUAL PROCEDURE

Follow these steps if you do not carry out analysis with the Stimulus Presentation Tool.

To carry out one analysis

1. On the Settings tab in the lower left part of the analysis part on your screen, check whether the correct face model is active (Face model). See Section 4.2 on page 55 for an overview of the available face models and for the procedure to select a different one.

2. Check whether the correct calibration is selected (Selected calibration, or Continuous calibration). To select a different calibration for this analysis, click the pencil button next to Selected calibration, or Continuous calibration and make your selection. You can only select Continuous calibration if you first set the Selected calibration to None.

3. For Video analysis – position the video to where you want to start the analysis. By default, videos are processed frame-by-frame. If you like to speed up the analysis, you can change the sample rate. See page 193 for more information.

   For Image analysis – select Analyse all images if you want to analyze them all at once. If your set of images contains faces of different persons and you want to calibrate FaceReader for one or more of these persons, add a participant for each of the persons.
4. Click the Start analysis button.

To carry out analysis for all participants at once, press the Start batch analysis button on the toolbar of the project explorer.

Video and camera analysis – an analysis interval is added to the Overview pane with the start time and the running end time of the interval.

Image analysis – the analysis results appear in the Overview pane. For each image, the dominant expression is shown. Click a row in the Overview window to display the analysis results for that image.

5. During analysis, check the Image quality bar. It should look like the one below, the colored bar must cross both dashed lines.

If the quality of your camera image is not good enough, the text Framing failed (FaceReader cannot find the face) or Face modeling failed (FaceReader cannot model the face) will appear in the Analysis Visualization window. Probably either the lighting of the
test person’s face or the position of the camera is not optimal. See **Camera and accessories** on page 28 for information how to improve your setup.

6. Click the **Stop Analysis** button to stop the analysis. The end time of the analysis interval in the **Overview** pane is fixed.

**Video analysis** – you can analyze more episodes by moving the video to a new position and clicking the **Start analysis** button again. The analyzed episodes are shown in the **Overview** window. But please note that the data of all the analysis intervals are saved in one log file. The text **Not Analyzed** will appear in the log file for the time points that were not analyzed. This can result in very big files.

![Overview window with analysis intervals]

For information about (saving) FaceReader log files, see page 93.

7. To export analysis results, choose **File > Export** and select to export the results of the analysis, participant, or the entire project. See page 93 for more information.

![Light bulb icon with text: To redo an analysis, click the Clear Results button and start the analysis again.]

If you exported log files before you clicked the **Clear Results** button, these will not be deleted.

---

**NOTES**

**Analysis information**

Below the **Overview** window you find a window with three tabs:

- **Settings** — There you set the settings for the current analysis (page 55).
- **Source Details** — There you find information on the source of analysis, that is, the video file or the camera (with its frame rate).

![Source Details Table]

- **Analysis Details** — There you find information on the number of **Analyzed frames** up to that moment, the **Average frame rate** (the number of frames analyzed per second), and the Remaining analysis time (for video analysis only).

Note:

- When you run a **camera analysis**, a new video frame is analyzed when the previous frame has been analyzed. If detection is demanding, the number of frames being analyzed per second may be lower than the camera frame rate. In this case FaceReader skips a frame to keep up with the camera frame rate. After the analysis is finished, FaceReader interpolates the results in the skipped frames and maintains a sample rate of 15 fps.

![Analysis Details Table - Camera]

- When you run a **video analysis**, the average frame rate may be lower than that expected from the frame rate of the video file. For example 27 fps when the video frame rate is 30 fps and you set to analyze every frame (**Settings** tab). In that case video plays slower than 1x during analysis, but all frames are analyzed.

![Analysis Details Table - Video]

See also **Analysis speed** on page 60 and **Sample rate** on page 193.
**Autosave**

An autosave file is created after each analysis. This is particularly important during batch analysis. If, for any reason, batch analysis is interrupted (for example after a power failure), you can recover the autosave file by renaming it like the original project file.

Do the following:

1. Make sure FaceReader is closed.
2. Browse to the project folder. There you should find a file named ~[project name]_Autosave (with no extension).
3. Rename the original project file to [project name]_backup.frx.
4. Rename the autosave file to the project name.
5. Open the project again in FaceReader. There you should find all analyses completed before the interruption.

**Analysis speed**

When you choose the options Show Texture Model or Show Mesh in the Analysis Visualization window (see page 71), the speed of the analysis is slowed down. Selecting only the option Framing, or closing the entire Analysis Visualization window can make the speed of the analysis much faster.

In addition to this you can choose to analyze every 2nd or 3rd frame instead of every frame. To do so, choose File, Settings, Default Analysis Settings. Choose one of the options under Video.

Selecting optional classifications (see page 60) decreases analysis speed. So select only the options you require. Also, do not keep other programs running in the background. This will also speed up analysis.

The deep face analysis also decreases analysis speed. To switch it off, choose File > Settings and select Show advanced options. Open the tab Advanced. Under Engine, de-select Use Deep face engine. Please note that using the Deep face engine improves FaceReader analysis. Do not mix using and not using the Deep face model within one project.

### 4.4 Optional classifications

In addition to facial expressions, FaceReader can analyze facial states, the global gaze direction, and can identify participants. If you have the Action Unit Module (see page 143), FaceReader can analyze action units as well. To select these optional classifications, choose
File > Settings. Click the Analysis Options tab, and make your selection under Optional Classifications.

![Settings window](image)

Each optional classification decreases analysis speed, so only select the options you require.

**CONTEMPT (EXPERIMENTAL)**

Contempt is an expression in which one corner of the lips is tightened and slightly raised. It can be classified reliably in different cultures [1]. Some authors state that it should be added to the six basic emotions defined by Paul Ekman [2]. However, others authors disagree with this [3]. FaceReader has an experimental functionality to classify contempt.

To classify contempt, choose File > Settings and open the tab Analysis Options. Select Contempt (experimental). To add contempt to the expression states, select the option Treat contempt as an emotional state. This adds contempt to the State Log and Timeline and makes contempt mutually exclusive with the other emotions in the State Log and Timeline, meaning that only one emotional state can be active at any given time.

**References**


**FACIAL STATES**

In addition to facial expressions, FaceReader can detect facial states. It can detect whether the left and right eye is open or closed, whether the mouth is open or closed and whether the eyebrows are raised, neutral or lowered. These states are shown in the *Facial States* window. They can also be visualized in the *Analysis Visualization* window, when the option *Show Facial States* is selected.

<table>
<thead>
<tr>
<th>Facial States</th>
<th>State</th>
<th>Certainty</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gaze</td>
<td>Forward</td>
<td></td>
</tr>
<tr>
<td>Mouth</td>
<td>Closed</td>
<td></td>
</tr>
<tr>
<td>Left Eye</td>
<td>Open</td>
<td>94 %</td>
</tr>
<tr>
<td>Right Eye</td>
<td>Open</td>
<td>97 %</td>
</tr>
<tr>
<td>Left Eyebrow</td>
<td>Neutral</td>
<td></td>
</tr>
<tr>
<td>Right Eyebrow</td>
<td>Lowered</td>
<td></td>
</tr>
</tbody>
</table>

**GLOBAL GAZE DIRECTION**

FaceReader can also detect the test participant’s gaze direction, that is, whether the participant looks to the left, forward or to the right.

The gaze direction is shown in the *Analysis Visualization* window. To show the Global gaze direction, click the *Show global gaze direction* button.
If the button is not available, select File > Settings > Analysis Options and under Optional Classifications select Global Gaze Direction.

You can also display the gaze in the Events of the TIMELINE (page 82).

PERSON IDENTIFICATION

In addition to classifying facial expressions and extracting other information from the face (like age, gender, etc.), FaceReader can recognize persons that have previously been added to a database. The identification functionality enables you to make a database of all the test persons that participate in your tests. This feature is available for video and camera analyses. To use the identification functionality, select the option Personal Identification. See page 76 how to enter persons to the database.

4.5 Calibrate FaceReader

Some people look, for example, angry or sad by nature. Use a calibration method to correct for these person-specific biases towards a certain facial expression. In addition to this, look if you can improve your camera, or lighting conditions, since improper conditions may cause a bias towards certain facial expressions.
Calibration will help to remove biases in emotional expression intensities. It does not affect other analyses than facial expression classification. For example, calibration does not affect Action Unit analysis (for Action Unit Analysis you FaceReader license must include the Action Unit Module).

If you use the Project Analysis Module, do not use participant or continuous calibration. Use a stimulus to score an episode in which your test participants have a neutral expression instead (see the chapter The Project Analysis Module on page 97).

There are two calibration methods available in FaceReader.

- **Participant calibration** — Use this method if you analyze videos or images. Also use this method if you do camera analysis and the experimental setup allows capturing a neutral phase before the experiment starts.

  If you use this method, you must have a video fragment, or images in which the expression of the test participant was neutral. Or, if you carry out camera analysis, you must ask the test participant to look neutral. From the neutral images, FaceReader selects the one with the lowest model error and uses the expressions other than neutral found in this image for calibration.

  **How participant calibration works**

  If you use images for calibration, FaceReader searches for the image with the lowest model error. If you use camera or video analysis, FaceReader analyzes two seconds and uses the image with the lowest model error for calibration.

  If FaceReader corrects the expressions other than neutral it in the following way:

  $$Expression\ intensity = \max \left(0, \frac{(I_a - I_c)}{1-I_{cal}}\right).$$

  Where $I_a$ is the expression intensity in the analysis and $I_c$ is the expression intensity found in the calibration. If $\frac{(I_a - I_c)}{1-I_{cal}}$ is lower than zero, the calculated expression intensity will be zero.

  The intensity of **Neutral** is calculated in the following way:

  $$Intensity\ Neutral = \frac{(N_a + (1-I_{max}))}{2}$$

  Where $N_a$ is the intensity of **Neutral** classified by FaceReader and $I_{max}$ is the maximum intensity of all emotions in the analysis.
**Continuous calibration** — Use this method if you carry out camera analysis and the experimental setup does not allow capturing a neutral phase before the experiment starts. This is for example the case if you start FaceReader automatically with another program.

If you use this method, FaceReader continuously adapts to a test person’s bias while analyzing his/her face. The advantage of this method is that you do not need any calibration videos/images.

Only use continuous calibration if there indeed are person-specific, or setup-specific biases. If there are no biases, continuous calibration can decrease the analysis accuracy.

**How continuous calibration works**

FaceReader continuously averages the facial expression intensities in the analysis. It corrects for the expression intensities in the analysis other than neutral in the following way:

\[
Expression\ intensity = \max(0, (I_a - I_m) / (1 - I_a))
\]

Where \(I_c\) is the expression intensity in the current frame and \(I_m\) is the average expression intensity over all frames before the current frame. If \((I_a - I_m) / (1 - I_a)\) is lower than zero, the calculated expression intensity will be zero.

The intensity of *Neutral* is calculated in the analysis in the following way:

\[
Intensity\ Neutral = (N_a + (1 - I_{max})) / 2
\]

Where \(N_a\) is the intensity of *Neutral* classified by FaceReader in the current frame and \(I_{max}\) is the maximum average intensity of all emotions in all the frames before the current one.

**CREATE A PARTICIPANT CALIBRATION**

1. Make sure all analyses are closed. To close an open analysis, click the button next to it.

2. Choose *Participant* and then *Calibrate Participant*.

3. Select the correct Face Model (see “Select a face model” on page 55 for more information on face models).
4. Choose the calibration source:
   - **Images** – Select the files in which the participant looks neutral.
   - **Video** – Select the video file and scroll to the part where the test participant looks neutral.
   - **Camera** – Ask the test participant to look neutral.

5. Click the **Start analysis** button. When the calibration is created, the **Calibration Effect** field shows the facial expressions before and after calibration.

6. If you are not satisfied with the calibration, click the **Retry with same source** button and repeat step 5. When you are satisfied with the calibration, give it a name and click **OK**. FaceReader asks whether you want to use this calibration for all future analyses of this participant. Choose **Yes** if you want this.

   To change a calibration for a participant, select it, choose **Participant** and then **Set calibration as default**. To delete a calibration, select it, choose **Participant** and then **Delete calibration**.

   **Select the calibration for a specific analysis**

   If you chose the option to use the calibration for all new analyses of this participant in step 6 on page 66, the calibration is selected automatically. However, you must select the same face model in the analysis as was used for calibration (see step 1 on page 56). If you select another face model, FaceReader warns you that the selected calibration was not made for this face model and the calibration will be deselected. Create a new calibration with this face model.
To select the calibration manually:

1. Make sure that continuous calibration is set to **No** in the **Analysis settings** window on the bottom-left of the analysis part on your screen.

2. Click the pencil button next to **Selected calibration** and select the calibration from the list.

To select this calibration automatically for all new analysis of a participant, open the **Participant** folder and then the **Calibrations** folder in the project explorer. Right-click the calibration and select **Set Calibration as Default**.

**USE CONTINUOUS CALIBRATION**

1. Open the analysis for which you want to use continuous calibration. To open an analysis, double-click it in the project explorer, or click the magnifying glass button next to it.

2. In the **Settings** window, that you find on the bottom-left of the analysis part on your screen, click the pencil button next to **Selected calibration** and select **None**.

3. In the same window, click the pencil button next to **Continuous calibration** and select **Yes**. This sets the **Selected calibration** field to **Disabled**.
Chapter 5

FaceReader’s output

5.1 FaceReader’s graphical and numerical output ......................................... 69
An overview of all the graphs and tables you can view in FaceReader.

5.2 Reporting Client .................................................................................. 89
Information about the Reporting Client which indicates whether the emotional state of the subject is positive or negative.

5.3 Export the numerical output ............................................................... 93
5.1 FaceReader’s graphical and numerical output

**ANALYSIS WINDOWS**

*To open an analysis window*

Click the *Select window* button in the right-corner of one of the analysis windows.

Choose the window from the list that appears. When you choose an analysis that is already open in another window, the analysis which is already open closes. For the upper windows you can choose between:

- Analysis Visualization (page 71)
- Subject Characteristics (page 74)
- Facial States (page 74)
- Monitor Identity (page 75)
- Expression Intensity (page 78)
- Expression Summary (page 79)
- Circumplex Model of Affect (page 80)
For the lower windows you can choose between the line charts:

- **Time Line** (page 82)
- **Valence Line Chart** (page 83)
- **Arousal Line Chart** (page 84)
- **Expression Line Chart** (page 86)
- **Head Orientation Line Chart** (page 87)

**To add more analysis windows**

1. Click the **Split/Unsplit** button in an analysis window. This will split the window horizontally.
2. Move the mouse pointer over the plus sign.
3. Select a window from the list that appears.

**To merge analysis windows**

To merge the windows again, click the **Split/Unsplit** button once more.

**To reset the analysis window layout**

To close any extra charts that you opened and to reset the position of your chart windows, choose **Window > Reset Analysis Window Layout**.
Each facial expression has a fixed color which is the same in all the charts. It is not possible to change the colors of the emotions.

**Common options**

Most windows and charts can be exported or copied to the clipboard, and zoomed in/out.

- **Export** the window/chart as a *.PNG, *.JPG, *.BMP, *.GIF, *.TIF or *.EMF image. An EMF image is a vector image and therefore scalable.
- **Copy** the window/chart to the clipboard, to paste it in another program like Word or PowerPoint.
- **Use the Zoom In and Zoom Out buttons** to change the level of detail.

**ANALYSIS VISUALIZATION**

The **Analysis Visualization** window shows how FaceReader analyzes your images.

By default, the window is visible on your screen. If not, click the **Select window** button and select **Analysis Visualization**.

**Options**

Click the icons on the left of this window to select one or more of the options.

- **Show Framing** – Draws a black box around the face at the location where the face was found. If the modeling was successful, a black and a white box are shown.
- **Show Mesh** – Shows the positions of the 500 key points used by the face modeling algorithm. The axes on the nose indicate the head orientation.

- **Show Texture Model** – Shows the model that has been constructed by the face modeling algorithm.
- **Show Global Gaze Direction** – Shows the gaze direction of both eyes. The button **Show Global Gaze Direction** is not available when in the Analysis Settings under Optional Classifications, **Global Gaze Direction** is deselected.

- **Show Facial States** – Shows the Facial States, like whether the left and right eye is open or closed, whether the mouth is open or closed and whether the eyebrows are raised, neutral or lowered. The button **Show Facial States** is not available when in the Analysis Settings under Optional Classifications, the option **Facial States** is deselected.

---

After the analysis, you can play back the visualizations when you play back the video.

If you have the Action Unit Module, you can also display action units in the Analysis Visualization window.
SUBJECT CHARACTERISTICS REPORT

In addition to emotions, FaceReader can extract other information from the face: the subject's gender, age and ethnicity and whether the person has a beard, moustache or glasses.

To view the table with subject characteristics, click the Select window button on one of the upper visualization windows and select Subject Characteristics.

For the age a range is given, for gender, ethnicity and the presence of glasses a certainty value (percentage). The amount of facial hair (beard and moustache) is indicated by a value between 0 and 100%.

<table>
<thead>
<tr>
<th>Subject Characteristics</th>
<th>Result</th>
<th>Amount</th>
<th>Certainty</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gender (fixed)</td>
<td>Female</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Age (fixed)</td>
<td>25 - 35</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Beard</td>
<td>None</td>
<td>3%</td>
<td></td>
</tr>
<tr>
<td>Moustache</td>
<td>None</td>
<td>4%</td>
<td></td>
</tr>
<tr>
<td>Glasses</td>
<td>No</td>
<td></td>
<td>100%</td>
</tr>
<tr>
<td>Ethnicity</td>
<td>Caucasian</td>
<td>88%</td>
<td></td>
</tr>
</tbody>
</table>

The additional facial features also give you an indication of the quality of the image. If the quality of your image is poor, the information will not be correct. For instance, if FaceReader reports that a female test person is male, then the modeling is not correct, most probably because the image is of poor quality.

FACIAL STATES TABLE

The Facial States table gives a dynamic overview of the facial states: mouth and eyes (open or closed), eyebrows (raised, neutral or lowered) and gaze direction (left, forward or right). For the eyes a certainty value is given (ranging between 50% and 100%). See the figure below for an example.
To view the table with facial states, click the Select window button on one of the upper visualization windows and select Facial States.

<table>
<thead>
<tr>
<th>Facial States</th>
<th>State</th>
<th>Certainty</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gaze</td>
<td>Forward</td>
<td>-</td>
</tr>
<tr>
<td>Mouth</td>
<td>Closed</td>
<td>-</td>
</tr>
<tr>
<td>Left Eye</td>
<td>Open</td>
<td>94 %</td>
</tr>
<tr>
<td>Right Eye</td>
<td>Open</td>
<td>97 %</td>
</tr>
<tr>
<td>Left Eyebrow</td>
<td>Neutral</td>
<td>-</td>
</tr>
<tr>
<td>Right Eyebrow</td>
<td>Lowered</td>
<td>-</td>
</tr>
</tbody>
</table>

If the table shows Disabled behind all the states, choose File > Settings. On the tab Analysis Options, under Optional Classifications select Facial States.

**MONITOR IDENTITY WINDOW**

In addition to classifying facial expressions and extracting other information like age and gender from the face, FaceReader can recognize persons that have previously been added to a database.

To view the Monitor Identity window, click the Select window button on one of the upper visualization windows and select Monitor Identity.
To add a person to the database
You can only add a person to the database when you carry out a Video Analysis or a Camera Analysis.

1. Create a Video Analysis, or Camera Analysis and open it.

2. Open the Monitor identity window, by pressing the Select window button on one of the upper analysis windows and selecting Monitor Identity from the list.

3. The Modifier Identity window opens.
4. Start the analysis. As soon as 5 frames have been analyzed, the Add this person button in the Monitor Identity window will become available and unknown person will appear in the Monitor Identity window.

5. Click the Add this person button. The Add person to database window opens.

6. Enter the name of the person in the video and click OK. The name will appear in the Monitor Identity window and is added to the database, together with the first 5 images that have been analyzed.

To edit or delete a person in the database
Click the Rename Identity icon to rename a person in the database.
To delete someone from the database, or to delete images associated with a person, click the Delete Identity icon behind it.
Click the Reset button to restart the person identification routines. The identification starts anew.

Monitoring the identity of a person
When you have added your test persons to the database, FaceReader will recognize them the next time they appear in a video or camera image, provided that they did not change too much. As soon as 5 frames have been analyzed, a prediction of the current person’s identity will be made and the name will appear in the Monitor Identity window. The frames will
continuously be refreshed and guesses at the person’s identity will keep being made. Add the person to the database if FaceReader gives the person the wrong identity.

---

Select the option **Identity** in the **Data export settings** to add a column with the test person’s name to your Detailed log files. See page 200 for this setting.

---

**EXPRESSION INTENSITY CHART**

In the **Expression Intensity** chart you can see which of the six basic emotions (and the neutral state) show up on the face. When your input is a live video stream or a video file, you will see the bars change over time, reflecting the changes in emotions on the face. Each emotion is expressed as a value between 0 and 1.

To view the **Expression Intensity** chart, click the **Select window** button on one of the upper visualization windows and select **Expression Intensity**.

By default, the **Expression Intensity** chart is visible on your screen.

**Facial expressions are scored as states**

Each time the dominant facial expression changes and is active for at least 0.5 seconds, this expression is scored as a state with its time stamp in the **State log**. An expression is scored “dominant” when its intensity is significantly higher than that of all others.
Note that if the intensity exceeds 0.5, this does not necessarily mean that an expression is scored. In the following example (Figure 5.1), Sad and Disgusted exceed 0.5, but only Disgusted is scored at that time (see the blue bar on the timeline).

![Expression Intensity chart and Timeline]

*Figure 5.1 An example of two expressions, Sad and Disgusted, with intensity exceeding 0.5. Top: Expression Intensity chart. Bottom: Timeline (see page 82).*

For more information about the State log, see page 96.

If you want to use other criteria to define a state, for example when the intensity of an expression is above 0.5, export the detailed log (see page 95). Then calculate the states in another program, like Excel.

**EXPRESSION SUMMARY CHART**

*To view the Expression Summary chart*

By default, the Expression Summary chart is visible on your screen.

Click the Select window button on one of the upper visualization windows and select Expression Summary.
Select one of the analysis intervals in the **Overview** pane to view a pie chart with the distribution of expressions in your data. See the figure below for an example. If no intervals are selected, the chart shows the results of all the intervals in the **Overview** pane. Use the Ctrl and Shift keys to select multiple intervals and view a pie chart that is based on all these data.

![Expression Summary](image)

**Options**

Click **Settings** and select **Show Values** to view the subdivision of emotions in percentages.

**CIRCUMPLEX MODEL OF AFFECT**

The circumplex model of affect describes emotions in a two-dimensional circular space, containing arousal on the vertical axis and valence on the horizontal axis. The center of the circle represents a neutral valence and a medium level of arousal. The circumplex model of affect in FaceReader is based on the model described by Russel (1980).

**To view the Circumplex Model of Affect chart**

Click the **Select window** button on one of the upper visualization windows and select **Circumplex Model of Affect**. By default, this window is not shown on your screen.

**Options**

The following additional options can be selected with the **Options** button on the toolbar:

- **Show current position** – Shows a circle around the affect, with the color of the current expression state.
- **Show history** – If you carried out video analysis or camera analysis, the affect found in previous images is shown when playing back the analysis.

- **Show expression label** – Shows the expression state found in the image selected in the Analysis View window.

- **Show heatmap** – This option is only available for camera and video analyses. It displays a heatmap of the affect found in the analysis.
  - **Based on absolute percentage** – The color of the heatmap is based on the percentage of time a certain affect was found in a video or camera analysis. The maximum is 100%.
  - **Based on maximum percentage** – The color of the heatmap is based on the percentage of time the affect that was most present occurred. This percentage of time is set as the maximum and is colored red.

![Circumplex Model of Affect](image)

*Figure 5.2 The Circumplex Model of Affect window in which the options Show current position, Show history, Show expression label and Show heatmap are selected. The heatmap colors are based on the affect that was occurring most.*

**References**


TIMELINE

The Timeline gives an overview of the Facial Expressions, and Facial States on a timeline. Each event, stimulus, state, or expression is shown in a different color. You can play back through the timeline together with playing back the video.

Options

Click Expressions and choose which expressions you want to view. By default all expressions are selected. Unknown means that no face is found or the face cannot be modeled (for instance, because the quality of the video is poor). When analyzing a video file, Not Analyzed indicates (in blue) what part of the video has not yet been analyzed.

With Facial States, choose whether you want to display the Gaze and Facial States. By default, this option is selected.

If you have the Action Unit Module, the timeline also shows the intensity of the Action Units.

If you have the Project Analysis Module, the timeline also shows the Events and Stimuli.

See EXPORT (DETAILED LOG, ODX, N-LINX AND API) on page 200, for information on how to select which of the variables that are displayed in the timeline are added to the log files.
VALENCE LINE CHART

To view the Valence Line chart
Click the Select window button on one of the lower visualization windows and select Valence Line Chart.

By default, the Valence Line chart is visible on your screen.

See the figure below for an example. When you play back the video, a hairline shows the time in the video.

The valence indicates whether the emotional status of the subject is positive or negative. 'Happy' is the only positive emotion, 'Sad', 'Angry', 'Scared' and 'Disgusted' are considered to be negative emotions. 'Surprised' can be either positive or negative. The valence is calculated as the intensity of 'Happy' minus the intensity of the negative emotion with the highest intensity. For instance, if the intensity of ‘Happy’ is 0.8 and the intensities of ‘Sad’, ‘Angry’, ‘Scared’ and ‘Disgusted’ are 0.1, 0.0, 0.05 and 0.05, respectively, then the valence is 0.7.
If you select one of the analysis intervals in the **Overview** pane, a blue block shows the analyzed interval. See Figure 5.3 for an example. If no intervals are selected, the chart shows the results of all the intervals in the **Overview** pane.

![Figure 5.3 Valence Line chart with an analysis interval selected in the **Overview** pane.](image)

**Options**

Click **Options** and then select **Auto Scale Y axis** to adjust the Y axis to the maximum value.

**AROUSAL LINE CHART**

Arousal indicates whether the test participant is active (+1) or not active (0). Arousal is based on the activation of 20 Action Units (AUs) of the Facial Action Coding System (FACS).

**How Arousal is calculated**

1. The activation values (AV) of 20 AUs are taken as input. These are AU 1, 2, 4, 5, 6, 7, 9, 10, 12, 14, 15, 17, 18, 20, 23, 24, 25, 26, 27, and the inverse of 43. The value of AU43 (eyes closed) is inverted because it indicates low arousal instead of high arousal like the other AUs.

2. The average AU activation values (AAV) are calculated over the last 60 seconds. During the first 60 seconds of the analysis, the AAV is calculated over the analysis up to that moment.

\[
AAV = \text{Mean}(AV_{past\ 60\ seconds})
\]

3. The average AU activation values (AAV) are subtracted from the current AU activation values (AV). This is done to correct for AUs that are continuously activated and might indicate an individual bias. This results in the Corrected Activation Values (CAV).

\[
CAV = \text{Max}(0, AV - AAV)
\]
4. The arousal is calculated from these CAV values by taking the mean of the five highest values.

\[ Arousal = \text{Mean}(5 \text{ max values of CAV}) \]

**To view the Arousal chart**

Click the Select window button on one of the lower visualization windows and select Arousal Line Chart.

By default, the Arousal Line Chart is not shown on your screen.

When you play back the video, a hairline shows the time in the video.

If you select one of the analysis intervals in the Overview pane, a blue block shows the analyzed interval. If no intervals are selected, the chart shows the results of all the intervals in the Overview pane.
Options

Click Options and then select Auto Scale Y axis to adjust the Y axis to the maximum value.

**EXPRESSIONS LINE CHART**

*To view the Expressions Line chart*

Click the Select window button on one of the lower visualization windows and select Expressions Line Chart.

See Figure 5.5 for an example. In the Expressions Line Chart you can view one or more facial expressions over time. Each emotion is plotted in a different color. When you play back the video, a hairline shows the time in the video.

If you select one of the analysis intervals in the Overview pane, a blue block shows the analyzed interval. See Figure 5.5 for an example. If no intervals are selected, the chart shows the results of all the intervals in the Overview pane.
Options

From the Expressions list choose the emotions you want to view.

Click Options and then select Auto Scale Y axis to adjust the Y axis to the maximum value.

HEAD ORIENTATION LINE CHART

To view the Head Orientation Line chart

Click the Select window button on one of the lower visualization windows and select Head Orientation Line Chart.
When you play back the video, a hairline shows the time in the video.

If you select one of the analysis intervals in the **Overview** pane, a blue block shows the analyzed interval. If no intervals are selected, the chart shows the results of all the intervals in the **Overview** pane.

**Options**

With **Head Orientations**, select whether you want to view the changes in orientation in X, Y and/or Z direction.

Click **Options** and then select **Auto Scale Y axis** to adjust the Y axis to the maximum value.
5.2 Reporting Client

FaceReader’s Reporting Client informs you of the emotional status of the subject with simple and immediate indicators.

**MAIN ACTIONS**

To view the Reporting Client
Choose View > Reporting Client.

The Reporting Client consists of three sections: Valence Monitor, Smiley, and Valence Pie.
To move the Reporting Client
If you like, you can display the Reporting Client window on a second monitor.

At the top of the Reporting Client window, click the Change Dock State button .
Click the window title and drag the window to the position you require.

Display options
- To hide a section of the Reporting Client, click the Show/Hide button.

- To change the order of the three sections, at the top of the Reporting Client window, click the Change Dock State button two times.

The four sections are now independent of each other. Click a title and drag the window to the position you require.

- To display the Reporting Client on top or on the background, click Settings .

  Under Display Style select or deselect Always on top and click OK.

- To reset the Valence Pie, click New Session.
VALENCE MONITOR

The Valence Monitor is a three-light indicator. The light is

- green if the valence of the analyzed frame is above 0.33.
- orange if the valence is between -0.33 and +0.33.
- red and flashing if the valence is below -0.33.

SMILEY

The Smiley dynamically visualizes the test participant’s facial expressions. Each expression has a number of features (except ‘scared’): Happy — Smiling mouth; Sad — Corners of the mouth down and tears dropping from the eyes; Angry — Red face, eyebrows lowered; Surprised — Big eyes, raised eyebrows; Disgusted — Tongue sticking out.
VALENCE PIE

The Valence Pie shows the average valence value. Green is a positive valence, orange is neutral and red is negative. The average is based on the running average which you can define in the Reporting Client Settings.

To adjust the duration of the running average

Click the Settings button .

Under Timing, set the duration of the running average. The default value for the running average is 02:00 minutes.
5.3 Export the numerical output

**EXPORT ANALYSIS RESULTS**

**Before exporting results**
- What results you can export depends on the Data Export options selected in the general settings. Choose File > Settings > Data Export. Under Export (Detailed log, ODX, N-Linx and API) choose the data you want to export.
- Before exporting results, make sure that the values of all independent variables are defined. If at least one independent variable is not scored for a participant, it is marked with a warning icon.

**To export analysis results**

1. Choose File > Export >
   - **Analysis** — To export the results of the analysis currently open.
   - **Participant** — To export the results of all analyses related to the participant currently selected.
   - **Project** — To export the results of the entire project.

2. Browse to the location on your computer where you want to store your log files and click OK. The default location is:
   C:\Users\Public\Documents\Noldus\FaceReader 7\Projects\<Project Name>\Logs.

3. In the Save Logs window, Enter a name for your log files.

4. In the Save Logs window, select one or more of the following formats and click OK:
   - **Save detailed log (.txt)** — See below for more information about the Detailed log in text format.
   - **Save state log (.txt)** — See page 96 for more information about the State log in text format.
   - **Save Observer log (.odx)** — By default, The Observer log contains information from the State log as well as the Detailed log. If you are only interested in the State log data, you can deselect the Save detailed values to Observer log check box. See page 96 for more information about the Observer log.

When you export the results of a participant, or an entire project, an extra option Save all analyses to a single Observer log is available. This way you can import all analyses results at once into The Observer XT. The different participants and analyses are imported into separate observations.
Each observation contains the name of the participant and analysis.

**Export file names**

The default name for the export log files is:

- for the Detailed log:
  
  `[Participant number]_[Participant name]_[Analysis name]_[Analysis type]_YYYYMMDD_hhmss_detailed.txt`

- for the State log in text format:
  
  `[Participant number]_[Participant name]_[Analysis name]_[Analysis type]_YYYYMMDD_hhmss_state.txt`

- for The Observer log:
  
  `[Participant number]_[Participant name]_[Analysis name]_[Analysis type]_YYYYMMDD_hhmss_odx`

where [Participant number] is the number given automatically (Participant 1, 2 etc.);
[Participant name] is the name entered under **Name** when adding that participant; [Analysis name] the name of the selected analysis, [Analysis type] specifies whether an image, video, or camera analysis has been carried out, and YYYYMMDD_hhmss is the date/time code of the start of the analysis.

- YYYY = year including the century.
- MM = month with leading zero.
- DD = day with leading zero.
- hh = hours, 12-hour format with leading zero.
- mm = minutes with leading zero.
- ss = seconds with leading zero.

**EXPORT FILES**

**Detailed log**

The Detailed log (see Figure 5.6 for an example) contains all the emotional classifier outputs. Each emotion is expressed as a value between 0 and 1, indicating the intensity of the emotion. ‘0’ means that the emotion is not visible in the facial expression, ‘1’ means that the emotion is fully present. When no face is found or the face cannot be modeled (e.g. because the quality of the video is poor), a record with FIND_FAILED or FIT_FAILED is added. If you analyze a video file and skip frames (that is, you set the Sample rate to Every 2nd frame or Every 3rd frame), the logging frequency changes accordingly. If you work live (using a camera) and your computer cannot process the incoming images fast enough, frames will be skipped and a record with MISSING will be added to the Detailed log.

You can add more information to the log files, like Facial States, Head Orientation, or Valence values. See EXPORT (DETAILED LOG, ODX, N-LINX AND API) on page 200, for a full description of the options to add to the detailed log files.

The Detailed logs are text files with the data separated by tabs. You can view the data in most spreadsheet programs and text editors, for instance, Excel or Notepad. You can also
import Detailed logs into The Observer XT, our software package for collecting observational data.

**State log**

The State log shows the emotional state the test person is in (see Figure 5.7 for an example). A record is added to the log each time the dominant emotion changes and is active for at least 0.5 seconds. If no face is found or the face cannot be modeled (for instance, because the quality of the video is poor), a record with **UNKNOWN** is added to the State log.

State logs are text files with the data separated by tabs.

![Image of State log](image)

*Figure 5.7 An example of a State log.*

---

If you want to use other criteria to define a state, for example when the intensity of an emotion is above 0.5, export the detailed log (see page 95). Then calculate the states in another program, like Excel.

---

**Observer log**

The Observer log contains information from the State log as well as the Detailed log, in XML format. Select this output format if you want to import your data in The Observer XT, our software package for collecting observational data. If you want to import all analyses results from multiple participants and analyses at once into The Observer, select the option **Save all analysis to single Observer log** (see page 93).
Chapter 6

The Project Analysis Module

6.1 Introduction ......................................................................................... 98
6.2 Stimuli .................................................................................................. 100
6.3 The Stimulus Presentation Tool........................................................... 104
6.4 Event markers ...................................................................................... 117
6.5 Independent Variables......................................................................... 119
6.6 Participant groups ............................................................................... 121
6.7 Numerical group analysis ................................................................. 122
6.8 Temporal group analysis...................................................................... 130
6.9 Analysis advisor for project analysis................................................... 136
6.1 Introduction

THE PROJECT ANALYSIS MODULE

With FaceReader’s Base Module, you need to export the log files in order to calculate a number of statistics on the facial states. For example, to calculate the mean intensity of the facial state Happy, you must export the detailed values and calculate the mean intensity of this state in a program like Excel.

With the Project Analysis Module, you can:

- **Automate your tests.**
  
  Automatically present stimuli to the test participant and synchronize them with FaceReader data (for this purpose use the with Stimulus Presentation Tool; see page 104).

- **Calculate statistics in FaceReader itself.**
  
  Calculate mean intensities of facial expressions of single participants, but also for a group of participants, or during certain episodes.

- **Calculate relative statistics.**
  
  You can, for example, calculate the expression intensities of test participants when they watched a certain commercial relative to the expression intensities when they were watching a neutral stimulus. You can mark the time during which the test participants watched the commercial with a stimulus. See “Numerical group analysis” on page 122 for a full description of the calculations you can do with the Project Analysis Module.

---

When your project contains image analyses only, you cannot analyze the data in the Project Analysis.

---

INDEPENDENT VARIABLES AND PARTICIPANT GROUPS

*Independent variables*

Independent variables (see page 119) are factors that remain constant throughout an analysis, but can vary per participant. By default, each project contains the independent variables age and gender of the participant. These can be estimated by FaceReader, from the analyzed images. Alternatively, you can enter the values of these variables manually.

With the Project Analysis Module you can define more independent variables. Typical examples of independent variables are the native language of the test participant, or whether the participant has previous experience with the product tested.
Participant groups

The Project Analysis Module allows you to create groups of participants (see page 121), based on the value of the independent variables. This way you can, for example compare the facial expressions of males with those of females. Or you can compare the expressions of groups with and without previous experience with a product tested. You can also create participant groups manually. The project always contains a group with all participants.

CALIBRATION AND PROJECT ANALYSIS

If you carry out project analysis, do not use participant calibration, or continuous calibration. Instead, define a stimulus Neutral (see DEFINE STIMULI on page 100). Score this stimulus (see Section 6.7 below) when the test participant watches a neutral set of images or a neutral video fragment. In the analysis, calculate the facial expressions during the experimental phase relative to the facial expressions during the neutral stimulus. See page 139 for this procedure.

MARK EPISODES

If you carry out video or camera analysis, and have the Project Analysis Module, you can mark episodes that you are especially interested in. This can be, for example, a time fragment during which the test participant watches a certain commercial. Or it can be the time a participant is allowed to drink or eat a certain product you are interested in.

Stimuli

With stimuli you can mark time fragments in the analysis. This can, for example, be the time a commercial is shown. These time fragments have a fixed duration. You can use a video fragment as stimulus source, for example video with commercial. You score a stimulus manually during or after carrying out the analysis. You can analyze the facial expressions over the time the stimulus occurred. For details, see page 100.

Note that if you use the Stimulus Presentation Tool (see page 104) any stimulus included in the test is automatically recorded by FaceReader, so you do not need to score it manually.

Event markers

With event markers you can mark time fragments in the analysis, just like with stimuli. In contrast to stimuli, event markers have no fixed duration and are not linked to a video. With event markers you can, for example, mark episodes where something unexpected occurs, like a visitor entering the room, or mark events that have no fixed duration, like drinking a fruit juice. You score an event marker manually and score it again, or score another one to set the stop time of the marker. For details, see page 117.
Stimuli and event markers in The Observer XT

Stimuli and event markers can be exported into the state log. If you use FaceReader together with The Observer XT, the stimuli and events are imported as state events. These can then be used in to select the time fragments for further analysis in The Observer XT. See Chapter 9 for more information.

6.2 Stimuli

DEFINE STIMULI

By defining stimuli, you can mark the parts of the analyses you are especially interested in. Stimuli are, for instance, the new commercials the test participants will watch or the pages of your newly developed website they will view. With FaceReader’s Project Analysis Module you can compare the analyses over these time periods with other data.

To define stimuli:

1. Choose Project > Stimulus > Add Stimulus or click on the bottom-left pane.

2. Under Name, enter the stimulus name, for instance, ‘Commercial 1’.
3. Under **Trigger key**, enter a keyboard key for this stimulus, that is the key that you press when the stimulus (commercial 1 in this example) starts.

4. Under **Color**, select a color for the stimulus and click **OK**. This color will be used throughout the program for this stimulus.

5. Select to present either a video, or an image as stimulus, or no external stimulus.

*If your stimulus is a video or part of a video*

1. Select the **Video**, for instance, the video with the six commercials which your test participants will watch.

2. Enter the **Start time in video** (in hours:minutes:seconds with two decimals).
   In our example this is the start time of Commercial 1. If this commercial starts half a minute after the start of the video, enter **00:00:30.00**. Leave **00:00:00.00** if the video start with this stimulus.

3. Enter the **Duration** (in hours:minutes.seconds with two decimals). In our example this is the duration of Commercial 1.
   If the entire video file is a stimulus, do not edit **Duration**.

*If your stimulus is an image*

1. Select the image, for example a screen capture of a web page, or a wrapping of a chocolate bar.

2. Enter the **Duration** (in hours:minutes.seconds with two decimals).

*If your stimulus is not linked to a video or image*

Enter the **Duration** (in hours:minutes.seconds with two decimals).

**To delete or edit a stimulus**

1. Open the **Stimuli** tab at the bottom of the project explorer.

2. Right-click the stimulus you want to delete or edit, and select the option you require.

**SCORE STIMULI**

Scoring stimuli allows you to analyze periods of time when a stimulus was presented and compare data between them. With the Stimulus Presentation Tool (see page 104) stimuli are scored automatically in FaceReader when a stimulus is presented on the screen.

If you do not use the Stimulus Presentation Tool, you can also score stimuli manually while you carry out a video analysis or a camera analysis. You can also score the stimuli after you
finished an analysis. Scored stimuli appear in the project explorer as dots above the analysis bar. Expand the **Analysis** and **Scored Stimuli** items to view the scored stimuli.

To score a stimulus during an analysis
- **Automatically** — Use the Stimulus Presentation Tool (see page 104)
- **Manually** — Press the trigger key that is associated with your stimulus.
  
  If you have the **Timeline** window open, a bar appears with the same length as the stimulus duration that you chose when you created the stimulus. You can press the stimulus trigger key for each time the stimulus starts.

To score a stimulus after an analysis
Open the **Timeline** window and scroll the video to the position where the stimulus starts. Then press the stimulus trigger key. A question appears whether you want to score the stimulus at that point. Choose **Yes**.

To Copy scored stimuli
You can copy the scored stimuli to other participants or analyses. To do so, unfold the analysis and double-click **Scored Stimuli**. Click the stimulus you want to copy. Click **Scored Stimuli** at the top of the window that opens, and choose one of the options under **Copy To**.
**Restrictions for scored stimuli**

- Multiple instances of the same stimulus may not overlap. Therefore, do not start a stimulus when the previous instance of this stimulus has not ended.

- Do not score a stimulus when the remaining video time is shorter than the stimulus duration.

To make sure the analysis is not interrupted, FaceReader does not give a warning during the analysis if you score overlapping stimuli or score a stimulus that continuous after the end of the analysis. Instead, an error mark will appear in the Project Explorer and you must correct the scored stimuli after the analysis is finished.

Double-click **Scored Stimuli** or one of the lines. Alternatively, right-click **Scored Stimuli**, then select **Edit Analysis**, and then **Edit Scored Stimuli & Event Markers**. The **Scored Stimuli** window opens. The time periods in which stimuli of the same type are overlapping are marked in red.
Move the stimuli to their correct position, so that they are no longer overlapping. To delete a stimulus, click the **Delete Scored Marker** button.

If a stimulus is scored when the remaining video time was shorter than the stimulus duration, opening the **Scored Stimulus** window automatically moves the stimulus start time to the latest possible moment in that video.

### 6.3 The Stimulus Presentation Tool

**INTRODUCTION**

*What is the Stimulus Presentation Tool?*

FaceReader is often used to analyze how a subject responds to one or more stimuli in form of video, for example video commercials. Synchronizing the display of a stimulus with the trigger of the corresponding stimulus marker in FaceReader is essential.

With FaceReader and the Stimulus Presentation Tool, you can:

- Define the stimuli to be presented, organized in a test (see below).
- Present the stimuli while FaceReader analyzes the test participant’s face.
- Automatically synchronize FaceReader data with stimulus trigger markers.

**Tests**

A test is a collection of video stimuli being presented to a test participant. You can store one or more tests in your FaceReader project. The Stimulus Presentation Tool displays the stimuli during the test while FaceReader records and/or analyzes the participant’s face.

Furthermore:

- A test includes *independent variables*, like gender, age, or any other variable of interest defined in the project.
- Presentation of stimuli can be randomized.

**Software you need**

- FaceReader with the Project Analysis Module.
- The Stimulus Presentation Tool.
- Recommended for two-PC configurations: a **Network Time Protocol** to synchronize computers (see page 112).
To install the Stimulus Presentation Tool

1. Insert the FaceReader installation USB stick in the test participant’s PC.

2. Run the file **Stimulus Presentation Tool 2 Setup.exe**.

   If you upgraded FaceReader from version 6.1 and have Stimulus Presentation Tool 1, there is no need to uninstall version 1. However, Stimulus Presentation Tool version 1 works only with FaceReader 6.1. Stimulus Presentation Tool version 2 works with FaceReader 7.

3. Follow the instructions on the screen.

   By default, the Stimulus Presentation Tool is installed in the following location:

   C:\Program Files (x86)\Noldus\Stimulus Presentation Tool 2.

**FaceReader settings**

Before connecting FaceReader with the Stimulus Presentation Tool, do the following:

1. Choose **File > Settings > Data Export**.

2. Under **External Communication (API and Stimulus Presentation Tool)**, select **Enable External Control**.

3. Make sure the value of **External Connection Port** is the same as that in the Stimulus Presentation Tool. By default, this is **9090**. If you prefer, you can enter another port number. Enter this number also in the Stimulus Presentation Tool (see below).
One computer

In this configuration, the test participant uses a computer (for example the Noldus Portable Observation Lab) where both FaceReader and the Stimulus Presentation Tool are installed.

When starting the Stimulus Presentation Tool:

- Under **FaceReader IP/Host** enter **127.0.0.1**. This is identified as the same PC.
- Under **FaceReader Port** leave **9090** or enter the number entered in FaceReader.

![Connect to FaceReader](image)
**Two computers**

In this configuration, the computer of the test participant has the Stimulus Presentation Tool installed and running. On the test leader computer, FaceReader is installed and running. The two computers are connected through a network.

![Diagram of two computers connected through a network](image)

*Figure 6.1 Left: Test participant’s PC with the Stimulus Presentation Tool. Right: Test leader’s PC with FaceReader installed, and the FaceReader hardware key plugged in.*

To allow proper communication between the FaceReader PC and the test participant’s PC, create exceptions to the Windows Firewall for port 9090. For details, see page 111.

When starting the Stimulus Presentation Tool:

- Under **FaceReader IP/Host** enter the IP address of the FaceReader PC.
- Under **FaceReader Port** leave **9090**.

**Synchronization (two-computer configuration)**

In order for FaceReader correctly synchronize face analysis with stimulus presentation, the clocks of the test participant PC and the FaceReader PC must be in sync. We recommend to set the two clocks to the same time using a **Network Time Protocol (NTP)** server.

For details, see **SYNCHRONIZE COMPUTERS WITH A NETWORK TIME PROTOCOL** on page 112.
DEFINE A TEST

Prerequisites
1. You have defined one or more stimuli (see page 100).
2. You have opened the project in FaceReader that contains those stimuli.

To define a test

1. In FaceReader, choose Project > Tests > Add Test, or on the bottom-left pane, click the Test tab and click the Add Test button.
2. Give a Name to the test (default: Test 1, Test 2,...).
3. Select the Default camera you want to use. In the Select Camera window, choose the options that apply and click OK.
4. Add stimuli.
   From the Select Stimuli list, select the first stimulus video you want to add, and click the Add button. The name of the stimulus appears under Stimuli Order.
   Repeat this step for the next stimulus.
5. **Specify the independent variables for the test.**

Under **Independent Variable Usage**, click an independent variable and choose how you want to determine the value for a participant.

- **Automatic** (only for Gender and Age). FaceReader enters the values automatically for each participant, based on the analysis.
- **Entered by Participant** — The participant is asked to enter the value of this variable at the start of the test.
- **Leave blank** — To leave the value blank and edit it later.
- **[value or category]** — Specify one of the values available; note that the value you specify here will be assigned to all analyses and participants who take part to that test. Use this option for example to compare data between tests which differ by that variable.

6. **Specify other test options.**

Under **Options**, choose the options that apply:

- **Randomize stimulus order** to present the stimuli in a random order.
- **Let Participants enter their name** at the start of the test.

7. Click **OK**.

**Notes**

- Video formats accepted by FaceReader: QuickTime (mov), MP4, VOB (from camcorders), H.264 DivX, MPEG-4 DivX, MPEG-1, MPEG-2, DV-AVI.
- Once the stimuli are listed under **Stimuli Order**, you cannot change their order. To put them in a specific order, delete the stimuli and re-add them in that order.
- To add stimuli that are not in the list, close the **Add New Test** window, then add the stimuli you need (see page 100), then on the bottom-left pane click the **Test** tab and double-click the test to the re-open the test window, and complete step 4.
- To add independent variables, close the **Add New Test** window, then add the independent variables (see page 119). Next, on the bottom-left pane click the **Test** tab and double-click the test to the re-open the test window, and complete step 5.
- To delete a stimulus from the test, under **Stimuli Order** click the **Delete** button for that stimulus.

**To Edit and delete tests**

- To edit an existing test, double-click the test name on the bottom-left pane (**Test** tab).
- To delete a test, on the bottom-left pane (**Test** tab) right-click the test name and select **Delete Test**.
RUN A TEST

Prerequisites

- You have defined at least one test in your FaceReader project.
- If you run a test in a two-PC configuration, make sure the two computers are connected, and that appropriate exceptions in Windows Firewall are set on both PCs (see page 111).

To run a test

1. On the test leader’s PC, open the FaceReader project.
2. On the participant PC, start Stimulus Presentation Tool.
3. In the Connect to FaceReader window, under FaceReader IP/Host enter the IP address of the FaceReader computer. For details, see COMPUTER CONFIGURATIONS on page 106.

   When necessary, change the Temporary storage path of the participant PC where data are stored during the test.

   When ready, click Connect.
4. In the Select Test window, choose a test from the Available Tests list, then click Start.

   If the test you require is not listed, in FaceReader open the project that contains that test. Next, in the Stimulus Presentation Tool click the Refresh button.
5. Let the participant sit in front of the computer.
6. In the Welcome window, let the participant enter
   - his/her name (optional; see step on page 109)
   - the values of the independent variables set to Entered by Participant in the test definition (see page 109).

   When ready, ask the participant to click Start.

   The Start button is available when the participant has entered the values of all required independent variables.
7. After a couple of seconds the first stimulus video is displayed.
8. At the end of the test a message Thanks for Participating appears.

   - To start the test for the next participant, click the Next button.
   - To choose another test, click anywhere on the Stimulus Presentation Tool window, then press Alt+Home, then click Connect.
   - To close the Stimulus Presentation Tool, click the Close button.

The participant and analysis are added automatically in FaceReader.
Notes

- You can connect FaceReader with one Stimulus Presentation Tool at a time.
- During the test, FaceReader shows the message **Test in Progress**. To change the views in FaceReader, click **OK** and select the windows you require. Do not change settings.
- Analysis is done automatically during the test. Do not click the **Start/Stop analysis** button during the test.
- Between presentation of two stimuli, a message “Video will start shortly” is shown for a fixed time.
- After the test participant has clicked **Start** in the **Welcome** window (step 6), and before the first stimulus is presented, a new FaceReader analysis is created and started in the background on the FaceReader PC.
- When a video starts, the Stimulus Presentation Tool sends the information to FaceReader, which scores the start of the stimulus.

- To switch the **Stimulus Presentation Tool** window to full screen, press **F11**. Press **F11** again to resume the original window size.

  - To go from **Select Test** to **Connect to FaceReader**, click at the bottom-left corner of the **Stimulus Presentation Tool** window.
  
  - To go from the **Welcome** window back to **Select Test**, click anywhere on the window, then press **Alt+Home**, then click **Connect**.

  - To stop the test before the end of the last stimulus, in FaceReader click the **Stop analysis** button or in the Stimulus Presentation Tool click anywhere on the window, then press **Alt+Home**. The analysis and participant are marked with an error icon.

**FIREWALL EXCEPTIONS FOR STIMULUS PRESENTATION TOOL**

If the Stimulus Presentation Tool is installed on a computer other than the one with FaceReader, for both computers you must create an **Inbound Rule** and **Outbound Rule** in Windows Firewall for port 9090 (or the port you choose if 9090 is not available; see page 106).

**To create an Inbound/Outbound Rule for a port in Windows Firewall**

1. In the Windows’ **Search** field, type **firewall**, and under the results click **Windows Firewall**.

2. Turn on the firewall for all networks, then click **OK**.
3. Click Advanced Settings.

4. On the left panel of the Windows Firewall and Advanced Security window, click Inbound Rules and on the right panel under Actions choose New Rule.

5. In the New Inbound Rule Wizard, on the Rule Type page, choose Port, then click Next>.

6. Select Specific local ports and enter 9090 (or the port chosen, if different), then click Next>.

7. On the Action page select Allow the connection, then click Next>.

8. On the Profile page choose the network the rule applies to, then click Next>.

9. On the Name page, enter a Name (for example Port9090). Then click Finish.

10. On the left panel of the Windows Firewall and Advanced Security window, click Outbound Rules and on the right panel under Actions choose New Rule. Repeat the procedure to complete the Outbound Rule. Make sure you choose the same options as for the Inbound Rule.

11. Repeat all steps above for the other PC.

SYNCHRONIZE COMPUTERS WITH A NETWORK TIME PROTOCOL

Introduction
For reliable analysis of FaceReader data in relation to stimulus timing, a good degree of synchronization between FaceReader and the Stimulus Presentation Tool is essential when the two programs are installed on different computers. Synchronized clock times are important to align the moment of scoring a stimulus in FaceReader with the moment of showing a stimulus on the test PC. To synchronize the test PC to the FaceReader PC, you can use NetTime, a simple Network Time Protocol (SNTP).

Basic steps to be followed on both PCs
1. Install NetTime.
2. Adjust the NetTime Settings.
3. Create exceptions in the Windows firewall.
4. Before the start of a test with Stimulus Presentation Tool, synchronize the two PCs. You can also choose to do this automatically at regular intervals (minimum 15 minutes).

See below for the steps in detail. Note that Noldus has tested the Stimulus Presentation Tool with NetTime version 3.14.

**To install NetTime**

Do the following on both FaceReader and test PCs:

1. Browse to [http://www.timesynctool.com](http://www.timesynctool.com), and download the latest version of NetTimeSetup.exe.

2. Run the installation file. During installation, select **Install as Service (Recommended)**.

**NetTime Settings**

1. On the taskbar, click the **Network Time Synchronization** icon.

2. Click **Settings**.
3. Under Hostname or IP Address:
   - For the FaceReader PC — Leave the Time Servers names as shown in the next table.
   - For the test PC — In the first Time Servers field, enter the name of the FaceReader PC, and delete all other external Time Servers. See the following table.

To find the name of a PC, for Windows 8 choose PC Settings > PC and devices > PC Info, and for Windows 7 right-click My Computer and choose Properties.

<table>
<thead>
<tr>
<th></th>
<th>FaceReader PC</th>
<th>Test PC</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Time Servers</strong></td>
<td>0.nettime.pool.ntp.org</td>
<td>[FaceReader PC’s name]</td>
</tr>
<tr>
<td></td>
<td>1.nettime.pool.ntp.org</td>
<td>[empty]</td>
</tr>
<tr>
<td></td>
<td>2.nettime.pool.ntp.org</td>
<td>[empty]</td>
</tr>
<tr>
<td></td>
<td>3.nettime.pool.ntp.org</td>
<td>[empty]</td>
</tr>
</tbody>
</table>

| **Update Interval** | 15 minutes | 60 seconds |

4. Choose SNTP as Protocol and 123 as Port.

5. Next to Update Interval enter (see also the table above)
   - For the FaceReader PC — 15 minutes.
   - For the test PC — 60 seconds.

6. For the FaceReader PC only — Select Allow other computers to sync to this computer.

7. For both PCs —
   - Select Show NetTime icon in the system tray at login and Start NetTime service at bootup.
   - De-select Demote Servers after [ ] failures.
   - Next to If time adjustment greater than, select 10 milliseconds, then Adjust System Time.

8. Click OK. When a warning appears about Update Intervals being lower than 10 minutes (on the test PC), click No.

**Firewall exceptions**

To prevent that syncing fails because of the Firewall, create exceptions on both PCs as follows. The following procedure is valid for Windows 8.

1. In the Windows’ Search field, type firewall, and under the results click Windows Firewall.

2. Turn on the firewall for all networks, then click OK.

3. Click Advanced Settings.
4. **Inbound Rule**
   
   a. On the left panel of the *Windows Firewall and Advanced Security* window, click *Inbound Rules* and on the right panel under *Actions* choose *New Rule*.
   
   b. In the *New Inbound Rule Wizard*, on the *Rule Type* page, choose *Program*, then click *Next*.
   
   c. On the *Program* page, select *This Program path*, click *Browse* and select the file `C:\ProgramFiles (x86)\NetTime\NetTimeService.exe`. Then click *Next*.
   
   d. On the *Action* page select *Allow the connection*, then click *Next*.
   
   e. On the *Profile* page select all options *Domain*, *Private*, and *Public*. Then click *Next*.
   
   f. On the *Name* page, enter a *Name* (for example NetTime Service). Then click *Finish*.

5. **Outbound Rule**

   a. On the left panel of the *Windows Firewall and Advanced Security* window, click *Outbound Rules* and on the right panel under *Actions* choose *New Rule*.

   b. Repeat the step 4 above to complete the Outbound Rule. Make sure you choose the same options as for the Inbound Rule.

6. Repeat all steps above for the other PC.

   If you followed all procedures for establishing Firewall exceptions (page 111 and page 112), each computer should have two Inbound Rules and two Outbound Rules:

   - One for the port (for communication between FaceReader and Stimulus Presentation Tool)
   - One for NetTime Service.

---

**To synchronize the test PC to the FaceReader PC**

1. Always start the test PC after starting the FaceReader PC. This ensures that the test PC always finds its time server.

2. On the test PC, click the *Network Time Synchronization* icon on the taskbar.
3. Make sure that the first item under **Server Name** is the name of the FaceReader PC. If this is not the case, click **Settings** and enter the FaceReader PC’s name for the first time server (see **NetTime Settings** on page 113).

4. Click the **Update Now** button.

5. The **Offset** and **Lag** are updated.
   - **Offset** is the estimated difference in time between the clocks that cumulated up to the time of the update. This is the accuracy of synchronization of the Stimulus Presentation Tool with FaceReader. A positive value means that the FaceReader PC clock is faster than the test PC.
   - **Lag** (also known as delay) is the traveling time of time packets from the client to the server and from the server back to the client. The shorter this lag, the more accurate the estimate of the offset between clocks.

6. You are now ready to start the test with the Stimulus Presentation Tool (see page 110).

**Notes**

- After clicking **Update Now**, always make sure that on the Network Time window the **Status** cell for the FaceReader PC says **Good**.

- To change the order of the servers in the **NetTime Options** window, copy and paste the name of one cell to the other.

- Click **Update Now** every time you start a test to keep the time offset between FaceReader and Stimulus Presentation Tool as low as possible.
6.4 Event markers

DEFINE EVENT MARKERS

Event markers are used to indicate that, for instance, the participant was distracted or was trying food product A. With event markers, you can mark the parts of the analyses you are especially interested in. In FaceReader you can compare the analyses over these time periods with other data.

To define an event marker
1. Choose Project > Event Marker and then Add Event Marker.

2. In the Name field, enter the event marker name, for instance, ‘Food product A’.

3. Enter the Trigger key for this marker, that is the key on your keyboard that you press when the event (‘Test participant takes food product A’ in this example) starts.

4. Select a color for the marker and click OK. This color will be used throughout the program for the event marker.

To delete or edit an event marker
1. Open the Event Markers tab at the bottom of the project explorer.
2. Right-click the event marker you want to delete or edit and select the option you require.

**SCORE EVENT MARKERS**

You can score event markers while you carry out a video analysis, or camera analysis. You can also score the event markers after you finished an analysis. You score event markers by pressing the associated trigger key. The event is stopped by pressing the same key a second time, by pressing a trigger key that is associated with another event marker, or by the end of the analysis. Scored event markers appear as dots below the analysis in the project explorer.

**To score during an analysis**
Press the trigger key that is associated with your event marker. If you have the Timeline window open, a bar appears in the line event markers. Press the same trigger key to stop the Event, or press another key to start another event.

**To score after an analysis**
Open the Timeline Window and scroll the video to the position where the event starts. Then press the event marker trigger key. A question appears whether you want to score the event marker at that point. Choose Yes. Scroll to the position where the event marker should stop and press the same trigger key, or press another key to start another event.

**To edit a scored event marker**
Double-click the Scored Event markers folder. In the window that opens, edit the markers by dragging them to the correct position. Follow the same procedure as described in Restrictions for scored stimuli on page 103.

**To copy a scored event marker**
To copy a scored event marker to other participants or analyses, follow the same procedure as described in To Copy scored stimuli on page 102.
6.5 Independent Variables

**DEFINITION**

Independent variables are factors that can vary but are constant per participant. Examples are the nationality of the participant, or the previous experience with a product or commercial. By default, each project contains the independent variables age and gender of the participant. These can be estimated by FaceReader, from the analyzed images. Alternatively, you can enter the values of these variables manually. You can use the independent variables to group participants, for example to create groups of males and females, or to make groups with and without previous experience with the product.

With the Project Analysis Module you can define more independent variables.

**DEFINE INDEPENDENT VARIABLES**

*To define an independent variable*

1. Choose **Project > Independent Variable > Add Independent Variable**.
2. Give a name to the variable, for example *Experience level*.
3. Choose one of the following
   - **Numerical** – Numerical variable values can have decimals and can also be negative.
   - **Nominal** – Enter the independent variables categories in the *Categories* field. Click the plus button to add the category. Enter a minimum of two independent variable categories.

![Image of Independent Variable Information]

- **NAME**
  - Native Language

- **CATEGORY**
  - **Numerical**
  - **Nominal**
  - Categories:
    - French
    - English
    - Dutch
    - German

- **OK**
- **Cancel**
To delete or edit an independent variable

1. Open the Independent Variables tab at the bottom of the project explorer.

2. Right-click the independent variable you want to delete or edit and select the option you require.

The default independent variables Age and Gender cannot be edited or deleted.

SCORE INDEPENDENT VARIABLES

Independent variables must be scored for each participants. Participants for which one or more independent variables have not been scored are left out in the numerical and temporal group analysis (see page 122 and page 130).

To score an independent variable, expand the Participant item in the Project Explorer and double-click Independent Variables. Click the pencil button next to the independent variable and select the category. In the example above, this would mean defining the native language of each participant.

! The Independent Variables item in the Project Explorer displays a warning icon if the values have not been scored yet for a participant. Also the participant group item will display a warning icon. Open the participant item and double-click Independent Variables. Then fill in the values.
6.6 Participant groups

Use the values of the independent variables to create participant groups, or create them manually. The project always contains a group with all participants.

**DEFINE PARTICIPANT GROUPS**

1. Choose **Participant group > Add participant group**.
2. Give the group a name, for example, **Male participants**.
3a. **Based on value of independent variable** – Select the option **Criteria based**.
   - Choose the independent variable from the list, and select = or \( \neq \) as operator for nominal variables. For numerical variables you can also select > or < as operator.
   - Select the value from the **Value** field.
   - Click the plus button to add the selection criterion. You can add multiple criteria. The **Matching Participants** field shows which participants match the criteria.
3b. **Manual selection** – Give the group a name and select your participants.

Adding or removing participants to or from your project also adds/removes them to/from participant groups.

**DELETE OR EDIT A PARTICIPANT GROUP**

1. Open the **Participant Groups** tab in the Project Explorer.
2. Right-click the participant group and select the option you require.

### 6.7 Numerical group analysis

With **Numerical group analysis**, you can calculate statistics on the analyzed facial expressions of all participants, participant groups and single participants. Choose **Participant Group > Open Numerical Group Analysis**.

The **Numerical Group Analysis** window appears with the **Group Results** tab open. The top window displays average facial expressions for all participants and the participant groups over the entire analysis. The Bottom window displays graphical results.

**Replicates**

Each participant is taken as a replicate. So if you have one participant with three analyses, the standard deviations will be zero, because there is only one sample. If you have three
participants with two analyses each, the standard deviations will be based on three samples.

**ABSOLUTE VS RELATIVE ANALYSIS**

**Absolute analysis**
1. Optionally select stimuli or event markers in the toolbar of the Group Results window.
2. Click the Group Results window to view the statistics for the entire analysis and the selected stimuli or event markers. The average facial expressions appear for all participants together and for the participant groups.

<table>
<thead>
<tr>
<th>Stimulus/Event Marker</th>
<th>N</th>
<th>Neutral</th>
<th>Happy</th>
<th>Sad</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>MEAN</td>
<td>STDEV</td>
<td>MEAN</td>
</tr>
<tr>
<td>All Analyses</td>
<td>5</td>
<td>0.476</td>
<td>0.176</td>
<td>0.404</td>
</tr>
<tr>
<td>Twins eating</td>
<td>5</td>
<td>0.374</td>
<td>0.192</td>
<td>0.572</td>
</tr>
<tr>
<td>Frying insects</td>
<td>5</td>
<td>0.539</td>
<td>0.251</td>
<td>0.280</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Stimulus/Event Marker</th>
<th>N</th>
<th>Neutral</th>
<th>Happy</th>
<th>Sad</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>MEAN</td>
<td>STDEV</td>
<td>MEAN</td>
</tr>
<tr>
<td>All Analyses</td>
<td>2</td>
<td>0.612</td>
<td>0.122</td>
<td>0.253</td>
</tr>
</tbody>
</table>
3. Click a stimulus name to see which facial expression intensities differ significantly between this stimulus and other stimuli. Click a group name to see which expression differs significantly between this group and another group.

FaceReader carries out a T-test per stimulus with the participants as samples. A colored cell indicates a significant difference. An open triangle indicates a significance level of $P<0.05$. A closed triangle indicates a significance level of $P<0.01$. The direction of the triangle indicates whether the intensity is lower or higher.

<table>
<thead>
<tr>
<th>Arousal</th>
</tr>
</thead>
<tbody>
<tr>
<td>MEAN</td>
</tr>
<tr>
<td>0.312</td>
</tr>
<tr>
<td>0.392</td>
</tr>
</tbody>
</table>

Figure 6.2 In this example, the intensity of arousal is significantly lower between two stimuli. The significant level is indicated with an open triangle, which is $P<0.05$. A closed triangle indicates $P<0.01$.

⚠️ Please note that the appropriate statistical test depends on your data. Your data may not be normally distributed, which means that you need a non-parametric test instead of a t-test. Also, a Bonferroni correction on the P-values may be needed. Consult your statistician for advice.

4. Open the Participant Results tab to view the results per participant.
Relative analysis

Use relative analysis if you want to calculate the intensities relative to the intensities in a certain episode. For example, you want to calculate the expression intensities when the participants watched a commercial relative to the intensities when they watched a neutral stimulus. See page 127 for the mathematical equations for relative statistics and page 136 for some common examples.

1. Open the Participant Groups tab in the Project Explorer.

2. Select what episode to correct your data for in the Relative Analysis Type field of the Project Analysis Settings window.
   - **Versus all other Measurements** — The facial expression intensities during a stimulus relative to all other time fragments (see Figure 6.3 A). Use this option to calculate in which way the facial expressions, for example, during watching a certain commercial differ from the expressions while the participants were not watching it.
     For relative statistics, both the expression value during the stimulus interval and outside the stimulus interval, are calculated for only the participants in the selected participant group (see also “how relative statistics are calculated” on page 127). So the participants that are in other participant groups are not used in the option “versus all other measurements”.
   - **Versus all other Stimuli** — The facial expression intensities during a stimulus relative to the expressions when other stimuli were active (see Figure 6.3 B). This way you can for example calculate the facial expressions of test participants when they watched a certain commercial relative to their expressions when they watched other commercials.
   - **Versus other Stimulus** — The facial expression intensities during a stimulus relative to the expression intensities during another stimulus (see Figure 6.3 C). When you select this option, the Other Stimulus field is enabled in the Project Analysis Settings window. Select the other stimulus from the list. With this option you can for example correct the facial expressions of test participants when they watched a certain commercial for the expressions while watching a neutral scene. See also compare stimuli with a neutral episode on page 139.
   - **Versus interval just before Stimulus/Event episode** — The facial expression intensities during a stimulus relative to the expressions just before the stimulus or event (see Figure 6.3D). With this option you can measure the effect of a stimulus on the participant’s mood, by looking at the changes induced by the stimulus. Enter the duration of the interval before the stimulus or event marker in the Interval field.
3. Select the stimulus or event marker of interest from one of the lists of the toolbar of the Numerical Group Analysis window.

4. Select Relative from the Result type list of the toolbar of the Numerical Group Analysis window. The relative results now appear. Click the Group Results tab for the results of all the participant groups. Click one of the participant group names, or a stimulus name to carry out T-tests on the relative expression intensities. See step 3 on page 124 for more information. Click the Participant Results tab for the results of the separate participants.

⚠️ If you select an option and for some participants there are no data with this option, FaceReader gives a warning. For example, you selected the option Versus other stimulus and for some participants you did not score this stimulus. Choose to include these participants in the absolute analysis only, or to exclude the participants from both the absolute and relative analysis.
HOW RELATIVE STATISTICS ARE CALCULATED

For the relative statistics, the expression intensities during the selected stimulus or event marker are corrected for the average intensities during the time interval selected in the Project Analysis Settings window see step 2 on page 125. Suppose you have three participants with one analysis each and scored the same stimulus for all three participants. You selected Versus all other measurements as Other stimulus in the Project Analysis Settings window. As an example, calculation of the relative mean value of Happy is done in the following way:

Numerical group analysis

Participant 1 — \((\text{mean intensity Happy within stimulus interval}) - (\text{mean intensity Happy outside stimulus interval}) = A\)
Participant 2 — \((\text{mean intensity Happy within stimulus interval}) - (\text{mean intensity Happy outside stimulus interval}) = B\)
Participant 3 — \((\text{mean intensity Happy within stimulus interval}) - (\text{mean intensity Happy outside stimulus interval}) = C\)

Relative mean value of Happy = \((A + B + C)/3\)

Temporal group analysis

For the Line Charts with relative values, the calculation is done in the following way:

Participant 1 — \((\text{mean intensity Happy outside stimulus interval}) = W\)
Participant 2 — \((\text{mean intensity Happy outside stimulus interval}) = X\)
Participant 3 — \((\text{mean intensity Happy outside stimulus interval}) = Y\)

Mean value of Happy outside stimulus interval = \((W + X + Y)/3 = Z\)

For each time step in the Line chart the relative value of Happy is:

\(((\text{Mean value of Happy (Participant 1)} + \text{Mean value of Happy (Participant 2)} + \text{Mean value of Happy (Participant 3)}) / 3) - Z\)

RESULT EXPORT AND CHARTS

Export

The data in the Numerical Group Analysis window can be exported to a text file. Choose Export and then Export Group Results to export the data in the Group Results tab. Choose Export and then Export Participant Results to export the data in the Participant Results tab.
**Chart Type**

The bottom window shows a graphical representation of the selected analysis. Choose from the Chart type list on the toolbar how to display the data. Move over the graph with your mouse pointer to display the values.

**Box plots** – Box plots contain the mean, median (=50th percentile) and the borders represent the 25th and 75th percentiles. The error bars (whiskers) represent the 10th and 90th percentiles. A percentile is the percentage of participants that has this or a lower expression intensity. So if the 25th percentile of the facial expression Happy is 0.3, this means that 25 percent of the participants has an intensity of Happy of maximally 0.3. If you hover over the box plot with your mouse, the intensity values are shown.

*Figure 6.4 Box plot for the facial expression Happy. P10 = 10th percentile, P25 = 25th percentile, P75 = 75th percentile, P90 = 90th percentile, MN = Mean, MDN = Median.*
The individual participants represent the samples. Hence, if you have five participants with three analyses each, the box plots are based on five samples. The method used to calculate percentiles is the N + 1 Basis interpolation, which is also used in the statistical program SPSS. If the sample size is lower than 3, the 25th percentile is the same as the minimum and the 75th percentile is the same as the maximum value, which is also the same as in SPSS.

- **Bar charts** – As bar charts with mean intensities.

- **Auto scale Y axis** – Selecting this option sets the maximum value of the Y axis to the maximum value in the plot. By default the Y axis has a maximum value of 1.

**Participant Groups**

Choose from the **Participant Groups** list on the toolbar for which groups to create graphs. There are three chart types:

- **Expressions** – Facial expressions intensities for the selected participant groups. Optionally, select from the **Expressions** list on the toolbar which expressions to display. By default all expressions are shown.

- **Valence** – The valence for the selected participant groups.

- **Arousal** – The arousal for the selected participant groups.
6.8 Temporal group analysis

The temporal group analysis allows you to play back the stimulus video together with the video of the test participant and the analysis per group.

PROCEDURE

1. Open the Participant Groups tab in the project explorer and select a participant group.

2. Choose Participant Group > Open Temporal Group Analysis. The top-left window displays the stimulus video, the top-right window the video of the participant’s face and the bottom window displays analysis graphs for the selected participant group.

3. Select Absolute or Relative from the Result Type list on the toolbar.
   - Absolute – Continue with step 4.
   - Relative – Continue with step 5.

4. If you selected Relative in step 2 above, select in the Project Analysis Settings window which episode to compare the stimulus with. See step 2 on page 125 for an explanation of the options.

5. Select the stimulus from the Stimulus list on the toolbar.

6. Optionally, adjust the volume of the stimulus video in the bottom-left corner of this window. If no volume control is visible, the video does not have audio, or the audio format is not supported (see Appendix A).

7. Select the participant and analysis from the lists in the Analysis Visualization window.

You can also open the Temporal Group Analysis window for a participant group by clicking the magnifying glass button next to the group.

This button opens the Numerical Group Analysis (see page 122).
8. Click one of the buttons on the top-left of the Analysis Visualization window to show for example the Framing, Mesh, or Global gaze direction.

For details on the visualization options, see ANALYSIS VISUALIZATION on page 71.

![Image](image_url)

**Figure 6.5** Visualizing the stimulus video (right) together with the video of the test participant (left).

**CHARTS**

The bottom window displays four charts on different tabs. Note that these are results per group, and do not change when you select another participant in the Analysis Visualization window.

*To copy, export and zoom in/out charts*

You can copy and export all charts. The line chart also have the option to zoom in or out. Choose the appropriate button on the chart toolbar.

*Expressions*

This window (see Figure 6.6) shows the average facial expression intensity of the participant group during the stimulus.
Click **Expressions** at the top of the chart and choose the expressions to display.

![Image of expressions chart]

**Figure 6.6** Visualization of stimulus video, test participant and intensities of facial expressions. The hairline shows the position of the videos.

Note that this chart shows the group average. When an expression is dominant in this chart, it does not mean that the corresponding state was scored at that time for all subjects in that group.
• Play the videos together with the graphic representation of the facial expression intensities. The hairline shows the position in the video of the test participant.

• Click Options and select Auto Scale Y Axis to use the maximum expression value as maximum value for the Y axis.

Valence

The Valence chart (Figure 6.7) shows the average valence of the participant group over time. Play the videos together with the visualization of the valence (see Figure 6.7).

• Click Options and select Auto Scale Y Axis to use the maximum expression value as maximum value for the Y axis.

![Figure 6.7 Simultaneous visualization of stimulus video, test participant and valence. The hairline shows the position of the videos.](image-url)
**Arousal**

The Arousal chart shows the average arousal of the participant group over time. Play the videos together with the visualization of the arousal (see Figure 6.8).

---

*Figure 6.8 Simultaneous visualization of stimulus video, test participant and arousal. The hairline shows the position of the videos.*

- Click **Options** and select **Auto Scale Y Axis** to use the maximum expression value as maximum value for the Y axis.
**Summary of absolute expressions**

The **Summary of absolute expressions** shows the average percentage of the time that each expression was scored across subjects. An emotion may appear also if it was scored for one subject only.

![Pie chart showing Summary of Absolute Expressions](image)

*Figure 6.9 Summary of absolute expression, in a pie chart for grouped data.*

To show the percentage values, click **Settings** and then **Show values**.

Note that the results in the expressions pie may not be immediately comparable with the Expressions line chart (page 131).

For example, the pie chart may show a small percentage for **Happy**, while the Expression line chart shows **Neutral** as dominant throughout the test, and **Happy** never exceeding the other emotions. This happens because one expression may become dominant (and be scored) for one subject, and therefore become visible in the pie chart, but the **average** expression across subjects at that time, represented in the expression line, may be another one.
6.9 Analysis advisor for project analysis

This section describes the procedure for a number of common analyses.

**EXPRESSION INTENSITY; ENTIRE ANALYSIS**

*Single participants*

1. Choose **Participant Group > Numerical Group Analysis**.
2. Open the **Participant Results** tab. This window displays the average expression intensities of all participants with standard deviations.

<table>
<thead>
<tr>
<th>Participants</th>
<th>N</th>
<th>Neutral</th>
<th></th>
<th>Happy</th>
<th></th>
<th>Sad</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Mean</td>
<td>STDEV</td>
<td>Mean</td>
<td>STDEV</td>
<td>Mean</td>
<td>STDEV</td>
</tr>
<tr>
<td>Participant 1</td>
<td>377</td>
<td>0.242</td>
<td>0.333</td>
<td>0.787</td>
<td>0.295</td>
<td>0.017</td>
<td>0.014</td>
</tr>
<tr>
<td>Participant 2</td>
<td>377</td>
<td>0.403</td>
<td>0.325</td>
<td>0.486</td>
<td>0.369</td>
<td>0.142</td>
<td>0.085</td>
</tr>
<tr>
<td>Participant 3</td>
<td>377</td>
<td>0.450</td>
<td>0.417</td>
<td>0.562</td>
<td>0.390</td>
<td>0.001</td>
<td>0.000</td>
</tr>
<tr>
<td>Participant 4</td>
<td>377</td>
<td>0.671</td>
<td>0.287</td>
<td>0.270</td>
<td>0.253</td>
<td>0.012</td>
<td>0.010</td>
</tr>
<tr>
<td>Participant 5</td>
<td>377</td>
<td>0.106</td>
<td>0.134</td>
<td>0.754</td>
<td>0.251</td>
<td>0.736</td>
<td>0.147</td>
</tr>
</tbody>
</table>

*Participant groups*

1. Choose **Participant Group > Numerical Group Analysis**.
2. The window that now opens displays the average expression intensities for the participant groups.
3. Click the group name to calculate whether the average expression intensities differ significantly between this group and the other groups (see step 3 on page 124 for more information).

**EXPRESSION INTENSITY; DURING STIMULUS**

*Absolute*

1. Define the episodes you are interested in as stimuli.
2. Score all stimuli during (see page 102) or after the analysis (see page 102).
3. Choose **Participant Group > Numerical Group Analysis**.
4. Select the stimuli of interest from the list on the toolbar.

5. From the Result Type list, choose Absolute. The window now displays average expression intensities per stimulus for all participant groups.

<table>
<thead>
<tr>
<th>Stimulus/EventMarker</th>
<th>N</th>
<th>Neutral</th>
<th>Happy</th>
<th>Sad</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>MEAN</td>
<td>STDEV</td>
<td>MEAN</td>
</tr>
<tr>
<td>Twins eating</td>
<td>5</td>
<td>-0.312</td>
<td>0.105</td>
<td>0.372</td>
</tr>
<tr>
<td>Frying insects</td>
<td>5</td>
<td>0.083</td>
<td>0.155</td>
<td>-0.155</td>
</tr>
</tbody>
</table>

6. Click one of the stimuli names to calculate whether the facial expression intensities during this stimulus differ significantly from the intensities during other stimuli (see also step 3 on page 124).
**Relative: participant group relative to another group**

Locate the expressions in the table for the groups and stimuli you are interested in. Calculate the difference manually.

<table>
<thead>
<tr>
<th>Stimulus/EventMarker</th>
<th>N</th>
<th>Neutral</th>
<th>Happy</th>
<th>Sad</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Mean</td>
<td>STDEV</td>
<td>Mean</td>
</tr>
<tr>
<td>Twins eating</td>
<td>2</td>
<td>0.837</td>
<td>0.334</td>
<td>0.378</td>
</tr>
<tr>
<td>Frying Insects</td>
<td>2</td>
<td>0.704</td>
<td>0.086</td>
<td>0.114</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Stimulus/EventMarker</th>
<th>N</th>
<th>Neutral</th>
<th>Happy</th>
<th>Sad</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Mean</td>
<td>STDEV</td>
<td>Mean</td>
</tr>
<tr>
<td>Twins eating</td>
<td>3</td>
<td>0.266</td>
<td>0.142</td>
<td>0.701</td>
</tr>
<tr>
<td>Frying Insects</td>
<td>3</td>
<td>0.428</td>
<td>0.264</td>
<td>0.391</td>
</tr>
</tbody>
</table>

To visualize these expressions over time:

The procedure below only applies if you used a video as stimulus (see page 98).

1. Open the **Participant Group** tab in the project explorer
2. Select the participant group of interest in the project explorer.
3. Choose **Participant Group > Temporal Group Analysis.**
4. Select the stimulus of interest from the list on the toolbar.
5. From the **Result Type** list, choose **Absolute.**
6. Open the **Expressions** tab in the bottom window and play the videos.

**Relative; stimulus relative to another stimulus**

1. Define the episodes you are interested in as stimuli.
2. Score all stimuli during (see page 102) or after the analysis (see page 102).
3. Choose **Participant Group > Numerical Group Analysis.**
4. Open the Participant Group tab in the project explorer.

5. In the Project Analysis Settings window, choose Other stimulus as Relative Analysis Type. Choose the stimulus with which you want to compare as Other Stimulus.

6. Select the stimuli of interest from the list on the toolbar.

7. From the Result Type list, choose Relative. The facial expressions intensities now shown in the Group Results and Participant Results tab are corrected for the intensities during the Other stimulus. See page 127 for the calculations.

<table>
<thead>
<tr>
<th>Stimulus/EventMarker</th>
<th>N</th>
<th>Neutral</th>
<th>Happy</th>
<th>Se</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>MEAN</td>
<td>STDEV</td>
<td>MEAN</td>
</tr>
<tr>
<td>Twins eating</td>
<td>5</td>
<td>-0.312</td>
<td>0.105</td>
<td>0.371</td>
</tr>
<tr>
<td>Frying insects</td>
<td>5</td>
<td>0.083</td>
<td>0.155</td>
<td>-0.155</td>
</tr>
</tbody>
</table>

To visualize the relative intensities over time:

The procedure below only applies if you used a video as stimulus (see page 98).

1. Open the Participant Group tab in the project explorer.
2. Select the participant group of interest in the project explorer.
4. In the Project Analysis Settings window, choose Other stimulus as Relative Analysis Type. Choose the stimulus with which you want to compare as Other Stimulus.
5. Select the stimulus of interest from the list on the toolbar.
6. From the Result Type list, choose Relative.
7. Open the Expressions tab in the bottom window and play the video.

**COMPARE STIMULI WITH A NEUTRAL EPISODE**

**Stimuli**

1. Define a stimulus and name it, for example, Neutral. Link this to an episode in the video of which you expect or know that it will cause the participants to look neutral.

Chapter 6 - The Project Analysis Module 139
Alternatively, ask the test participants to look neutral before the test starts, or after it has ended and score the stimulus then (see step 3).

2. Define the episodes you are interested in as stimuli as well.

3. Score all stimuli during (see page 102) or after the analysis (see page 102).


5. Open the Participant Group tab in the project explorer.

6. In the Project Analysis Settings window, choose Other Stimulus as Relative Analysis Type. Choose Neutral as Other Stimulus.

7. Select the stimuli of interest from the list on the toolbar.

8. From the Result type list, choose Relative. The facial expressions now shown in the Group Results and Participant Results tab are corrected for the facial expressions during the neutral phase. See page 127 for the calculations.

9. Click one of the stimuli names to calculate whether the facial expression intensities during this stimulus differ significantly from the intensities during other stimuli (see step 3 on page 124 for more information).
To visualize the intensities for a stimulus over time:

1. Open the **Participant Group** tab in the project explorer.

2. Select the participant group of interest in the project explorer.

3. Choose **Participant Group > Temporal Group Analysis**.

4. In the **Project Analysis Settings** window, choose **Other Stimulus** as Relative Analysis Type. Choose **Neutral** as Other Stimulus.

5. Select the stimulus of interest from the list on the toolbar.

6. From the **Result Type** list, choose **Relative**.

7. Open the **Expressions** tab in the bottom window and play the videos.

**Stimuli relative to another stimulus**

1. Define a stimulus and name it, for example, **Neutral**. Link this to an episode in the video of which you expect or know that it will cause the participants to look neutral. Alternatively, ask the test participants to look neutral before the test starts, or after it has ended and score the stimulus then (see step 3).

2. Define the episodes you are interested in as stimuli as well.

3. Score all stimuli during (see page 102) or after the analysis (see page 102).

4. Choose ** Participant Group > Numerical Group Analysis**.

5. Open the **Participant Group** tab in the project explorer.

6. In the **Project Analysis Settings** window, choose **Other Stimulus** as Relative Analysis Type. Choose **Neutral** as Other Stimulus.

7. Select the stimuli of interest from the list on the toolbar.

8. From the **Result Type** list, choose **Relative**. The facial expressions now shown in the **Group Results** and **Participant Results** tab are corrected for the facial expressions during the neutral phase. See page 127 for the calculations.
9. Look up the expression of interest in the table and calculate the difference between the stimuli.

THE PERCENTAGE OF EACH FACIAL EXPRESSION

For a participant group during a stimulus

1. Open the Participant Group tab in the project explorer and select the participant group.

2. Choose Participant Group > Temporal Project Analysis.

3. Select the stimulus from the Stimulus list on the toolbar.

4. Choose Absolute from the Result Type list on the toolbar.

Open the Summary of Absolute Expressions tab in the bottom window and select Show Values from the Settings list on the toolbar.

The graph now shows the mean percentage of each facial expression. See EXPRESSION SUMMARY CHART on page 79 for more information on the expression summary.
7.1 Action Unit classification

Action Units are muscles or muscle groups in the face that are responsible for facial expressions. The Action Units are described in the Facial Action Coding System (FACS) published by Ekman and Friesen (1978).

FaceReader can analyze Action Units with the Action Unit Module. The following Action Units are analyzed:

1. Inner Brow Raiser
2. Outer Brow Raiser
4. Brow Lowerer
5. Upper Lid Raiser
6. Cheek Raiser
7. Lid Tightener
9. Nose Wrinkler
10. Upper Lid Raiser
12. Lip Corner Puller
14. Dimpler
15. Lip Corner Depressor
17. Chin Raiser
18. Lip Puckerer
20. Lip Stretcher
23. Lip Tightener
24. Lip Pressor
25. Lips Part
26. Jaw Drop
27. Mouth Stretch
43. Eyes Closed

Intensities are annotated by appending letters, A (trace); B (slight); C (pronounced); D (severe) or E (max). These intensities follow the classification as described in Ekman et al. (2002).
References

7.2 Analyze Action Units

Action Unit analysis is by default switched on if you have the Action Unit Module. However, when you upgrade a basic FaceReader license with the Action Unit Module, you must switch the option on manually. To do so:

2. Under Optional Classifications, select Action Unit Classification.

Analyzing action units requires processing time. To speed up the analysis, you may want to (temporarily) disable action unit analysis. To do so, deselect Action Unit classification in the settings (see step 2 above).
7.3 Action Units during the analysis

Action Unit activity can be displayed in the Analysis Visualization window during and after the analysis. Click the lowest button on the left side of this window. Action Units appear in the Analysis Visualization when the activity is Trace or higher. The colors under the name represent the activity of this action unit.

7.4 Action Units in the analysis output

ACTION UNIT INTENSITY

Select the Action Unit Intensity window from the upper-right windows. It shows the intensity of 20 Action Units, divided into the classes Trace, Slight, Pronounced, Severe, and Max. These intensities are shown by consecutive letters from A to E. From the Action Units list, choose which ones to display. The available action units are shown in the figure on the next page and the table on page 144.
Options

- Click the **Save as image** button to save the **Action Unit Intensity** window as a *.PNG, *.JPG, *.BMP, *.GIF or *.TIF image and use it in your presentations and reports.

- Click the **Copy** button to copy the **Action Unit Intensity** window to paste it in another program.

**ACTION UNIT STATES**

The intensity of the action units is displayed in the timeline. Choose which action units to display from the **Action Units** list on the toolbar. By default all action units are selected.
**ACTION UNITS IN THE LOG FILES**

Action Unit intensities can be added to the detailed log. To do so, choose `File > Settings` and then click the `Data Export` tab. Under `Export (Detailed log, ODX, N-Linx and API)`, select `Action Units`. Optionally, select `Export Action Units as Continuous values` (see page 149).
The intensities are added as letters (See “action unit intensity” on page 146) to the detailed log.

<table>
<thead>
<tr>
<th>Action Unit 01 - Inner Brow Raiser</th>
<th>Action Unit 02 - Outer Brow Raiser</th>
<th>Action Unit 04 - Brow Lowerer</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>A</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>A</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>A</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>A</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>NotActive</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>NotActive</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>NotActive</td>
<td>NotActive</td>
<td>C</td>
</tr>
<tr>
<td>NotActive</td>
<td>NotActive</td>
<td>C</td>
</tr>
</tbody>
</table>

**Action Units as Continuous values**

You can also export Action Unit intensities as continuous values. To do so:

1. Choose File > Settings > Data export

2. Under Export (Detailed log, ODX, N-Linx and API) select Export Action Units as continuous values.

   ![Export Options]

The categories are exported with the following values to the detailed log file:

- **Not active** – 0
- **A** – [0.00 - 0.16]
- **B** – [0.16 - 0.26]
- **C** – [0.26 - 0.58]
- **D** – [0.58 - 0.90]
The figure below shows an example of a log file with continuous Action Unit intensities.

<table>
<thead>
<tr>
<th>N</th>
<th>O</th>
<th>P</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action Unit 06 - Cheek Raiser</td>
<td>Action Unit 07 - Lid Tighther</td>
<td>Action Unit 09 - Nose Wrinkler</td>
</tr>
<tr>
<td>0</td>
<td>0.1039221</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1044</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.106339</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1047224</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1095609</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1187323</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1191372</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1237751</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1329748</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1425876</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1507059</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1624604</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1763499</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.1862904</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.196694</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.2053856</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.2033924</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.2000526</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.2063995</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0.2069813</td>
<td>0</td>
</tr>
</tbody>
</table>

**Action Unit intensities in The Observer XT**

If you send FaceReader data to The Observer XT 13 using the N-Linx network communication protocol, Action Unit intensities are not transferred to The Observer XT as numerical values but as intensity classes.
If you want to import the intensities as continuous values, export the FaceReader data as detailed log and import these manually into The Observer XT as external data (see page 179).

See the chapter Use FaceReader with The Observer XT on page 158 for more information on importing FaceReader data into The Observer XT.
Chapter 8

The Remote PPG Module

8.1 Introduction ................................................................. 153
8.2 Heart rate analysis ...................................................... 155
8.1 Introduction

REMOTE PPG

Photoplethysmography (PPG) is a simple and low-cost optical technique that can be used to detect blood volume changes in the tissue under the skin. It is based on the principle that changes in the blood volume result in changes in the light reflectance of the skin.

With each cardiac cycle the heart pumps blood to the periphery. Even though this pressure pulse is somewhat damped by the time it reaches the skin, it is enough to distend the arteries and arterioles in the subcutaneous tissue.

PPG is often used non-invasively to make measurements at the skin surface. In remote PPG (RPPG), FaceReader can detect the change in blood volume caused by the pressure pulse when the face is properly illuminated. The amount of light reflected is then measured. When reflectance is plotted against time, each cardiac cycle appears as a peak. This information can be converted to heart rate average and variability.

For an overview of the accuracy of the estimated heart rate, see Tasli et al. (2014b).

Because blood flow to the skin can be modulated by multiple other physiological systems, the PPG can also be used to monitor breathing, hypovolemia, and other circulatory conditions (Reisner et al., 2008).

REFERENCES

Photoplethysmography
http://en.wikipedia.org/wiki/Photoplethysmogram

Remote PPG and FaceReader


Please cite the original work in your studies when based on FaceReader’s remote PPG.
THE REMOTE PPG MODULE

With FaceReader’s Remote PPCG Module, you can analyze heart rate of the test participant without additional hardware, using the FaceReader camera.

The option to analyze heart rate must be switched on, which is by default the case if you have the Remote PPG Module. However, when you upgrade a basic FaceReader license with the Remote PPG Module, you must switch the option on manually. Choose File > Settings > Analysis options. Under Optional Classifications, select Estimate Heart Rate.

Guidelines for an optimal RPPG measurement

- **Lighting**
  
  Make sure that light is diffuse (no strong shadows on the face), preferably from a frontal direction. Strong light reflectance on the forehead and hair covering the face (and forehead) should be avoided. See also Camera and accessories on page 28.

- **Camera settings**
  
  Remote PPG is intended to work with the cameras supported for FaceReader. Below you find recommended settings:
  - Video resolution: 1280 x 720.
  - Frame rate: at least 15 fps; preferred 30 fps.
  - Distance between camera and subject: 0.5-1 m.

  The camera should be able to capture a frontal view of the subject’s face throughout the session. The accuracy of the measurement is related with the head pose. Frontal head
pose is recommended where abrupt head pose changes can degrade the optimal performance.

8.2 Heart rate analysis

The Remote PPG module offers two additional analysis windows: Heart rate (at the top of the screen) and Heart Rate Line Chart (at the bottom of the screen).

For the remaining analysis windows, see Chapter 5 FaceReader’s output.

HEART RATE WINDOW

The Heart rate window shows the current heart rate of the participant estimated by means of remote photoplethysmography (RPPG; see details on page 153). Heart rate is expressed in beats per minute (bpm).

To view the Heart Rate window
Click the Select window button on one of the upper analysis windows and select Heart Rate.

By default, this window is not shown on your screen.

Figure 8.1 The Heart rate window.
**Calibration**

FaceReader requires a 10 second Calibration period where the signal of the skin color is sampled and processed for a reliable measurement. During the calibration stage the test participant should look into the camera and avoid extensive head movement.

Calibration is done at the start of analysis and every time the participant’s face is found again after it was not found from some time. When the face is found again, the **Heart rate** window shows **Calibrating**.

![Calibrating](image)

**Calculation**

To calculate the heart rate, for each time step the pulses over the previous ten seconds are used.

**Post-processing**

At the end of analysis, the skin color signal is processed again to improve accuracy and to re-calculate heart rate, also in the initial 10 seconds and every time a new calibration was carried out. Note that after analysis the reported heart rate values can differ from those seen during analysis. Do not rely on the exact values you see during analysis.

**HEART RATE LINE CHART**

The Hear Rate Line Chart shows the heart rate estimated with Remote photoplethysmography, plotted against time.
To view the Heart Rate Line chart

Click the Select window button on one of the lower visualization windows and select Heart Rate Line Chart.

Heart rate is expressed in beats per minute (bpm). When you play back a video, a hairline shows the time in the video. See Figure 8.2 for an example.

Note that because heart rate is subject to post-processing (page 156), the heart rate line after analysis may look different than that during analysis.

![Heart Rate Line Chart](image)

*Figure 8.2 An example of Heart Rate line chart.*

**Options**

Click Options and then select Auto Scale Y axis to adjust the Y axis to the maximum value.

**Interval visualization**

If you select one of the analysis intervals in the Overview pane, a blue block shows the analyzed interval. If no intervals are selected, the chart shows the results of all the intervals in the Overview pane.
Chapter 9

Use FaceReader with The Observer XT

9.1 FaceReader and The Observer XT ........................................................ 159
9.2 The Observer XT 13 ............................................................................... 160
9.3 With The Observer XT 12.5 or lower..................................................... 173
9.4 Visualize FaceReader data in The Observer XT ................................. 182
9.5 The Observer XT sample projects with FaceReader data ................. 187
9.1 FaceReader and The Observer XT

WHY USE FACEREAдер IN COMBINATION WITH THE OBSERVER XT

Integrating FaceReader data with other data may give you a more complete picture of the phenomena that you are studying. For instance, when testing your newly developed web site, it may be interesting to know what emotions it evokes, but it may be even more intriguing to see at what part of the web site your test person is looking when his facial expressions are classified as 'happy' or 'surprised'. Manually logging the test person's verbal reactions or measuring his physiological responses makes the picture complete. For the integration of all these data, you can use The Observer XT.

You can let FaceReader record a video of the test participant’s face and import FaceReader’s log files together with the video into The Observer XT. You can then visualize the test person’s facial expressions together with your observational data and calculate statistics. The procedure for co-acquiring and importing FaceReader data depends on which version of The Observer XT you have.

Make sure that FaceReader elements that are imported into The Observer do not already exist in the Coding Scheme of The Observer XT. Otherwise the FaceReader data will be assigned to the element that was already present in the Coding Scheme and your Observer data will be incorrect. Please be especially aware to not use the element names Unknown, or Neutral in the Coding Scheme of The Observer XT, since these names are used for the facial expressions.

With The Observer XT 13

If you have The Observer XT 13 with the External Data Module and you observe live, you can use the Noldus network communication protocol N-Linx to control FaceReader with The Observer XT. This way you achieve the following:

- When you create an observation in The Observer XT, FaceReader automatically creates a participant with a camera analysis. Since you cannot mix camera analyses with image analyses within one FaceReader project, this option only works if your FaceReader project does not contain image analyses yet.

- The FaceReader independent variables are imported into the Independent Variables list of The Observer XT.

- When you start an observation in The Observer XT, FaceReader starts analyzing.
• When you stop an observation in The Observer XT, FaceReader analysis stops. The FaceReader data are imported automatically in the observation and synchronized with the Event Log.

• Optionally, select the option in The Observer XT to import the FaceReader video automatically into the observation.

See page 160 for the procedure.

When you carry out offline observations in The Observer XT, you must export the FaceReader data and import them manually into The Observer XT. The procedure is the same as for The Observer XT 12.5 or lower. See the following sections for the procedure:

- **EXPORT FACEREADER LOG FILES** – page 176.
- **IMPORT FACEREADER LOG FILES AS OBSERVATIONAL DATA** – page 177.
- **IMPORT DETAILED LOGS AS EXTERNAL DATA** – page 179.

**With The Observer XT 12.5 or lower**

If you have The Observer XT 12.5 or lower, you can control the start and stop of FaceReader analysis together with an observation in The Observer XT. Automatic import of FaceReader data into The Observer XT is not possible. Therefore you must export the FaceReader data and import them into the observation. See page 173 for the procedure.

If you start FaceReader analysis manually, you also must synchronize the analysis with the event log manually. See Chapter 4 *Carry out observation* in The Observer XT Reference Manual for details.

### 9.2 The Observer XT 13

The functionality makes use of the Noldus network communication protocol N-Linx. You can use one instance of FaceReader together with one instance of The Observer XT. To set it up, you must do the following:

1. If FaceReader and The Observer XT run on different computers, create exceptions for port 5672 on both computers (page 161).

2. Create settings in FaceReader (page 162).

3. Create settings in The Observer XT (page 164).

4. If FaceReader and The Observer run on different computers and you want to import the FaceReader videos automatically in The Observer XT, create a mapped folder on both computers where FaceReader stores its video files (page 167).
External data module
For the automatic import of FaceReader data into The Observer XT, your license for The Observer XT must include the External Data Module. To see if you have this module, open The Observer XT and choose Help > About The Observer XT > License info.

If you do not have this module, you must export the FaceReader detailed logs as odx-file (page 176) and import them as observational data (see page 177).

Offline observation
If you carry out offline observations in The Observer XT, you must export FaceReader data manually and import them into The Observer XT. This procedure is the same as for The Observer XT 12.5 or lower versions. See the following sections for the procedure:

**EXPORT FACEREADER LOG FILES** – page 176.
**IMPORT FACEREADER LOG FILES AS OBSERVATIONAL DATA** – page 177.
**IMPORT DETAILED LOGS AS EXTERNAL DATA** – page 179.

**EXCEPTIONS FOR N-LINX PORT IN WINDOWS FIREWALL (FOR TWO COMPUTER SETUP)**

Follow this procedure only if FaceReader and The Observer XT run on two different computers. Communication with N-Linx runs through port 5672 on both computers. You need to allow inbound and outbound traffic through port 5672 in Windows Firewall on both computers.

1. Open the Control Panel and select Windows Firewall.
2. On the left side of the window, click Advanced Settings.
3. Click Inbound Rule and click New Rule in the Actions pane.
4. In the New Inbound Rule Wizard Window that opens, select Port and click Next.
5. Select TCP and enter 5672 in the Specific local ports field and click Next.

6. Click Allow the connection and click Next.

7. Select to which network the rule applies and click Next.

8. Give the rule a name, for example N-Linx connection and click Finish.

9. Check in the Inbound Rules windows that this rule is set to Enabled.

10. Click Outbound Rule and click New Rule in the Actions pane.

11. Repeat steps 4 to 9 for the outbound rule.

12. Close all Control panel windows.

Follow this procedure for both computers.

**SETTINGS IN FACEREADER**

1. Choose File > Set Default camera, choose your camera and select the option Record.

2. Choose File > Settings > Data Export.
3. Under **External Communication (N-Linx)**, select **Enable N-Linx**.

4. If FaceReader and The Observer XT run on the same computer, leave the default address *localhost* in the **N-Linx server address** field. If the programs run on different computers, enter the IP address or computer name of the computer with The Observer XT. To find that name, open the Control Panel and choose **System**.

5. In the **N-Linx server port** field, leave the default port 5672. Ask your system administrator for assistance if this port is in use by another program.
6. Under **Export (Detailed Log, ODX, N-Linx and API)**, choose which data to send to The Observer XT.

**Settings in the Observer XT**

Make sure FaceReader is open and that you have followed the steps above to create FaceReader settings.

1. In The Observer XT, open your project and choose **File > Preferences > N-Linx Settings**.

1. Select **Use N-Linx server to connect with other applications**.
2. In the Services address field, leave the default value Localhost.

3. In the Services port field, leave the default port 5672. Ask your system administrator for assistance if this port is used by another program.

4. Click Test connection. If connection with N-Linx is found, the Status will change to Connected. If not, enter the correct settings and click Test connection again.

5. Click OK.


7. Select Live Observation. The Devices window now opens. If not, click the Devices button.

8. Double-click the line FaceReader-[computer name]

9. Select the FaceReader settings for your experiment.
For an explanation of the settings, see the following pages:
- **Smoothen classifications** – page 192.
- **Continuous calibration** – page 67.
  To use Participant calibration (see page 65), select that option manually in FaceReader.
- **Face model** – page 55.
- **Image rotation** – page 192.

10. Click **OK** and select the checkbox in front of the line **FaceReader -[computer name]**.

### Automatic linking of video files (optional)

Use automatic linking only if you have many analyses in your project. You need to create these settings for each project. Therefore, if you have only a few analyses, it is easier to import the videos into The Observer XT manually. To link your videos automatically to your observation:

1. **Choose** **Setup** > **Project Setup** > **Live Observation** and click the **Devices** button.
2. **Double-click** the line **Automatic linking of video files**.
3. **Click** the **Browse** button and select the folder where FaceReader stores its video files. By default this is `C:\Users\Public\Documents\Noldus\FaceReader 7\Projects\[Project Name]\Recorded Videos`. Note that you have to repeat this step every time you create a new FaceReader project, because the FaceReader videos are stored in the project folder.
4. In the **Link video extensions field**, make sure it includes the extension `.avi`.

5. In the **Link videos based on field**, select **Video start time (later than observation start time)**.

6. In the **Search for field**, select **1**.

7. Click **OK** and select the checkbox in front of **Automatic linking of video files** in the **Devices** list and the checkbox in front of the line **FaceReader [computer name]**.

---

**CREATE A MAPPED DRIVE FOR THE FOLDER WITH VIDEOS (FOR TWO COMPUTER SETUP)**

This procedure is necessary if you want to use automatic linking of video files (see page 166) and FaceReader and The Observer XT run on different computers. This is only useful if you have a project with many analysis, since you have to specify these settings for each project. If you have only a few videos per project, import them manually into The Observer XT.
On the computer with FaceReader:

1. Right-click the folder where the video files are going to be stored, which is by default C:\Users\Public\Documents\Noldus\FaceReader 7\Projects\[Project name]\Recorded Videos
   and select Share with and then Specific People.

2. Click the arrow next to Add and select Everyone and then click Add.

3. Select Read/Write as Permission level and click Share > Done.

On both computers:

1. Open File Explorer and then This PC.
2. Click the Map network drive icon.

![Map network drive icon](image)

3. Choose a name for the drive and browse to the shared folder. Make sure this is the same on both computers. Then click Finish.

![Map Network Drive](image)

4. When you now start the computer with The Observer XT you need to enter the login details for the computer with FaceReader.
OBSERVE IN THE OBSERVER XT AND ANALYZE IN FACEREADER

1. When your project in The Observer XT is ready, check the following:
   - That your camera is connected to the PC, that it is turned on, and selected as default camera in FaceReader.
   - That FaceReader is open and the bottom-right corner shows that the connection to N-Linx is established.
   - That you selected the data to export in FaceReader.

2. Create a new observation in The Observer XT. A new participant is created in FaceReader with a camera analysis.

3. Start the observation in The Observer XT. Dependent on the settings in The Observer XT, the Independent Variables list appears. This list contains the independent variables you created in The Observer XT together with the FaceReader independent variables Age, Gender and ParticipantID (see Independent Variables on page 171 how FaceReader independent variables are imported into The Observer XT). When you entered the values of the user defined independent variables, the observation and FaceReader analysis start.

4. Score data in The Observer XT. FaceReader automatically analyzes the camera images and creates a video file.

5. Stop the observation. Classification in FaceReader is automatically stopped. The FaceReader data are automatically imported into the observation. The Expression states are imported as behaviors and the values of the detailed log are imported as external data. If you selected Automatic Linking of Video Files, the video is automatically imported into the observation. Click OK when the video is found.

HOW FACEREADER DATA ARE IMPORTED INTO THE OBSERVER XT 13

See Visualize FaceReader data in The Observer XT on page 182 for a full overview of how FaceReader data appear in The Observer XT.

Event data
FaceReader event data are imported into The Observer XT as separate event logs within the observations. This is the case for the following FaceReader data:

- State Expression Values
- Facial States
- Stimuli
- Events
- Action Units (with the Action Unit Module only)
**Continuous data**

Continuous data are imported into The Observer XT at a sample rate of 5 frames per second. Your license for The Observer XT must include the External Data Module (see also page 161). The following data can be imported as continuous data:

- Facial expression values.
- Valence.
- Arousal.
- X-, Y-, Z- head orientation.
- Heart rate (if your FaceReader license includes the Remote PPG Module). But please take notice of the note Heart rate on page 172.

**Independent Variables**

The FaceReader independent variables *Age, Gender* and *ParticipantID* are imported into The Observer XT together with the FaceReader data. The values for *Age* and *Gender* are estimated by FaceReader and the *ParticipantID* is the participant number automatically assigned by FaceReader. If the independent variables are not present yet in The Observer XT, they will be added to the Independent Variables list. If you created them as User defined variables in the Independent Variables list of The Observer XT (with the exact variable names as mentioned above) and no values are filled in yet before observation start, the FaceReader values are imported into the list after the end of the observation. If you already entered values in The Observer XT before observation start, these values are maintained. FaceReader does not overwrite the Independent Variable values in The Observer XT.

To enter the independent variable values in The Observer XT instead of importing the FaceReader values, create user defined independent variables *Age, Gender* and *ParticipantID* in The Observer XT. Make sure the names match exactly. Choose to enter the independent variables before starting the observation (Choose **Setup > Project Settings > Observation Settings** and choose **Before Observation** from the **Edit Independent Variables** list).

To import FaceReader independent variable values in the Independent Variables list of The Observer XT, the variable name must exactly match the FaceReader variable name. If you, for example, have an Independent Variable *age* (lower case a instead of upper case), or *Participant ID* (with a space), a new Independent Variable *Age* or *ParticipantID* will be added to the Independent Variables list.
**IMPORTANT NOTES**

**Duplicate elements**
Elements that are imported as events into The Observer should not already exist in the Coding Scheme of The Observer XT with the exact same name. As an example, you may have a mutually exclusive behavior group that contains the behavior *Neutral*, or *Unknown*. If you import FaceReader emotional expressions into The Observer XT, the expressions *Neutral*, or *Unknown* will then be scored for the behavior group that was already present in the Coding Scheme and will not be present in the imported event log *State Expression Values*. Therefore both the event log with the manual annotations and the event log *State Expression Values* will be incorrect.

**Sample rate**
FaceReader data are imported into The Observer XT with a sample rate of 5 frames per second. This is to limit the amount of data that is transferred to The Observer XT. FaceReader itself samples with the camera frame rate and converts the data to a sample rate of 15 frames per second after the analysis is finished (see Video frame rate and samples in FaceReader on page 43. Therefore, the data in The Observer XT may differ slightly from the analysis results in FaceReader.

**Heart rate**
If your FaceReader license includes the Remote PPG Module, FaceReader can estimate the test participants’ heart rate. These data can be imported real-time in The Observer XT.

In FaceReader, the first 10 seconds of the analysis is used for calibration and the data are post-processed after the analysis is finished (see the chapter The Remote PPG Module on page 152). The Observer XT imports the heart rate data real-time. Therefore, the heart rate data of the first ten seconds that are imported into The Observer XT contain data that are not yet calibrated. The data that are imported are not post-processed and will differ from the FaceReader data. Since post-processing is used to re-calculate the data, based on the calibration, the data in FaceReader itself are more reliable.

**Event log duration**
- There will be a slight delay between the moment you start an observation in The Observer XT and the moment FaceReader starts analyzing. Since the end of all event logs is determined by the end of the observation, the FaceReader event log will have a shorter duration than The Observer XT event log in the analysis. This is caused by the offset between the event logs.

- The observation in The Observer XT ends when you click the stop observation button. However, the FaceReader analysis will stop when you confirm to the message in The Observer XT *Are you sure you want to stop the observation?* Therefore the FaceReader
event log will be longer than The Observer XT event log. However the event log duration in the analysis is determined by the end of the observation (see the previous bullet).

9.3 With The Observer XT 12.5 or lower

The functionality to control FaceReader with The Observer XT enables you to:

- Start classification when you start an observation.
- Stop classification when you stop an observation.
- Import the FaceReader video into The Observer XT.
- If you run FaceReader and The Observer XT on the same computer, the FaceReader analysis is automatically synchronized with the events in The Observer XT.

For this functionality to work you must select settings in both FaceReader and The Observer XT. The procedure below describes the settings for when you have FaceReader and The Observer XT on the same computer. If you have the two programs on two different computers, contact our support department (see Appendix B for contact information) for the correct procedure.

**SETTINGS IN FACEREADER**

1. Create a participant with a camera analysis.

2. Choose File > Settings > Data Export. Select which data to export under Export (Detailed log, ODX, N-Linx and API).

**SETTINGS IN THE OBSERVER XT**

1. In The Observer XT, create a new project.
2. Select **Set up project**, select **Live** and in the **Devices** window click **Add external program**. The **Add External Program** window opens.

3. In the **Name** field, enter ‘**Control FaceReader**’ or a similar name to indicate that these are the settings to control FaceReader.

4. Select the checkbox next to **Start Observation**.

5. In the same row, click the ellipsis button next to the **Program** field and browse to **FaceReader.exe** in the folder `C:\Program Files (x86)\Noldus\FaceReader 7`.

6. Select the file and click **Open**.

7. In the **Command line options** field enter **STARTOBS**. This instructs FaceReader to start analyzing when you start an observation.

8. Select the checkbox next to **Stop Observation**.

9. In the same row, click the ellipsis button next to the **Program** field and browse to **FaceReader.exe** in the folder `C:\Program Files (x86)\Noldus\FaceReader 7`.

10. Select the file and click **Open**.

11. In the **Command line options** field enter **STOPOBS**. This instructs FaceReader to stop analyzing when you stop an observation.

12. Leave the **ms. before fields** of the lines **Start Observation** and **Stop Observation** empty.
13. Click OK. The Devices list now shows a new device with the name you gave in step 3. Select the checkbox in front of it.

![Devices list](image)

**Automatic linking of video files (optional)**

Use automatic linking only if you have many analyses in your project. You need to create these settings for each project. Therefore, if you have only a few analyses, it is easier to import the videos into The Observer XT manually. To link your videos automatically to your observation:

1. Choose Setup > Project Setup > Live Observation and click the Devices button.
2. Double-click the line Automatic linking of video files.
3. Click the Browse button and select the folder where FaceReader stores its video files. By default this is C:\Users\Public\Documents\Noldus\FaceReader 7\Projects\[Project Name]\Recorded Videos. Note that you have to repeat this step every time you create a new FaceReader project, because the FaceReader videos are stored in the project folder.
4. In the Link video extensions field, make sure it includes the extension .avi.
5. In the Link videos based on field, select Video start time (later than observation start time).

6. In the Search for field, select 1.

7. Click OK and select the checkboxes in front of Automatic linking of video files in the Devices list and the device with the name you entered in step 3.

![Devices window](image)

**OBSERVE IN THE OBSERVER XT AND ANALYZE IN FACEReADER**

1. When your project is ready, check that your camera is connected to the PC and that it is turned on.

2. Start a new observation in The Observer XT. Classification in FaceReader is automatically started.

3. Score data in The Observer XT.

4. Stop the observation. Classification in FaceReader is automatically stopped. The Automatic Linking of Video Files window appears. Click OK when the video is found. It is automatically linked to the observation.

For more information on a project in The Observer XT, see The Observer XT Reference Manual.

It is not possible to use a single video stream in FaceReader and The Observer XT simultaneously.

**EXPORT FACEReADER LOG FILES**

1. Choose File > Export > [one of the options], to export the data for a single analysis, single participant, or entire project.'
2. If your The Observer XT license does not include the External data module – Choose **Save Observer log**. Select whether to export only the State log (see page 96) or also the Detailed log (see page 95). The log files are imported as observational data into The Observer XT (page 177).

When you export the results of a participant, or an entire project, an extra option **Save all analyses to a single Observer log** is available. This way you can import all analyses results at once into The Observer XT. The different participants and analyses are imported into separate observations. However, if you do so, do not use the option **Automatic linking of video files** (see step on page 175), but import the FaceReader videos afterwards into the observations.

Since FaceReader export files can be very large, we recommend to create a FaceReader export file for each analysis and import them one by one in The Observer XT.

- **If your The Observer XT license does include the External data module** – Choose **Save Observer Log** (see page 96) and, optionally, **Save Detailed log** (see page 95). The expression states are imported into The Observer XT as observational data (page 177) and the detailed log as external data (page 179).

**IMPORT FACEREADER LOG FILES AS OBSERVATIONAL DATA**

1. Start The Observer XT, open the appropriate project or create a new one. Choose **File > Import > Observational Data**.
2. In the Files of type field, select The Observer XT (*.odx) from the list.

3. Browse to your Observer log file and open it. The log files are by default in the folder: 
   C:\Users\Public\Documents\Noldus\FaceReader 7\Projects\[project name]\Logs.

   The data are imported into The Observer XT as a new observation named 'FaceReader data'.
   The State log is imported as behaviors and the Detailed log as numerical modifiers. That
   means that you can calculate statistics like, e.g., the mean and maximum classification value
for each of the facial expressions in The Observer XT. FaceReader independent variables are imported into The Observer XT with importing log files.

<table>
<thead>
<tr>
<th>Independent Variables</th>
<th>Video</th>
<th>User-defined</th>
<th>User-defined</th>
<th>System</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>Video File</td>
<td>Age</td>
<td>Gender</td>
<td>Start time</td>
</tr>
<tr>
<td>Description</td>
<td>File reference</td>
<td>Numerical</td>
<td>Text</td>
<td>Timestamp</td>
</tr>
<tr>
<td>Type</td>
<td>x</td>
<td>All values</td>
<td>Male, Female...</td>
<td>HH:mm:ss,ff</td>
</tr>
<tr>
<td>Format</td>
<td>Observation</td>
<td>Observation</td>
<td>Observation</td>
<td>Observation</td>
</tr>
<tr>
<td>Predetermined Values</td>
<td>External</td>
<td>Compulsory</td>
<td>Automatic</td>
<td></td>
</tr>
<tr>
<td>Scope</td>
<td>Observation</td>
<td>Observation</td>
<td>Observation</td>
<td></td>
</tr>
<tr>
<td>Value Update</td>
<td>Observation</td>
<td>Observation</td>
<td>Observation</td>
<td></td>
</tr>
</tbody>
</table>

![Image of Independent Variables](image)

Importing FaceReader data adds FaceReader elements to the coding scheme. However, these elements cannot be scored in a new observation in The Observer XT. Make sure the FaceReader elements do not already exist in the coding scheme of The Observer XT.

**IMPORT DETAILED LOGS AS EXTERNAL DATA**

To import FaceReader data as external data, your license for The Observer XT must include the External Data Module. To see if you have this module, open The Observer XT and choose Help > About The Observer XT > License info.
On the FaceReader installation USB stick you will find an import profile to import Detailed log files and a folder with the log file on which the import profile is based. Follow the steps below to copy both the import profile and the log file to your computer:

1. Browse to the Import Profile folder within the The Observer XT folder on the FaceReader installation USB stick.

2. Copy the import profile FaceReader 7 Detailed log as external data.eip to the default directory for import profiles:

   C:\ProgramData\Noldus\Common\Profiles.

3. Also copy the folder FaceReader 7 Detailed log as external data with the text file in it to this location.

You are now ready to import your log files into The Observer XT. To do so:

1. Choose File > Import > External Data.

2. In the Files of type field, select FaceReader 7 Detailed log as external data (*.txt) from the drop-down list.

3. Browse to the location on your computer where you stored your log file. The default location is:

   C:\Users\Public\Documents\Noldus\FaceReader 7\Projects\[project name]\Logs.

   The ProgramData folder is a hidden folder. To view this folder, click Start on the Windows task bar, select Control Panel and double-click Folder Options. Click the View tab and select the option Show hidden files, folders, and drives.
4. Select the observation into which you want to import the log file.

5. Select the appropriate log file and click **Open**. The data are imported into The Observer XT. In a similar way you can import data for Valence, and Head Orientation as external data. For this purpose you need to make an import profile. See Chapter 5 of The Observer XT Reference Manual on External Data for more information on how to do so, or contact Noldus Consultancy.

You can calculate the mean, minimum and maximum values for each facial expression. For more information see **Numerical Analysis** in the chapter **Calculate Statistics** of The Observer XT Reference Manual.
9.4 Visualize FaceReader data in The Observer XT

STATE EXPRESSION VALUES

State Expression values are imported into the observation as a separate event log. When you open the coding scheme, you will see that a behavioral group Dominant Expressions has been added with the six basic emotions, Contempt (optionally), the Neutral state plus Unknown and Not Analyzed as behaviors. Unknown is the emotion that is logged when FaceReader cannot find or model the face. See the figure below for a visualization of imported State log values.

<table>
<thead>
<tr>
<th>Relative Time (s)</th>
<th>2.00</th>
<th>4.00</th>
<th>6.00</th>
<th>8.00</th>
<th>10.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dominant Expressions</td>
<td>Neutral</td>
<td>Happy</td>
<td>Angry</td>
<td>Surprised</td>
<td>Unknown</td>
</tr>
</tbody>
</table>

EVENT MARKERS AND STIMULI

Event Markers and Stimuli are imported as separate event logs into the observation. They are added to the Coding Scheme as behavior groups Event Markers and Stimuli. See the figure below for an example of a visualization of imported Event Markers and Stimuli.

<table>
<thead>
<tr>
<th>Relative Time (s)</th>
<th>5.00</th>
<th>10.00</th>
<th>15.00</th>
<th>20.00</th>
<th>25.00</th>
<th>30.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Markers</td>
<td>Event 1</td>
<td>Event 2</td>
<td>No Event Marker</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stimuli</td>
<td>Stimulus 1</td>
<td>No Stimulus</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
FACIAL STATES AND GLOBAL GAZE DIRECTION

If you imported Facial States or Global Gaze Direction in The Observer XT, the new observation contains an extra Event File: Facial states. The behavioral group Facial States has been added to the coding scheme (‘Facial states’, a start-stop group) containing the states as State Events with modifiers. For example the State Left eye has the modifiers Open and Closed.

CONTINUOUS DATA

Continuous data are shown as a continuous graphs when you use FaceReader and The Observer XT 13 with N-Linx, or imported the detailed log as external data into The Observer XT. Your license for The Observer XT must include the External Data Module. The data for each facial expression, Valence, Arousal, Head orientation, and Heart rate (RPPG Module) are shown as continuous graphs.
ACTION UNIT INTENSITIES AS CONTINUOUS DATA

This option is only available if your FaceReader license includes the Action Units Module in FaceReader. In addition to this, you chose to export Action Units as continuous values in the Data export tab of the FaceReader Settings window (File > Settings).

You imported the detailed log into The Observer XT as external data. The Action Unit intensities are displayed as continuous graphs.

ACTION UNITS AS OBSERVATIONAL DATA

This option is only available if you have the Action Units Module in FaceReader. If you imported the detailed log as odx-file, or used FaceReader and The Observer XT with N-Linx, the Action Units are imported as a separate event log in the observation. The Coding Scheme contains a behavior group Action Units with the modifier group Activation intensity that
contains the intensities A to E. See the figure below for an example of a visualization. Click the + sign next to an Action Unit to visualize its intensity values (A, B,...).

**DETAILED LOG AS OBSERVATIONAL DATA**

If you imported both the State log and Detailed log into The Observer XT as odx-file, the new observation contains two Event Files: **State Expression Values** and **Detailed Expressions**. Two behavioral groups have been added to the coding scheme:

- **Dominant Expressions** – This behavioral group includes the six basic emotions, optionally contempt, the neutral state and 'Unknown' (the emotion that is logged when FaceReader cannot find or model the face) and 'Not analyzed'.

- **Detailed Values** – This behavioral group contains the behavior 'Detailed expression values' to which numerical modifier groups are attached: one for each emotion.

**VALENCE AND AROUSAL VALUES AS OBSERVATIONAL DATA**

If you saved Valence and Arousal values to the detailed log, and imported it into The Observer XT as odx-file, an Event log **Detailed Valence and Arousal** is imported. The behavior group **Detailed values** in the Coding scheme contains a State event **Valence and Arousal** with
numerical modifiers **Valence intensity** and **Arousal intensity**. You can carry out a Numerical analysis on the values.

**HEAD ORIENTATION AS OBSERVATIONAL DATA**

If you exported Head Orientation values to the detailed log, and imported it into The Observer XT as odx-file, an Event log Detailed Head orientation is imported. The behavior group Detailed values in the Coding scheme contains a State event **Head orientation** with the numerical modifiers **Y - Head orientation**, **X - Head orientation**, and **Z - Head orientation**. See the figure below for an example of a visualization of Head Orientation. You can carry out a numerical analysis on the Head Orientation values.

**DATA SELECTION AND STATISTICAL ANALYSIS**

You can use the imported data for data selection and statistical analysis. For example to select the time period over which ‘Stimulus 1’ was scored and to analyze the facial expressions over this time period. For more information on Data selection and statistical analysis, see The Observer XT Reference Manual.
9.5 The Observer XT sample projects with FaceReader data

On the FaceReader installation USB stick, in the folder The Observer XT\Sample Projects, you find two sample projects with FaceReader data for The Observer XT 13:

Child FaceReader XT 130

In this sample project the facial expressions of a child playing an online game are recorded in a media file and analyzed with FaceReader. Simultaneously, the Noldus screen capture device is used to create a media file of the monitor. With an event marker the time intervals during which the child looks away were marked in FaceReader. FaceReader data, with Action Units, Stimuli and Event markers, and video files were imported into The Observer XT.

For a full description of this sample project you can download the pdf-file “Description of sample projects of The Observer XT 13 - psychology usability ergonomics” from The Observer XT section of www.noldus.com/downloads. You need to register and login to be able to download this file.

FaceReader & The Observer XT 130

In this sample project two test participants test the taste of three fruit juices. The time periods after the test participants drank each fruit juice were marked with event markers. Each participant has been videotaped with two cameras, a webcam (for analysis in FaceReader) and a camcorder (to see what cup the participant takes). The FaceReader log files (Observer log and Detailed log), with Action Units, Stimuli and Event markers, have been imported into The Observer XT. The test participants’ behavior has been manually scored.

In the Data profile Intervals by fruit juices, the time intervals after the participants drank each fruit juice were separated using the imported FaceReader event markers Fruit juice 1, Fruit juice 2 and Fruit juice 3, respectively.

Under Behavior Analysis, you can find the archived Behavior Analysis State Expression Values per fruit juice, with an accompanying chart. For this Behavior analysis the data profile Intervals by fruit juices was used.

Video files

The associated media files are stored in the Media folder on the FaceReader installation USB stick. Before opening the sample projects, make sure to copy the media files to the default Video files folder of The Observer XT:

C:\Users\Public\Public Documents\Noldus\The Observer XT\Video Files.
Chapter 10 - Settings

10.1 General settings ................................................................. 190
10.2 Default Analysis Settings .................................................. 191
10.3 Analysis options ................................................................. 194
10.4 Identification ................................................................. 196
10.5 Data Export ................................................................. 198
10.6 Visualization ................................................................. 202
10.7 Reporting Client .......................................................... 203
10.8 Site license ................................................................. 204
10.9 Advanced options ....................................................... 205
This chapter lists the settings that you can make in FaceReader. Each numbered section in this chapter refers to one tab in the Settings window.

**To access all settings**

Choose File > Settings. Where necessary, additional information is available as tooltips, as shown in the figure below.

![Application Settings](image)

**To reset to default**

Click the **Reset to default** button to undo the changes you made in the settings and go back to the default settings.

Note that this resets all tabs to the default settings, not only the tab that is currently open.

![Warning](image)

Clicking **Reset to Default** will make **General** the default face model. If you are in the middle of a project in which you used the **General** face model, make sure that you re-select **General** for the new analyses. This way you do not mix data obtained with different versions of the general face model.
10.1 General settings

In the General settings you can view your license info and select the default location where FaceReader saves its projects.

**LICENSE**

*Your license number*

Shows the license number of the hardware key currently plugged in. This license determines the software modules that you can use. For details, see Modules on page 25 and FaceReader trial version on page 27.

**PROJECT EXPLORER**

*Open analysis on creation*

The analysis immediately opens once it is created. Default: selected.
PROJECT INFORMATION

Default project folder
The default location where the projects are stored. Click the button next to it to select another location.

Default: C:\Users\Public\Documents\Noldus\FaceReader 7\Projects.

10.2 Default Analysis Settings

ACTIVE FACE MODEL

Default face model
Choose the model that will be used by FaceReader for finding, modeling and classifying faces. Note that for a specific analysis you can use another model (see SETTINGS FOR THE CURRENT ANALYSIS on page 55).

You can choose between four models:

- General (default) — This model has been trained on a very diverse selection of images. The model works well under most circumstances for most people.

  Note that the General face model has changed since FaceReader 6.0. See page 17.
• **EastAsian** — Select this model to analyze East Asian faces, for instance, Chinese or Japanese faces.

• **Children** — Select this model if your test participants are children between the age of 3 and 10. The current FaceReader version is not well-trained for analysis of East-Asian children.

• **Elderly** — Select this model if your test participants are elderly from the age of 60. The model is suitable for all ethnicities.

**CALIBRATION**

*Continuous calibration*

With this option selected, FaceReader continuously calibrates during an analysis. See page 67 for more information about this method. Default: Not selected.

**CLASSIFICATION**

*Smoothen classification values*

With this option selected (default), classification values are transformed to obtain a smooth output signal. FaceReader smoothenes the classification values taking the duration between frames into account. When there is a large time gap between frames, FaceReader will consider the facial expressions detected in those frames as less correlated then when there is a small time gap and thus adapts the strength of the smoothing.

When this option is not selected, FaceReader gives the raw output data.

If you are analyzing a set of images, this option has no effect.

**ROTATION**

*Image rotation*

If you have images that are rotated, select one of the options from the drop-down list to make sure the faces are upright.

• None (default).
• 90° CW (clockwise).
• 180° CW.
• 270° CW.
VIDEO

Sample rate

This option applies when you perform video analysis.

By default, **Every frame** is selected. This means that all video frames are analyzed. To speed up the analysis, change the sample rate to analyze **Every 2nd frame** or **Every 3rd frame**.

Under normal circumstances, analyzing 10-15 frames per second is sufficient for an accurate analysis. This means that if your video contains 30 frames per second or more, you can safely decrease the sample rate of FaceReader without loss of accuracy and make the analysis two to three times faster.

*For camera analysis* — Video is sampled at 15 frames per second, also when your camera is set to a higher frame rate, and independent of what you choose under **Sample rate**.
10.3 Analysis options

**BATCH ANALYSIS**

*Skip already analyzed frames*

When you have selected this option, video fragments that were already analyzed will be skipped in batch analysis.

⚠️ Make sure you deselect this option when you carried out a camera analysis while simultaneously recording video and want to re-analyze these videos offline. Otherwise FaceReader will not analyze the frames that were already analyzed in the camera analysis.

**CAMERA ANALYSIS**

*Maximum Camera Analysis Duration*

Enter the maximum duration for analyses carried out with a live camera image.

Default: 1 hour.

Maximum: 2 hours.
OPTIONAL CLASSIFICATIONS

Contempt (experimental)
Select this option to classify contempt, which is an expression in which one corner of the lips is tightened and slightly raised.

- Treat Contempt as an Emotional State — Select this option to add contempt to the expression states in the State log and Timeline. This makes contempt mutually exclusive with the other expressions.

Facial States
Select this option to classify whether the test participant’s eyes are open or closed, his/her mouth is open or closed and the eyebrows are raised, neutral or lowered.

Action Unit Classification
With this option selected, FaceReader classifies Action Units. This option is only available when you have the Action Unit Module.

Global Gaze Direction
With this option selected, FaceReader classifies whether the test participant looks left, forward or right.

Estimate Heart Rate
With this option selected, FaceReader estimates the participant’s current heart rate by means of Photoplethysmography (see Chapter 8 The Remote PPG Module). This option is only available if your license includes the Remote PPG Module.

Person Identification
Select this option to enable the identification functionality.

Default settings
Facial States and Person Identification are selected. If you have the Action Unit Module, Action Unit Classification is selected as well. If you have the Remote PPG Module, Estimate Heart Rate is also selected.
10.4 Identification

**BASE Settings**

*Always find the best match*

If this option is selected, FaceReader identifies people by choosing from the list of persons that have been added to the system. With the option disabled, FaceReader also considers the possibility that the person in the (video) image is a new, unknown person.

Default: Selected.

**FineTune Settings**

*Avoid matches to recently added persons*

People tend to change in appearance only gradually. Someone who has been added to the database several years ago will have changed more than someone who has been added to the system an hour ago. This option allows you to change the extent to which this fact is being considered:

- 0 - not important.
- 1 - little important.
- 2 - medium important.
• 3 - important.
• 4 - very important.
• 5 - extremely important.
Default: 0 - not important

**Acceptable False Positive Rate**

FaceReader can make two types of identification errors. Firstly, an unknown person can be incorrectly identified as someone already in the data set (false positive). Secondly, a known person may not be recognized as such and may be considered as an unknown person (false negative). This option allows you to specify the false positive rate that you find acceptable. You can enter a value between 0.01 and 0.5. If you lower the value, the chance increases that FaceReader is not able to identify the person while it is present in the database (false negative). If you increase the value the chance increases that FaceReader finds a match with an incorrect person in the database (false positive).

Default: 0.08.

**Force matches when model quality is poor**

This option allows you to specify how important it is that FaceReader makes matches if the quality of the appearance model is poor:

0 - not important.
1 - little important.
2 - medium important.
3 - important.
4 - very important.
5 - extremely important.
Default: 3 - important.
10.5 Data Export

EXTERNAL COMMUNICATION (API AND STIMULUS PRESENTATION TOOL)

External communication is needed when you use the Stimulus Presentation Tool. Also, with FaceReader, an Application Programming Interface (API) is included. This API allows you to analyze images or videos with FaceReader on one computer and send the logged data to an application on another computer. Our support department (see Appendix B for contact information) can supply you with a detailed description of how to use the API functionality. They can also give you an example of an application that can receive FaceReader data.

Enable external control (API)
Select this option when you want to use the Stimulus Presentation Tool and in all cases when you want to use the API functionality.
Default: Not selected.

External connection port
Specify the port through which the external application or the Stimulus Presentation Tool can connect to FaceReader. External applications can also receive the logged data through this port.
Default: 9090.

Please note that if you use The Observer XT 13 or higher with FaceReader 7 or higher, you do not use this setting, but connect with the Noldus communication protocol N-Linx instead. See **EXTERNAL COMMUNICATION (N-LINX)** on page 199.

**Export with a fixed interval (5 frames per second)**

If this option is selected, an update to the Detailed log will be made every 200 milliseconds. If your computer cannot process the incoming images fast enough, frames will be skipped and a record with **MISSING** will be added to the Detailed log.

---

To be able to import the Detailed log as external data into The Observer XT, you must export with a fixed interval.

---

Default: Not selected.

**EXTERNAL COMMUNICATION (N-LINX)**

N-Linx is a network communication protocol that enables data transfer between Noldus software. Use N-Linx if you have The Observer XT 13, and want FaceReader to start and stop analyzing together with an observation in The Observer XT. The FaceReader are imported automatically into the observation and synchronized with the manual annotations. If you do not use N-Linx, or if you have an older version of The Observer XT, you must export the FaceReader data and import them into The Observer XT manually. Data import with N-Linx is easier and faster and ensures synchronization. For this functionality to work, your license for The Observer XT must include the External Data Module

**Enable N-Linx**

Select this option to start and stop FaceReader analysis together with an observation in The Observer XT and to import the data automatically in the observation.

**N-Linx server address**

Enter the IP address, or full computer name, of the computer with The Observer XT.

---

If connection with N-linx is established the text **N-Linx connected** appears in the bottom-right corner of your FaceReader window.
**EXPORT (DETAILED LOG, ODX, N-LINX AND API)**

By default, the detailed export file contains the classification output values for the six basic emotions, and the neutral state. Contempt is added if you selected it as optional classification in the *Analysis Options* tab (see page 195). Select one of the options below to add extra information to the log file.

---

**Action Units**

With this option selected, extra columns with the action units are added to the log file. Values are between A (trace) and E (max). This option is only available when you have the Action Unit Module.

**Export Action Units as Continuous Values**

With this option selected, the Action Unit categories A-E are exported as numerical values between 0 and 1 (see page 149 for an overview of the values). With this option selected, the Action Unit intensities can be imported into The Observer XT as external data (see *IMPORT DETAILED LOGS AS EXTERNAL DATA* on page 179).

**Subject Characteristics**

With this option selected, six extra columns are added to the Detailed log: Gender (male/female), Bearded, Mustache, Glasses, Age (an estimation of the test person’s age) and Ethnicity (Caucasian, Eastern Asian, African, South Asian or Other). For Bearded, Mustache and Glasses, a value between 0 and 1 is given.

**Facial States**

With this option selected, 5 extra columns are added to the Detailed log: Mouth (open or closed), Left-Eye (open or closed), Right-Eye (open or closed), Left-Eyebrow (raised, neutral or lowered) and Right-Eyebrow (raised, neutral or lowered).

**Global Gaze Direction**

With this option selected, one extra column is added to the Detailed log: Gaze (left, forward or right).

**Head Orientation**

With this option selected, three extra columns are added to the Detailed log: X - Head Orientation, Y - Head Orientation, and Z - Head Orientation (in degrees).

---

Please note that if your observations are long, writing a lot of extra information to the log can make your log files very large and can make the analysis slower.
Heart Rate

With this option selected, the extra column Heart Rate is added to the Detailed log. It contains the heart rate per sampled video frame estimated with Remote Photoplethysmography (see Chapter 8 The Remote PPG Module).

Identity

If the identification functionality is enabled, you can select this option to add the name of the test person to the log file.

2D Landmarks

With this option selected the X-Y-coordinates of the blue dots around the eye, nose and mouth of the mesh (shown in light blue in the picture below) are added to the log file. The log file has 98 numbers in the column Landmarks. The first two numbers are the X- and Y-coordinates of landmark 1, the third and fourth are the coordinates of landmark 2 etc.

The following landmarks are present in the detailed log:

- 1-5 – left eyebrow
- 6-10 – right eyebrow
- 11-12 – corners left eye
- 13-14 – corners right eye
- 15-17 – nose
- 18-49 – mouth

The X,Y-coordinates are relative to the upper left corner of the image.
**Image Quality**

The image quality is indicated by a value between 0 and 1.

**Valence and Arousal**

If you select this option the valence and arousal are added to the log file. Valence indicates whether the facial expressions are positive or negative and to what degree. Arousal indicates the degree of activity.

### 10.6 Visualization

**VIDEO**

*Repeat video (for demonstrations only)*

This option is for demonstration purposes only. If you select this option your video is played continuously.

Default: Not selected.
10.7 Reporting Client

DISPLAY STYLE

Always on top
With this option selected the Reporting Client window is displayed on top of the FaceReader screen. For details, see page 89.
Default: Selected.

TIMING

Duration
This option allows you to set the duration of the running average that is used when displaying the Valence Pie.
Default: 02:00 minutes.
Chapter 10 - Settings

10.8 Site license

SITE LICENSE

If you have a batch of FaceReader licenses for on site use. In this window you can change Site License connection settings, for example if Site License Services was moved to another computer or if there are multiple computers with Site License Services.

*Use Site License Services for authentication.*
Select this option to use Site Licenses.

*Services address*
Enter the IP address or computer name of the computer with Site License Services.

*Services port*
Leave the default port 5672. Ask your system administrator for assistance if this port is already in use by another program.

![Settings window showing Site License settings]

*More info?*
For more information on using FaceReader with site licenses, see the Site License Manager Reference Manual.
10.9 Advanced options

We recommend that you use the advanced settings only at the advice of Noldus, or if you have experience with face recognition algorithms.

To view the Advanced options, select Show advanced options in the Settings window. Then click Advanced.

![Advanced settings presets](image)

**ADVANCED SETTINGS PRESETS**

**Preset for face-finding settings**

Changing this preset will change the Size of Interest (the size of the frame that moves over the video image searching for the face, see page 207). By default, FaceReader starts searching for the face with a frame size that is 11% of the video image size (minimum face fraction = 0.11). It searches the whole video image and if it does not find the face, it increases the frame size with 10% (face size scaling factor = 1.10) and searches again. FaceReader increases the frame size 10 times (number of face scaling steps = 10) and goes on searching until the face fraction is 0.30 (maximum face fraction). Changing one of the Size of Interest settings, sets the Preset for face finding settings to [custom].

Make sure that the Size of Interest is comparable to the size of the face in the video image. Choose one of the following options:
• **Find all faces (slow)** — Select this option if the default setting does not work properly or if you want to include faces from people who sit a bit far from the camera. With this option selected, the minimum face fraction is 0.08, the maximum face fraction 0.30, the face size scaling factor 1.10 and the number of face scaling steps 13. Because FaceReader starts searching with a smaller frame, it takes longer to search the whole video image than with the default setting.

• **Find medium size faces** — This is the default setting which normally works fine when the test person sits at a normal distance from the camera (0.5 - 2 m). With this option selected, the minimum face fraction is 0.11, the maximum face fraction 0.30, the face size scaling factor 1.10 and the number of face scaling steps 10.

• **Find large faces only (fast)** — Select this option if speed of classification is very important and you only have close-up images of your test persons. With this option selected, the minimum face fraction is 0.20, the maximum face fraction is 0.30, the face size scaling factor is 1.10 and the number of face scaling steps is 4.

If you change the preset for face-finding settings, this also changes the Minimum face fraction (see **SIZE OF INTEREST** on page 207). This is done in the following way:

- **Find all faces (slow)** -> Minimum face fraction = 0.08
- **Find medium-size faces** -> Minimum face fraction = 0.11
- **Find large faces only (fast)** -> Minimum face fraction = 0.20
- **Default setting** — Find medium size faces.

**Preset for face-modeling settings**

Changing this preset will change the **Number of model fit iterations** (see page 207). You can also change the **Number of model fit iterations** directly. If you do so, the **Preset for face modeling settings** is set to [custom].

- **Maximum accuracy (slow)** — This sets the **Number of model fit iterations** to 12.
- **Medium accuracy** — With this option selected, the **Number of model fit iterations** is 8.
- **Low accuracy (fast)** — This option sets the **Number of model fit iterations** to 5.

Default: Medium accuracy.
**ENGINE**

*Use deep face engine*

Deselect this option if you do not want to use the Deep face classification (see page 12). You may want to do so to speed up the analysis. Please note that the analysis is more accurate when the deep face classification is switched on.

Default setting — Option selected.

**FACE MODELING**

*Number of model fit iterations*

Number of updates of the appearance model. FaceReader starts with an "average" face and updates this in a number of steps (iterations) so that it resembles the face of the test person. Higher values give a more accurate fit. You can set the Number of model fit iterations by clicking the up and down arrows or by changing the Preset for face modeling settings (see page 206).

Accepted values: 1 - 20. Default: 8.

*Maximum model error*

Error measure used to determine if the face model is valid. Increasing this value will lead to more successfully fitted images, but the quality of the results might be less.

Accepted values: 0.1 - 1.00. Default: 0.60.

**SIZE OF INTEREST**

You can set the Size of Interest either by clicking the up and down arrows or by changing the Preset for face finding settings (see page 205).

*Minimum face fraction*

Minimum fraction of the face surface relative to the entire image surface.

Accepted values: 0.01 - 1. Default: 0.11.

*Maximum face fraction*

Maximum fraction of the face surface relative to the entire image surface.

Accepted values: 0.01 - 1. Default: 0.80.
**Face size scaling factor**

Factor by which the face surface is increased between the minimum and maximum face size.

Accepted values: 1.01 - 2. Default: 1.10.
## A.1 Video formats

### SUPPORTED VIDEO FORMATS

The minimum dimensions of your video should be about 640 x 480 pixels (120 x 120 minimally for the face area). For FaceReader to work at a reasonable speed, the maximum dimensions should not be greater than about 2000 x 2000 pixels. FaceReader supports the following video formats:

<table>
<thead>
<tr>
<th>Container</th>
<th>Code</th>
<th>Name/Encoder</th>
</tr>
</thead>
<tbody>
<tr>
<td>mpg</td>
<td>mpg1</td>
<td>MPEG-1 Part 2</td>
</tr>
<tr>
<td>mpg</td>
<td>mpg2</td>
<td>MPEG-2</td>
</tr>
<tr>
<td>mpg</td>
<td>H264</td>
<td>H.264/ MPEG-4</td>
</tr>
<tr>
<td>vob (DVD)</td>
<td>mpg2</td>
<td>MPEG-2</td>
</tr>
<tr>
<td>mp4</td>
<td>mp4v</td>
<td>MPEG-4 Video</td>
</tr>
<tr>
<td>mov</td>
<td>mp4v</td>
<td>MPEG-4 Quicktime</td>
</tr>
<tr>
<td>avi</td>
<td>XVID</td>
<td>XviD ISO MPEG-4</td>
</tr>
<tr>
<td>avi</td>
<td>XVID</td>
<td>XviD 1.1.0 Final</td>
</tr>
<tr>
<td>avi</td>
<td>DIB (_RGB)</td>
<td>BI_RGB Raw Bitmap</td>
</tr>
<tr>
<td>avi</td>
<td>DIV3</td>
<td>DivX 3 Low-Motion</td>
</tr>
<tr>
<td>avi</td>
<td>DIV5</td>
<td>DivX 5.x/6.x</td>
</tr>
<tr>
<td>avi</td>
<td>DIVX</td>
<td>DivX 4</td>
</tr>
<tr>
<td>avi</td>
<td>dvsd</td>
<td>DVC/DV Video</td>
</tr>
<tr>
<td>avi</td>
<td>DX50</td>
<td>DivX 6.0.0</td>
</tr>
<tr>
<td>avi</td>
<td>DX50</td>
<td>DivX 5.x</td>
</tr>
<tr>
<td>avi</td>
<td>CRAM</td>
<td>Microsoft Video 1</td>
</tr>
<tr>
<td>avi</td>
<td>cvid</td>
<td>Cinepak</td>
</tr>
<tr>
<td>avi</td>
<td>IV32</td>
<td>Indeo 3.x</td>
</tr>
<tr>
<td>avi</td>
<td>MJPG</td>
<td>Motion JPEG</td>
</tr>
<tr>
<td>avi</td>
<td>MP42</td>
<td>S-MPEG 4 version 2</td>
</tr>
<tr>
<td>avi</td>
<td>WMV3</td>
<td>WMP v9 (VC-1 Simple/Main)</td>
</tr>
<tr>
<td>asf (.wmv)</td>
<td>WMV1</td>
<td>WMP v7</td>
</tr>
<tr>
<td>asf (.wmv)</td>
<td>WMV2</td>
<td>WMP v8</td>
</tr>
<tr>
<td>asf (.wmv)</td>
<td>WMV3</td>
<td>WMP v9 (VC-1 Simple/Main)</td>
</tr>
<tr>
<td>asf</td>
<td>MP43</td>
<td>S-Mpeg 4 version 3</td>
</tr>
<tr>
<td>3gp</td>
<td>s263</td>
<td>ITU H.263 video (3GPP)</td>
</tr>
</tbody>
</table>

If you are not sure what the format of your video files is, you can use a program like GSpot to find this out. Browse to www.headbands.com/gspot to download GSpot (free of charge).
## OTHER VIDEO FORMATS

For a number of other formats, codecs are included, but these formats have not been tested. We can, therefore, not guarantee that they work.

<table>
<thead>
<tr>
<th>Container</th>
<th>Code</th>
<th>Name/Encoder</th>
</tr>
</thead>
<tbody>
<tr>
<td>avi</td>
<td>DIV1, DIV2, mp41, MPG4, MPG3</td>
<td>Divx (1,2,3)</td>
</tr>
<tr>
<td>avi</td>
<td>DIV4, DIV6, col1, col0, 3ivd</td>
<td>DivX 4, 5, 6, 3ivx D4, MPEG-4</td>
</tr>
<tr>
<td>avi</td>
<td>h261</td>
<td>H.261</td>
</tr>
<tr>
<td>avi</td>
<td>h262</td>
<td>H.262</td>
</tr>
<tr>
<td>avi</td>
<td>h263</td>
<td>H.263/H.263i</td>
</tr>
<tr>
<td>avi</td>
<td>h264, s264, AVC1, DAVC, H264, X264, VSSH</td>
<td></td>
</tr>
<tr>
<td>avi</td>
<td>IV31</td>
<td>Indeo Video 3</td>
</tr>
<tr>
<td>avi</td>
<td>mp45, m4s2, fmp4, 3iv2, smp4</td>
<td>MPEG-4 Part 2 (AVP), Xvid</td>
</tr>
<tr>
<td>avi</td>
<td>SVQ 1</td>
<td>Sorenson 1 (Quicktime)</td>
</tr>
<tr>
<td>avi</td>
<td>SVQ 3</td>
<td>Sorenson 3 (Quicktime)</td>
</tr>
<tr>
<td>avi</td>
<td>VP31, VP30, VP3</td>
<td>On2 VP3</td>
</tr>
<tr>
<td>avi</td>
<td>VP50, VP5, VP51</td>
<td>On2 VP5</td>
</tr>
<tr>
<td>avi</td>
<td>VP60, VP61, VP62, VP6F, VP6A</td>
<td>On2 VP6 (used by FLV)</td>
</tr>
<tr>
<td>flv</td>
<td>FSV1</td>
<td>Flash Screen Video</td>
</tr>
<tr>
<td>mpg</td>
<td>mp2v, mpg2, vcr2, hdv1, hdv2, hdv3, mx<em>n, mx</em>p</td>
<td>MPEG-2 Part 2</td>
</tr>
<tr>
<td>mpg</td>
<td>mpeg, mp1v, PIM1</td>
<td>MPEG-1 Part 2</td>
</tr>
<tr>
<td>rm</td>
<td>RV10, RV13, RV20</td>
<td>Real Video 1.0, 1.3, 2.0</td>
</tr>
<tr>
<td>wmv</td>
<td>wmv1, wmv2</td>
<td>WMV 1/2 (7/8)</td>
</tr>
<tr>
<td>wmv</td>
<td>wmv3, wvc1, wmv3</td>
<td>WMV 3/WMV-9/VC-1*</td>
</tr>
</tbody>
</table>

* Not all profiles are supported.

Video formats that are not supported (codecs are not included and installing the codecs yourself will not work):

<table>
<thead>
<tr>
<th>Container</th>
<th>Code</th>
<th>Name/Encoder</th>
</tr>
</thead>
<tbody>
<tr>
<td>avi</td>
<td>IV50, IV51</td>
<td>Indeo 5.x</td>
</tr>
<tr>
<td>avi</td>
<td>tscct</td>
<td>TechSmith Screen Capture</td>
</tr>
<tr>
<td>avi</td>
<td>IV41</td>
<td>Indeo 4.x</td>
</tr>
<tr>
<td>avi</td>
<td>I263</td>
<td>H.263</td>
</tr>
<tr>
<td>avi</td>
<td>cvid(_RGB)</td>
<td>BI_RGB Raw Bitmap</td>
</tr>
<tr>
<td>avi</td>
<td>(_RGB)</td>
<td>BI_RGB Raw Bitmap (8bit)</td>
</tr>
<tr>
<td>mp4</td>
<td>avc1</td>
<td>MPEG-4 AVC</td>
</tr>
<tr>
<td>mov</td>
<td>3iv1</td>
<td>3ivx (MPEG-4 based)</td>
</tr>
<tr>
<td>mov</td>
<td>svq3</td>
<td>Unknown</td>
</tr>
<tr>
<td>mov</td>
<td>avc1</td>
<td>MPEG-4 AVC</td>
</tr>
</tbody>
</table>
**PROJECT WIZARD**

The following video file extensions can be used in combination with the project wizard:

- .mpg
- .mpeg
- .avi
- .wmv
- .mov
- .asf
- .3gp
- .vob
- .mp4
- .mkv
- .flv

**VIDEO LENGTH, DURATION AND NUMBER OF SAMPLES**

For some video formats, FaceReader may have a slightly different calculation of the video length, duration, or number of samples than other video programs, like, for example, Windows Media Player. This is the case in the following cases:

- **The frame information in the video is incorrect** – Somehow the information on video duration, number of video frames and video frame rate do not agree. If this is the case, FaceReader calculates the frame rate from the number of frames and the duration of the video file. This may slightly differ from how other programs calculate this information.

- **The video frame rate varies** – If this is the case, FaceReader calculates the average frame rate over the entire video.

If the way FaceReader calculates the video information leads to analysis problems, convert the videos with a converter based on FFMPEG. For example, use WinFF ([http://winff.org/html_new/](http://winff.org/html_new/))
A.2 Image formats

**SUPPORTED IMAGE FORMATS**

FaceReader supports the following image formats:

- JPG
- BMP
- GIF
- TIF
- PNG

Animated GIFs are not supported, FaceReader uses the first frame of the animated GIF.

The minimum dimensions of your images should be about 640 x 480 pixels (120 x 120 minimally for the face area). For FaceReader to work at a reasonable speed, the maximum dimensions should not be greater than about 2000 x 2000 pixels.

**PROJECT WIZARD**

The following image file formats can be used in combination with the project wizard:

- .bmp
- .jpg
- .jpeg
- .jpe
- .jfif
- .png
- .gif
- .tiff
Appendix B

Technical support

B.1 Reference manual ................................................................. 215
B.2 Help menu ......................................................................... 215
B.3 Help desk ......................................................................... 215
B.4 NoldusCare ..................................................................... 216
B.1 Reference manual

To open the Reference Manual, press F1 or choose Help > Help. There is also a shortcut to FaceReader documentation on the desktop and in the Start menu of the computer with FaceReader. Use the Search function to find information on the topic you are looking for.

B.2 Help menu

FaceReader’s Help menu contains the following options:

- **Help** – Opens the FaceReader Reference Manual.
- **FaceReader Online** – This is a link to the FaceReader section on the Noldus website.
- **FaceReader Support** – This is a link to the Help desk section on the Noldus website.
- **Report an Issue** — You are forwarded to an online form where you can report your issue. Noldus Support will contact you after they received the form.
- **Upgrade** – If you click this option, the Upgrade Key dialog box opens. The dialog box contains your license number. It opens automatically when you start FaceReader 7 for the first time after installation and FaceReader detects that you have a hardware key for an earlier version.
- **About** – Choose this option to see details of exactly which version of FaceReader you are using and the serial number of your software.

B.3 Help desk

If you have any problems, questions, remarks or comments, please let us know. You can contact us via our web site (www.noldus.com) and fill out a Support Request Form (preferred), or phone. We offer 24 hour support via several help desks in different time zones.

Check the Reference manual before contacting our support department. Press F1 to open the manual, then use the search function to find the topic you are having problems with.

Before you contact Technical Support, please have the version number and license number of your copy of FaceReader available. To find these numbers, choose Help > About.
Please refer to the About Noldus - Contact us section on our web site (www.noldus.com) for other contact information.

B.4 NoldusCare

Your FaceReader license includes one year NoldusCare. NoldusCare extends the standard service you are entitled to and provides peace of mind at reasonable cost. Please look on our web site (noldus.com/support-center/nolduscare) for more information. We also recommend a training upon installation of FaceReader.
Appendix C

License Agreement

1. LICENSE. Noldus Information Technology b.v. (‘Noldus’) grants you a non-exclusive license to use the software and accompanying documentation (collectively called the ‘Software’ in this agreement) in accordance with the following terms. Noldus retains title and all ownership rights to the Software. Noldus will allow you to make back-up copies of the Software, always including copyright notices, provided that these copies are only for your own use. Noldus grants you the right to transfer this license and the Software to another party, provided that (a) the other party accepts all terms of this agreement, (b) all copies of the software are transferred and you discontinue use of the Software after transferring, (c) Noldus is promptly notified of the license number of the Software and the name and address of the other party, and (d) Noldus is not required to supply new media.

You may not sublicense, assign or transfer the license or the Software except as expressly provided in this agreement. Any attempt otherwise to sublicense, assign or transfer any of the rights, duties or obligations hereunder is void.

2. TERM AND TERMINATION. Failure to comply with any of these terms will terminate this agreement and your right to use the Software. You may also choose to terminate the agreement at any time. Upon termination of this agreement, you must immediately destroy the Software and all copies of it.

3. LIMITED WARRANTY. Noldus warrants that the media on which the Software is furnished are free of defects in workmanship and material under normal use, and that the Software will perform substantially in accordance with the specifications set forth in the documentation provided with the Software, for a period of ninety (90) days from the date of purchase by you. During the 90-day warranty period, if the Software does not perform as warranted, Noldus at its sole option will (a) provide, without charge, a replacement of the media, (b) provide, without charge, corrected Software, (c) replace, without charge, Software with a functionally similar program, or (d) refund the fees paid for licensing the Software. These are your sole and exclusive remedies for any breach of warranty. Do not return any product until you have called Noldus or its supplier and obtained a return authorization number.
4. DISCLAIMER. Software is licensed 'as is' without warranty as to its performance. Except for the limited warranty provided above, there are no warranties expressed or implied, including but not limited to implied warranties of merchantability or fitness for a particular purpose, and all such warranties are expressly disclaimed. In no event shall Noldus or its suppliers be responsible for any indirect or consequential damage or lost profits, even if Noldus and its suppliers had been advised of the possibility of such damage.

5. MISCELLANEOUS. The Software and accompanying documentation are protected by both Dutch copyright law and international copyright treaty provisions. This agreement will be governed by the laws of The Netherlands.

OTHER SOFTWARE. FaceReader 7 contains the following components for which additional agreements must be agreed upon:

6a Open Source Computer Vision Library
   License Agreement For Open Source Computer Vision Library (3-clause BSD License)
   Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
   - Redistribution's of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
   - Redistribution's in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
   - Neither the names of the copyright holders nor the names of the contributors may not be used to endorse or promote products derived from this software without specific prior written permission.
   This software is provided by the copyright holders and contributors "as is" and any express or implied warranties, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are disclaimed. In no event shall the Intel Corporation or contributors be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage.

b 6b. Emgu CV
   FaceReader contains Emgu CV components under a commercial license.

c FFmpeg
   FFmpeg is free software: you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation, either version 3 of the License, or (at your option) any later version.
The full text of the GNU Lesser General Public License can be found at:
Source code is available at http://ffmpeg.mplayerhq.hu/.

d  ZedGraph
ZedGraph is free software: you can redistribute it and/or modify it under the terms of
the GNU Lesser General Public License as published by the Free Software Foundation,
either version 3 of the License, or (at your option) any later version.
The full text of the GNU Lesser General Public License can be found at:
Source code is available at http://sourceforge.net/projects/zedgraph/.

e  NAudio
NAudio is an open source .NET audio and MIDI library, distributed under the terms of
the Microsoft Public License (Ms-PL).
The full text of the Microsoft Public License (Ms-PL) can be found at:
Source code is available at http://naudio.codeplex.com/.

f  Caffe
All contributions by the University of California:
Copyright (c) 2014, 2015, The Regents of the University of California (Regents). All
rights reserved.
All other contributions:
Copyright (c) 2014, 2015, the respective contributors.
All rights reserved.
Caffe uses a shared copyright model: each contributor holds copyright over their
contributions to Caffe. The project versioning records all such contribution and
copyright details. If a contributor wants to further mark their specific copyright on a
particular contribution, they should indicate their copyright solely in the commit
message of the change when it is committed.

LICENSE
Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
   conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
   conditions and the following disclaimer in the documentation and/or other materials
   provided with the distribution.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Noldus Information Technology b.v., P.O. Box 268, 6700 AG Wageningen, The Netherlands. For contact details, see www.noldus.com.
— Numerics
  2D Landmarks – 201

— A
  Absolute statistics – 123, 124, 130
  Acceptable false positive rate – 197
  Action Unit Module – 25
  Action units – 144, 146, 184, 195
    enabling – 145
    exporting – 148, 200
    exporting intensities as continuous values – 200
    in output – 146
    states – 147
    visualizing during analysis – 146
  Active Appearance Model – 12
  Active face model – 56, 191
  Adding a person to the database – 76
  Adding event markers – 117
  Adding images – 40
  Adding independent variables – 119
  Adding live video – 40
  Adding participant groups – 121
  Adding stimuli – 100
  Adding test participants – 39
  Adding video files – 40
  Add-on modules – 25
  Advanced options – 205
  Advanced settings – 205
  Advanced settings presets – 205
  Always find the best match – 196

Analysis
  open automatically – 190
  Analysis advisor for project analysis – 136
  Analysis details – 59
  Analysis options – 194
  Analysis speed – 60
  Analysis visualization – 71
    action units – 146
    facial states – 73
    framing – 71
    global gaze direction – 73
    mesh – 72
    texture model – 72
  Analyzed frames – 59
  Analyzing faces – 56
  Application programming interface (API) – 198
    enabling – 198
  Applications of FaceReader – 11
  Arousal – 84
    export – 202
  Asian people – 55
  Autosave – 60
  Average expression intensities
    for a calibrated stimulus relative to another stimulus – 141
    for a participant group relative to another group – 138
    for a stimulus relative to another stimulus – 138
    per participant – 136
    per participant group – 136
    per stimulus – 136
  Average frame rate – 59
Avoid matches to recently added persons – 196

— B
Backup – 37
Batch analysis – 194
autosave – 60
skip already analyzed frames – 194
Before you install – 22
Best match – 196
BMP – 213

— C
Calibration – 54
continuous calibration – 65, 192
equation – 64, 65
participant calibration – 64
with project analysis module – 99
Camera
adjusting – 29
IP – 28
USB – 28
Camera analysis
default camera – 41
frame rate – 41
maximum duration – 188, 194
set default camera – 43
with IP camera – 42
Camera drivers – 24
Children – 55, 192
Chinese people – 55, 192
Clear results – 58
Comparing participant groups – 122
Contempt – 61
enabling – 195
treat as emotional state – 195
Continuous calibration – 65, 192
Creating a new project – 36

— D
Data export – 93
settings – 198
Deep face classification – 16, 207
Default camera – 43
Default settings – 54
Deleting a participant – 40
Deleting an analysis – 43
Detailed log – 95, 179, 199
Device drivers – 22
DivX – 109, 210, 211
DV-AVI – 109

— E
East Asian people – 55, 192
Elderly people – 55, 192
Ethnicity – 74
Event markers – 99, 118
copying to other analyses – 118
creating – 117
deleting – 118
editing – 118
editing scored event markers – 118
scoring – 118
Exporting
analysis results – 93
to The Observer XT – 93
with fixed interval – 199
Expression intensity – 78
Expression summary – 79
for participant groups and stimuli – 142

— F
Face finding – 12
Face finding settings – 205
Face model – 54, 191
Face modeling – 12
number of model fit iterations – 207
preset for face-modeling settings – 206
settings – 206, 207
Face size – 206
scaling factor – 208
FaceReader
Action Unit Module – 144
limitations – 15
modules – 25
Project Analysis Module – 25
reference manual – 215
Remote PPG Module – 26
trial version – 27
working with projects – 35
working without a mouse – 16

FaceReader and
The Observer XT
– 159
External Data Module – 161
visualizing data – 182
with The Observer XT 12.5 or lower – 160, 173
with The Observer XT 13 – 160
FaceReader IP – 106, 107
FaceReader license
with hardware key – 35
with site licenses – 35
FaceReader Port – 106, 107
FaceReader’s output
action unit intensity – 146
action unit states – 147
analysis visualization – 71
arousal line chart – 84
circumplex model of affect – 80
expression summary – 79
expressions line chart – 86
graphs – 78
head orientation chart – 87
heart rate – 155
heart rate line chart – 156
identity – 75
smiley – 91
tables – 74
timeline – 82
valence line chart – 83
valence monitor – 91
valence pie – 92
Facial Action Coding
System – 25, 144, 146, 184, 195
Facial states – 11, 73, 74, 82, 195, 200
export – 200
FACS – 25, 144, 146, 184, 195
Find all faces – 206
Find large size faces – 206
Find medium size faces – 206
Firewall exceptions – 114
FIT_FAILED – 95
Fixed interval – 199
Force matches when model quality is
poor – 197
Frame rate – 41, 59, 193

— G
Gaze – 82
Gaze direction – 62
General face model – 55, 191
General settings – 190
GIF – 213
Global gaze direction – 11, 62, 73, 195, 200
export – 200
Graphical output – 69
Graphics card – 20

— H
H.264 – 109, 211
Hardware key – 27
upgrading – 26
Head orientation – 11, 87, 200
export – 200
Heart rate – 155
analysis – 156
export file – 201
line chart – 156
settings – 195
Help menu – 215
How does FaceReader work? – 12

— I
Identifying – 195
adding a person to the database – 76
enabling – 63, 195
export identity – 201
monitoring the identity of a person – 77
settings – 196
Identity – 75
Image formats – 213
for project wizard – 213
Import profile – 180
Importing FaceReader log files
detailed logs as external data – 179
with N-Linx – 160
Inbound Rule – 112, 115
Independent variables – 98
creating – 119
default – 40
deleting – 120
editing – 120
scoring – 120
Individual calibration – 64, 65
Installation – 19
windows 10 – 23
Intensity state – 82
adjust criteria – 79
Internet connection – 21
IP camera – 28

— J
Japanese people – 55, 192
JPG – 213

— L
Lag – 116
License
hardware key – 35
site licenses – 35
upgrading – 26
upgrading site licenses – 27
Lighting setup – 33
Location of log files – 93
Log – 93
default filename – 94
Loop video – 202

— M
Marking episodes – 99
Maximum model error – 207
Media file – 209
Mesh – 72
Microsoft LifeCam Studio – 24
Minimum face fraction – 207
MISSING – 95, 199
Model
children – 55, 192
east asian – 55, 192
elderly – 55, 192
general – 55, 191
Modules – 25
Action Unit Module – 25, 143
Project Analysis Module – 25, 97
Remote PPG Module – 26, 152
Monitoring the identity of a
person – 75, 77
Mouse emulator – 16
MP4 – 109
MPEG – 210
MPEG-1 – 109, 211
MPEG-2 – 109, 210, 211
MPEG-4 – 109, 210, 211

— N
NetTime – 112
Network time protocol – 112
N-Linx – 17, 199
NTP – 112
Number of face scaling steps – 205
Number of model fit iterations – 207
Numerical group analysis – 122
export results – 127
graphs – 128
relative statistics – 127
Numerical output – 69

— O
Observer XT log – 96
Offset – 116
Operating system – 20
Optional classifications
  action units – 195
  contempt – 195
  facial states – 195
  global gaze direction – 195
  person identification – 195
Outbound Rule – 115

— P

Participant groups – 98, 121
  based on independent variables – 121
  comparing – 122
  creating – 121
  deleting – 122
  editing – 122
  manual – 122
  significant differences – 124
Percentile – 128
Person identification – 75, 195
Photoplethysmography – 153, 155
Pictures – 213
PNG – 213
Preset for face-finding settings – 205
Preset for face-modeling settings – 206
Processor – 20
Professional photo light – 33
Project – 35
  backup – 37
  creating a new project – 36
  explorer – 38
  saving a project – 37
  with wizard – 44
Project analysis module – 25
  analysis advisor – 136
  relative statistics – 127

— Q

Quartile – 128

— R

Reference manual – 215
Relative statistics – 125, 127, 130
  compared to what? – 125
  numerical group analysis – 127
  temporal group analysis – 127
Remaining analysis time – 59
Remote access – 198
Remote PPG – 153
Repeat PPG Module – 26, 152, 154
Repeat video – 202
Reporting client
  smiley – 91
  valence monitor – 91
  valence pie – 92
Reset analysis window layout – 70
Rotation – 54, 192
RPPG – 153, 155
Running average – 203

— S

Sample projects – 187
Sample rate – 43, 54, 193
Saving a project – 37
Saving analysis results – 93
Scoring event markers – 118
Scoring independent variables – 120
Scoring stimuli – 101
Selecting data
  stimuli and event markers – 124
Selecting windows – 69
Setting up the hardware
  adjusting your camera – 29
  camera setup – 29
  choosing your camera – 28
  lighting setup – 33
Settings
  advanced – 205
  analysis options – 194
  data export settings – 198
  default and specific – 54
  face model settings – 191
  for all new analyses – 54
  for current analysis – 55
  general settings – 190
  identification settings – 196
  reporting client settings – 203
  site license settings – 204
  visualization setting – 202
Site licenses – 16, 204
Smiley – 91
Smoothing – 54, 192
SNTP – 114
Source details – 59
Specifications – 20
Speeding up analysis – 60, 193
State log – 96
Stimuli – 99
  copying to other analyses – 102
  creating – 100
  deleting – 104
  editing – 101
  editing scored stimuli – 103
  in a test – 104
  restrictions – 103
  scoring – 101
  significant differences – 124
Stimulus Presentation Tool – 104
  computers – 106
  defining a test – 108
  installing – 105
  running a test – 110
  settings – 198
Subject characteristics – 74, 200
Support – 214
Support request form – 215
Supported cameras – 28
Synchronizing computers – 112
System requirements – 20

— T
Technical support – 214
Temporal group analysis – 130
  absolute – 130
  graphs – 131
  relative – 130
  relative statistics – 127
Test – 104
  defining – 108
  running – 110
The Observer XT
  importing detailed log as external data – 179, 199
  log – 96
  version 12.5 or lower – 173
  version 13 – 160
  with N-Linx – 160
TIF – 213
Timeline – 82
Trial version – 27
T-test – 124

— U
Upgrade
  FaceReader – 26
  FaceReader license – 26
  FaceReader project – 26
  site licenses – 27
  Stimulus Presentation Tool – 105
Upgrading – 26

— V
Valence – 83
  export – 202
  monitor – 91
  pie – 92
Video
  batch analysis – 194
  files – 209
  formats – 210
  formats for project wizard – 213
  frame rate – 43, 59, 193, 212
  repeat video – 202
Viola Jones cascaded classifier algorithm – 12
Visualization options – 71, 131
  action units – 146
  facial states – 73
  framing – 71
  global gaze direction – 73
  mesh – 72
  texture model – 72
Visualization settings – 202
Visualizing stimulus video with test participant video – 130
VOB – 109

— W
  Webcam – 28
  What’s new in FaceReader 7? – 16
  Windows 10 64 bit – 17, 20
  Windows 7 64 bit – 20
  WMV – 211
  Working with projects – 35
  Working without a mouse – 16

— X
  XviD – 210